Home Forums Weaver Xtreme Theme WordPress Warning About Using Weaver Xtreme Theme Support

Topic Resolution: Answered
Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #71534
    Answered
    arctexas
    Participant

    Hello,

    I went to setup one of my new clients using Weaver Xtreme and when I went to download the Theme support plugin, I received this message

    “This plugin hasn’t been tested with the latest 3 major releases of WordPress. It may no longer be maintained or supported and may have compatibility issues when used with more recent versions of WordPress.”

    Thank  you

     

    #71535
    Best Answer
    scrambler
    Moderator

    This reply has been accepted as the best answer.

    It is fine, this is just because there has not been a new version in a while, the plugin is fine with the latest WP

    #71536
    Weaver
    Keymaster

    There will be a new release soon. Both Weaver Xtreme and the Theme Support plugin are being converted to require at least PHP 7.1 which adds some new PHP language features that greatly enhance security of PHP software.

    There are few, if any, hosts that still provide or support PHP 5.4, and Weaver is stopping support of 5.4. I frankly do not understand why WP still requires only 5.4. It really should move to 7.1 as the minimum version.

    Sites that might still be running PHP 5.4 and Weaver Xtreme WILL break, but using old version of the theme and turning off auto updates will solve that issue. It is WAY past time for PHP 5.4 to go.

    Note that PHP 7.1 and above will still run themes and plugins (and WP itself) written with PHP 5.4. PHP 8.1 apparently does cause some issues with some plugins and themes. In spite of a few Weaver users having issues with their websites when their hosts switched to PHP 8, Weaver did not have any issues running under PHP 8. It will work even better with PHP 8 now as the language features introduced with PHP 7.1 are still part of PHP 8.

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.