Home Forums Weaver Xtreme Theme “You don’t have permission to access this resource.”

Topic Resolution: Answered
Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #65028
    Answered
    Caetlyn
    Participant

    I’m trying save the theme settings onto my computer via the Save/Restore link in the admin section. However, every time I do so, I end up with a 403 Forbidden error.

    “You don’t have permission to access this resource.”

    Which files do I have to change the permission of for me to gain access to them?

    Thanks in advance.

    #65032
    scrambler
    Moderator

    @weaver will have to comment on that

    #65035
    Weaver
    Keymaster

    Is this always? Sometimes you can get that message if your login expires.

    Otherwise, this is a host problem. Typically, modern web create the proper permissions on your files when WP is installed. You would have had to done something manually to break access.

    And is that all the info you got? Did you see any file names or other specifics of what “this resource” is? You could look at your host’s error log files to maybe get more information.

    #65039
    Caetlyn
    Participant

    The exact error message is as follows:

    Forbidden
    You don’t have permission to access this resource.

    This only seems to happen when I’m using the theme within a subdomain. I’ll contact my host to see if they can work around it.

    Incidentally, what files would the issue be centred around so I can bring it to their attention? I doubt the host would be all that familiar with the Weaver theme – much less the admin side of it.

    #65040
    Weaver
    Keymaster

    I think it is at a higher level than the theme. Without knowing exactly the resource, it is hard to say.

    When saving files, the theme accesses  sub-directory /wp-content/uploads/weaverx-subthemes and creates files there. But all of that is done through WP core functions. It is common for plugins to access the /wp-content/uploads directory to store things.

    And normally, Weaver will perform checks to see if it can access those files and produces its own error messages if not. So I think the message is  coming from somewhere else.

    You also might be able to set WP_DEBUG to true in the wp-config.php file in your site’s root directory. That may generate more informative messages.

    #65041
    Caetlyn
    Participant

    I was re-reading my original post and realised that perhaps I haven’t exactly been clear on my issue. It may help you understand the resource more.

    The message only seems to occur when I click on the “download” link for either “Save all current settings to file on your computer” or “Save only theme related current settings to file on your computer.” under the Save/Restore section.

    Everything else seems to be working fine at this stage.

    #65043
    Best Answer
    Weaver
    Keymaster

    This reply has been accepted as the best answer.

    Could be a host setting that is blocking write access to the internet doenload from WordPress.

    Saving settings to your computer involves a different set of access needs than saving to the site.

    But I do think it is a hosting company access setting.

    #65054
    Caetlyn
    Participant

    Thanks. I’ll ask my host and see what they can do.

    #65056
    Caetlyn
    Participant

    Just an update for the reference of future forum members.

    The host got back to me saying there was a security rule defined in the .htaccess file which denies the execution of certain file extensions in the root directory. They’ve now fixed the issue.

    #65058
    Weaver
    Keymaster

    I would think that rule would break a few other themes and plugins as well.

    Glad you got it figured out, and happy to we figured it out.

Viewing 10 posts - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.