Home Forums Weaver Xtreme Theme WordPress Editor tool bar I have doesn’t match what is in product documentation.

Viewing 16 posts - 1 through 16 (of 19 total)
  • Author
    Posts
  • #18219
    TedPalmer
    Participant

    This is the question I posed in Experts-Exchange seeking a solution from a place where I have received 126 previous solutions that I have had with various IT programming products but mostly Visual Basic 2008 and 2010.

    “I am in the process of converting my EarthLink hosted website built with EarthLink provided website creation tool Trellix to WordPress. EarthLink also provided the WordPress installation functionality. The WordPress installed by Earthlink has been behaving pretty much as expected. But I noticed when I tried to add a HTML table builder tool to the top tool bar that the toolbar I have in the WP editor is different than shown in the setup screen for configuring the WP editor. I noticed the same difference when I tried to get a solution off of YouTube.com. I have thoroughly examined my WP Editor environment and read as much about this situation in WP provided documentation without finding a solution. I am adding a BAD and a GOOD screen shot of the WP Editor toolbars.”

    BAD:

    GOOD:

    The Experts-Exchange expert that I have been working with advised me that the BAD screen shot is what I see when “Text” mode is selected and the GOOD screen shot is what I see when “Visual” mode is selected.

    My response to that was:

    “I avoid Visual mode like the plague because it changes my content that I type on me on a rather grand scale. I got tired of having to go back and fix it. I even clicked a check box to not even show the visual tab. I’ll go back and change it and see what happens. I guess I may have to endure Visual mode to get the other tool bar buttons that I really need.”

    Here is what I discovered when I went to uncheck the check box that started this problem:

    “I finally found the option that I had checked to remove the Visual/Text mode tabs on the WP Editor. It was on a per page basis so I had to go back and visit each page that I have created to uncheck it. The option I had checked was provided by the theme Weaver Xtreme.

    Weaver Xtreme Options for this page — Disable Visual Editor for this page. Useful if you enter simple HTML or other code.

    Now that I have unchecked it. The Visual/Text mode tabs won’t come back. I logged off and logged back in. But that didn’t help. Have you got any suggestions as to how I might restore  the Visual/Text mode tabs on the WP Editor?”

    I followed that statement with what I learned from doing additional research:

    “Jason,

    I have information from additional research. I accessed another WordPress blog that I have working at a different URL. It uses Wintersong Pro Theme. I don’t know where it came from. It was provided by the website that hosts that blog. The WordPress editor on that blog behaves as you and I would both expect it to behave including the editor tool bar that is displayed depending on which Visual/Text mode is selected.

    That causes me to suspect that the Weaver Xtreme theme has got a bug in it. The provider of that theme acknowledges that it is the new latest evolution of his product. Previous evolutions of it were named Weaver II and Aspen. I’ll politely ask in that theme website’s forum about why the Visual/Text mode tabs in the WordPress editor didn’t restore after deselecting the check box that made it go away.”

    Jason’s response was:

    “I don’t use Weaver (for reasons wide and varied).  You can always test things/force changes by switching to a new theme, verifying that the editor functions as expected, then switch back to Weaver and see if it reset to norm. If not, there is most likely a bug in the theme. “

    I haven’t done as Jason suggested because my experience level with WordPress is still in the beginner stage. I’m concerned that I will loose all the work that I have invested in this project thus far. I still have lots to learn about backing up and restoring my WordPress assets.

    I agonized for quite some time before choosing Weaver Xtreme theme. Gensis is a theme that I considered but it has too many layers of thick stuff between me and the HTML That is why I choose Weaver Xtreme theme. I am confident that I made the right choice. Now I just have to learn how to use this powerful tool.

    Do you have a solution that will solve my problem?

    Respectfully yours,

    Ted Palmer

    Ted Palmer

    #24374
    Weaver
    Keymaster

    First, your 2nd screen shot is NOT from the editor, but rather from the WP Edit options page.

    So, are you sure you both unchecked the per page option “Disable Visual Editor for this page” AND then updated that page? Is the option really unchecked when you go back to the page?

    To test this, try to create a new page. You should see both editor views.

    If you don’t, then I suspect you’ve installed some plugin that also disables the Visual editor view. There are plenty that do that, and since you don’t like the Visual view, maybe you did that at some point?

    And most of the WP Edit options apply to Visual mode, and not the Text mode of the page/post editor.

    At any rate, there are so many Weaver users using this option that we’d have had other reports if it were a theme issue.

    #24375
    scrambler
    Moderator

    Also, there are TWO option in the page editor that would remove the Visual tab.

    “Disable Visual Editor” which you checked, and the one next to it called “allow raw HTML and Script”. So make sure that one is not checked either.

    #24376
    TedPalmer
    Participant

    Your questions followed by my answers are:

    >>”So, are you sure you both unchecked the per page option “Disable Visual Editor for this page” AND then updated that page? Is the option really unchecked when you go back to the page?” YES and YES to both questions in the above sentence.

    >> “To test this, try to create a new page. You should see both editor views.” My test results are shown in the inserted images that follow.

    Upper half of WP IDE:

    Lower half of WP IDE:

    #24377
    TedPalmer
    Participant

    I ran into a problem trying to insert all the images into one comment. There are 4 total. The last two images follow:

    >> Preview Add New TEST page:

    Next Image

    All Plugins Installed In MyInstance Of Word Press:

    Mr. Weaver:

    I believe that I have adequately responded to your questions with the above screen shot images. The last image is of all the Plugins that are currently installed into the instance of WordPress that I am using with your Weaver Extreme product. As you can see, none of the Plugins that you suggested I might have loaded are there to cause the problem that I am experiencing with your product.

    How do you suggest that I get Visual mode restored to my WordPress Editor screen so that I an add to it the optional functions shown in the Setup WordPress Editor Options screen?

    #24378
    TedPalmer
    Participant

    Mr. Weaver:

    BTW: You are correct “First, your 2nd screen shot is NOT from the editor, but rather from the WP Edit options page.”

    At the time I was not able to get the Visual mode tool bar to show because the tabs for selecting Visual or Text were not present. So I used the image that I could get to to communicate my message. I hope that helped make my explanation clear and unambiguous.

    #24379
    scrambler
    Moderator
    At this time, you need to Deactivate ALL plugins and see if the visual editor comes back in a newly created page.
    If it does, reactivate them one by one, testing in between to find the culprit.
    #24380
    Weaver
    Keymaster

    Have you tried a different theme – e.g., one of the default Tweney-xxxx themes?

    #24381
    TedPalmer
    Participant

    Wow, I have two helpers now. I’ll try both of your suggestions. First I have to backup what I have so far.

    Thanks guys.

    #24382
    TedPalmer
    Participant

    scrambler:

    Did you happen to notice the screenshot images I loaded to this discussion thread? The last screenshot shows all the plugins I have installed in my instance of WordPress. There are 2 kinds of plugins: one is the group of plugins that are loaded with every install of WordPress (WP). The others are the plugins that are loaded by Weaver Xtreme theme. I really don’t think my problem is being caused by any of the plugins loaded by installing WP. So that means that if the cause of my problem is in a plugin it has to be one from the installed Weaver Xtreme theme.

    Mr. Weaver:

    >> Have you tried a different theme – e.g., one of the default Tweney-xxxx themes?

    I tried this. I changed to the Tweney-2015 theme. I did an Update immediately after doing this. The Visual/Text mode tabs did not appear at the top of the Editor textbox. I changed back to the Weaver Xtreme theme and the Visual/Text mode tabs did not appear at the top of the Editor textbox after doing that also followed by an Update.

    Have you attempted doing any of the tests that you suggest I perform yourself? I’m not here to help you debug your product. I have a long history of discovering bugs that nobody else discovers because I just don’t think and do stuff the same way most other people think and do stuff. That’s why I choose Weaver Xtreme theme instead of Genesis. I have spent too many late nights, weekends, and holidays at work cleaning up the logically inelegant collections of idiosyncratic cryptic crap held together with Band-Aids, bailing wire, bubble gum, scotch tape, duct tape and copious quantities of Elmer’s Glue; created by people who actually thought they were computer programmers when in fact they wouldn’t make a pimple on a programmers butt to not recognize a bug when I see it. You have a bug in your product that nobody else has ever reported because nobody else has ever checked that check box labeled “Disable Visual Editor for this page”. Apparently you didn’t test it yourself either before going live.

    I plan to stay with Weaver Xtreme theme for now. But I am going to have to export my content to an XML file, except for my media files; uninstall WP; reinstall WP; import my XML file and manually upload my media files to fix this problem. I was considering upgrading to WP Editor Pro. It’s now on sale for half price. $17.50 for a one year subscription. Such a deal. Whoopee..!! Do you have any thoughts you would care to share with me about that?

    #24383
    TedPalmer
    Participant

    Mr. Weaver:

    And one more thing. . . . I noticed that you have your PhD. I don’t have one of those. But I am still pretty damn smart myself. I finally realized that when I came to the awareness that the reason I couldn’t find a design pattern in somebody else’s software was because it is impossible to find something that isn’t there.

    #24384
    scrambler
    Moderator
    “I tried this. I changed to the Tweney-2015 theme. I did an Update immediately after doing this. The Visual/Text mode tabs did not appear at the top of the Editor textbox.”
    This clearly means it is not related to the theme, and so that leaves either a plugin interaction or a broken installation.
    So regardless of what you think, deactivating ALL the plugin only takes a minute and will immediately tell you if a plugin is the cause of the problem.
    If deactivating ALL the plugin does not fix it, you can reactivate them all right away without any harm done. The next step will then be to redo the last WordPress update in Appearance > Update, in case the WordPress installation became corrupt.
    #24385
    Weaver
    Keymaster

    Just some comments –

    We really have tried pretty hard and spent a lot of time on YOUR issue. There have been not other reports from our thousands of users about this problem, so our assumption from the start that the most likely issue was not theme related. While Weave Xtreme is “new”, it is going on a year old now, so there are very very few bugs left.

    Given your statement that

    “I tried this. I changed to the Tweney-2015 theme. I did an Update immediately after doing this. The Visual/Text mode tabs did not appear at the top of the Editor textbox.”

    This is essentially 100% proof that the problem is not theme related. The desing of WordPress is such that one theme can’t leave “leftovers” behind that will affect how other theme work.

    You also said:

    “Apparently you didn’t test it yourself either before going live.”

    I find this accusation extremely insulting. This particular option has been used by many many people, and has been an integral part of both Weaver Xtreme, and its predecessor, Weaver II. Thus, this particular option has been available to Weaver users for nearly 5 years. Trust us, it works as it is supposed to.

    So, whatever you problem is, it is NOT Weaver Xtreme. You’ve proven that yourself. And because it is because of some plugin or custom code on YOUR site, it is impossible for us to reproduce it ourselves. That is why we offered suggestions for tracking it down.

    No matter what theme you pick, until you find the plugin causing the issue, you will continue to have it. You are more than welcome to not use Weaver Xtreme, although we think your original reasoning is sound. There is no other theme that can do what Weaver Xtreme can do. None.

    So, please be careful in the future before you start throwing insults and false accusations around. There was no need for that.

    #24386
    TedPalmer
    Participant

    Mr, Weaver,

    I am sorry I offended you.

    I have been struggling to continue to work on this problem, but my website hosting company, EarthLink, seems to have made some 3 day holiday weekend changes as is a popular choice among many major enterprises in Information Technology for timing of the installation of updates. I can’t start my WordPress instance via the usual navigation method without getting a 404 error. The EarthLink Support 1st level technician who worked with me on this issue acknowledged that this is their problem, and has escalated this issue to their next level of support. I have my support ticket number from today’s effort. EarthLink support has advised me to expect a response within 48 to 72 hours.

    I have made an effort to bypass their menu system by entering into my browser address bar text box my “domain name/path/index.php” but this yielded the same 404 web page result as EarthLink’s regular navigation method. Apparently my web hacker skills are not up to the task yet. So therefore I am going to have to wait till EarthLink fixes their problem on their issue before I can continue to work on this issue.

    Thank you for your help and for the help of scrambler.

    Ted Palmer

    #24387
    TedPalmer
    Participant

    EarthLink has completed their fix. Unfortunately
    for me the skill level limit of EarthLink technicians means that every fix they apply to a WordPress problem is the same — Reinstall WordPress. So I am back to square one. I do have a backup of every file starting at my /public/wordpress subdirectory. So once I refigure out what I knew that got me this far, I’ll be able to begin anew on my original problem if I haven’t succeeded at fixing it during the reinstall of WordPress.

    #24388
    GR8FL
    Participant

    I am just another Weaver user here, but thought I could offer some suggestions. I agree it is maddening to have problems with your site that are not easily resolved, but I can assure you that being critical of the support staff and developer of the theme is not going to make things any easier.

    If after you get things reinstalled and running and same problem persists, first make sure you are using latest version of WordPress (4.3.1. is current).

    And here are some troubleshooting steps you may want to try.

    • Flush any caching plugins you might be running, as well as server and/or browser caches.
    • Deactivate ALL plugins temporarily to see if this resolves the problem (plugin
      functions can interfere). If this works, re-activate them individually
      (one-by-one) to find the problematic plugin(s).
    • If that does not resolve the issue, try switching to the unedited
      default Twenty Fifteen theme for a moment using the WP dashboard to rule
      out any theme-specific issue (theme functions can interfere like
      plugins).
    • If that does not resolve the issue, try resetting the plugins folder via
      FTP or SFTP or whatever file management application your host provides.
      Sometimes, an apparently inactive plugin can still cause problems.
    • If all the above steps do not resolve the issue, then try MANUAL
      updating. Download a fresh copy of the WordPress .zip file to your
      computer, unzip it, and use that to copy up all files and folders EXCEPT
      the wp-config.php file and the /wp-content/ directory. You may need to
      delete the old copies of files & folder on your server before
      uploading the new ones. Read the Manual Update directions first.

    If you haven’t already done, always backup everything (including your database) before doing any actions, just in case something really goes wrong.

Viewing 16 posts - 1 through 16 (of 19 total)
  • You must be logged in to reply to this topic.