Home Forums Weaver Xtreme Theme Why does Weaver keep shrinking my images? From full size to very small.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #17874
    r1bryan
    Participant

    The images in http://www.sopacameraclub.com/newsletter/ start shrinking as soon as the page is opened.  Shrinks to really small. Weaverxjslib.min.js is what the profiler points to as the code that’s running.

    #22612
    Gillian
    Moderator

    What pictures are you referring to? Using Chrome, I see only one large picture (looks like full size) on the page you linked to.

    #22613
    Maureen
    Participant

    Looks fine on Safari also. 

    #22614
    Weaver
    Keymaster

    The theme does NOT shrink images. By default, images added using the Media Library are sized according to the size specified when you insert the image into the page or post.

    Always, no matter what the original size specified is, the image will be resized (by the browser) to fit within the limits of the content area. This is the only correct way to handle images in a responsive design, and is very desirable behavior.

    There is no code in the weaverxjslib that touches images (but videos are another matter – fitvids is indeed used on videos).

    Your images pages look to be a gallery of thumbnails with a lightbox popup. That has nothing to do with the theme.

    So, whatever you are seeing (and I don’t see any “really small” images other than the intentional?)thumbs for the galleries), it would be something you are doing – specifying the incorrect size (thumb, medium, large) from the media library, having incorrect image sizes set in the Settings:Media tab, or manually adding an <img> with incompatible styling.

    #22615
    scrambler
    Moderator

    the page you linked to has one large image on the right. As I shrink the browser, first the space for the text shrinks, then when the occupies all the width it starts shrinking, which is normal and good, or else it would get cutoff.

    If you are speaking of an other page like this one http://www.sopacameraclub.com/january-projected/ Your images behave in a responsive manner, they shrink with the browser (again necessary to keep them all visible, but they do rearrange in less columns when the screen gets below a certain size.

    So you really need to elaborate, because I am not following what you are saying.

    #22616
    r1bryan
    Participant

    Thanks for the interest.  Using firefox when I view the page: http://www.sopacameraclub.com/newsletter/ there is at first one large image on the right.  It starts out large, like filling half the page like it should.  Then about every second something occurs to make the image jump to a slightly smaller image.  Over a period of about a minute the image becomes very small, like a 1/2 inch wide.  I have tried all kinds of settings, especially the ones that address images size.  Whatever I try, makes no difference.  If you have firefox or IE maybe you’ll see what I mean.
    thanks,
    rb
        

    #22617
    scrambler
    Moderator

    I have tried IE11 and FF and I do not experience what you are describing. And there is nothing in Weaver I can think of that could cause such a behavior.

    Did you try a different computer?

    You may have something going on on your system.

    Also try deactivating ALL non weaver plugins to see if it makes a difference

    #22618
    r1bryan
    Participant

    OK its behaving better now.  Your comments are good ones.  I had someone else try on their computer – no problem.  Still acting a little odd when I do ctl + and ctl -, but working OK.  Thanks,
    rb
       

    #22619
    Weaver
    Keymaster

    @r1bryan

    I just looked again at your site using Crome and saw the effect. Please follow these instructions carefully:
    1. This is absolutely NOT related to Weaver.
    2. You have some plugin that is causing this. It might be Retina2x plugin.
    3. Disable your plugins, one at a time, until the issue stops. Start with the Retina 2x plugin.
    If it is the Retina 2x plugin, do let us know because we have recommended it. It normally works perfectly, but for whatever reason, it might be causing this problem. If it is, we are sorry we’ve recommended it, an we will try to contact that plugin author to see if it can get fixed.
    It is possible there is an interaction between more than one plugin.
Viewing 9 posts - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.