Home Forums Weaver Xtreme Theme Where ist the “Threshold for Slide Open Menu” gone in Weaver extreme?

This topic contains 43 replies, has 4 voices, and was last updated by  scrambler 3 years, 5 months ago.

Viewing 12 posts - 33 through 44 (of 44 total)
  • Author
    Posts
  • #20432

    Weaver
    Keymaster

    Weaver Xtreme Plus 1.1 was just released!

    #20433

    scrambler
    Moderator
    #20434

    nilolaus
    Participant

    Feels a little like being on Canned Camera.

    #20435

    scrambler
    Moderator

    ?? What do you mean ??

    #20436

    nilolaus
    Participant

    worked: http://wp.strafverteidiger-cuxhaven.de

    Just to mention: When not working on small business projects like this one I’m in quality assurance for a company (140 employees) managing online-projects. We would now be at a state, where we give the project back to the developer with the small, uncommented note: give us sth. that works. Unfortunately in this case I am sticking to your environment and do not have the time to use a different one. Fucking bad situation. Lucky that the customer delays delivering content.
    #20437

    scrambler
    Moderator

    Could you be less cryptic 🙂 and explain in more details.

    On each of these links what did you want to achieve, what did you do exactly and what does not work in etails

    #20438

    nilolaus
    Participant

    Sorry, if you do not see, what goes wrong, when you size the window – I can’t help. Then Point is: There is a working version (1). Then I bought this Waver Extreme and the working version got replaces by a menu jumping arround like crazy (2). Now I include this css (thank you for your work – no question) and I see that there is the mobile menu Icon, but still the dektop menu. Getting to smaller sizes the menu opens vertical and when opening submenus it layers over the content and clicking at the menu-icon has no function at all.

    May be you wanna just click at the links, size the window and see what happens. But … scrambler … I do really not want to get in trouble with you. It’s not your problem, that i decided to use the wrong software.
    Sorry.
    #20439

    nilolaus
    Participant

    And of course I can sit a day and configure the css … may be it will get better. And of course I can sit another day, when the next update apperars. And of course i can write my own menus and just inject them for different screen sizes. But the point is: There was a working version of the menu. And all of the versions are based on the latest WP-Version – so there is no question that the problems are weaver problems.

    And of course there is no need that weaver solves my problem. As i said, I’ve chosen the wrong software. But – who could have thought, that a developer replaces a working function with a not working function oder just deletes a working function. 
    #20440

    scrambler
    Moderator

    If you just want to rant and don’t want help, suits yourself…

    Your post was erroneous and that was what go me confused.

    http://wp.strafverteidiger-cuxhaven.de/  is using Apsen, what does this have to do with testing custom CSS for Xtreme Smart menus ?

    http://wp2.strafverteidiger-cuxhaven.de/ is using Xtreme and appear to work fine just using the default threshold (you said worked worse??)

    http://wp3.strafverteidiger-cuxhaven.de/ is using Xtreme and does not work, but it is does not seem to be using Smart menus…

    It does not look like you have selected use Smart Menus at the top of Main Options > Menus.

    My custom CSS clearly says it only works with Smart menus

    #20441

    Weaver
    Keymaster

    Dropping the menu switch point feature was necessary. While it may seem that your original version worked, it turned out that it really did not work correctly with all menu configurations, and could not be made to do so. The original addition of that function was in response to some requests, but unfortunately did not get the proper full testing before it was implemented. It was an unavoidable choice.

    Adding the exiting new functionality of the SmartMenus was also in response to a large number of requests over time for more menu layout options. Part of the consequence also eliminated the possibility of and easy switchpoint solution.

    @scrambler has devised some rather complicated CSS that seems to allow the switch point, but it is still experimental. If there is enough evidence the techniques work, it may be added as an option in the future, but that is not certain.

    On the other hand, do note that significant research went into the decision on the design of the Weaver Xtreme mobile menus, and just how they work, and at what point they switch. A significant majority of all websites have been implemented to treat an iPad as a regular desktop layout in both portrait and landscape. Weaver Xtreme’s design followed this majority rule.

    Also, significant research has revealed that probably most existing WordPress theme menus do NOT work properly on touch devices. There are generally FOUR different ways different touch devices handle touch events (and this is particularly true for menus). Current Android, Older Android,  iOS (Apple), and Windows 8+ touch screens all process touch events differently. Weaver Xtreme has been carefully designed to work on all four kinds of touch processing. A consequence of this is that it is very difficult to have multiple or variable desktop/mobile switch points.

    So, if you simply follow what is generally accepted as best web design practice, and treat iPads as desktop layout, Weaver Xtreme works as it should.

    At this point, if you feel compelled to have a different treatment of how the mobile menu functions, you will likely need to consider other themes. But do be sure their menus actually work at all on all four types of mobile devices.

    #20442

    nilolaus
    Participant

    1) Thought it is the same developer. Didn’t think that something of the same developer  that works right in one environment works wrong in the other.

    2) Klick the link, size the window – if you do not see, what goes wrong, I can’t help. It doesn’t “work fine”.
    3) Of course I selected “Use Smart menus”. There is a little cross in the Box and when I change your css the changes are visible in the menu.
    #20443

    scrambler
    Moderator

    If I inspect your page your menu is not using Smart menu, so if you have checked the option, something is wrong in your installation.

    I also cannot see what version of X Plus plugin you are using which makes me think it is either corrupted or not at the latest 1.1

    If you have PLus version 1.1 installed (NOT 1.0.1), I suggest you deactivate and delete the plugin and reinstall it from scratch

Viewing 12 posts - 33 through 44 (of 44 total)

You must be logged in to reply to this topic.