Home Forums Weaver Xtreme Theme Website showing up as blank … host says it’s a theme issue

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
  • #72076

    I manage a small website that doesn’t get changed or worked on very often (it’s just an informative ‘marker’ website for a roofing business). I was going to do routine update plugins, php file etc. and realized the site wasn’t working. It’s hosted by fatcow and they told me it’s a weaver xtreme theme issue causing the problem. This is a copy/paste of the error I got when I tried to change and/or update the theme:

    <b>Fatal error</b>: Uncaught Error: Call to undefined function mysql_escape_string() in /hermes/walnacweb03/walnacweb03/walnacweb03af/b2386/moo.cvrooferscom/wp-content/themes/smallbiz/functions.php:1011 Stack trace: #0 /hermes/walnacweb03/walnacweb03/walnacweb03af/b2386/moo.cvrooferscom/wp-content/themes/smallbiz/functions.php(1069): smallbiz_get_page_id_by_title_create_if_needed(‘Home’, -5, ‘Home ‘, ‘index.php’) #1 /hermes/walnacweb03/walnacweb03/walnacweb03af/b2386/moo.cvrooferscom/wp-content/themes/smallbiz/functions.php(1401): smallbiz_setup_menu_pages() #2 /hermes/walnacweb03/walnacweb03/walnacweb03af/b2386/moo.cvrooferscom/wp-includes/class-wp-hook.php(286): smallbiz_on_admin_menu(”) #3 /hermes/walnacweb03/walnacweb03/walnacweb03af/b2386/moo.cvrooferscom/wp-includes/class-wp-hook.php(310): WP_Hook->apply_filters(NULL, Array) #4 /hermes/walnacweb03/walnacweb03/walnacweb03af/b2386/moo.cvrooferscom/wp-includes/plugin.php(453): WP_Hook->do_action(Array) #5 /hermes/walnacweb03/walnacweb03/walnacweb03af/b2386/moo.cvrooferscom/w in <b>/hermes/walnacweb03/walnacweb03/walnacweb03af/b2386/moo.cvrooferscom/wp-content/themes/smallbiz/functions.php</b> on line <b>1011</b>


    I forgot to say at one point when I tried to update the Weaver Xtreme theme (after fatcow support asked me to change my theme and it didn’t work), I saw a message about updating from Weaver Xtreme 4 to 5 I believe? The error message was the same though.




    I see the site is unavailable at the moment with this error message:
    Parse error: syntax error, unexpected end of file in /hermes/walnacweb03/walnacweb03/walnacweb03af/b2386/moo.cvrooferscom/wp-content/themes/smallbiz/pre-header.inc.php on line 53

    Which version of WP and which PHP version are you currently running?

    Have you tried the Site Health plugin to check for issues?


    All the errors you mention point to a theme called smallbiz not xtreme.


    So either someone changed theme or you may have been hacked….

    We have seen a few report of such hacks lately where someone installed some files or fake plugins (that did not show up in the plugin list), and that would prevent any update or changes.

    A- If you have access to the admin side, you may want to try and install the Wordfence security plugin and run a scan.

    B- In case wordfence could not clean it up, and if you are able to switch to a Standard WordPress theme like 2020, you may want to try to do a full reset of the Weaver stuff as follow.

    • If access to weaver admin, save and download a copy of all your settings for good measure.
    • Switch to a WordPress base theme like 2020.
    • Delete weaver Xtreme theme
    • Deactivate and delete all installed weaver plugins.
    • Deactivate all other plugins
    • Reinstall Weaver Xtreme theme latest version from WordPress.org and activate
    • Reinstall Weaver Xtreme Theme Support Plugin latest version from WordPress and activate
    • If using the Weaver Xtreme PLUS plugin, download the latest fresh copy from your weaver Account, install and activate.
    • If using other Weaver plugins like showposts or showslider, reinstall them from WordPress.org and activate.
    • Check if thigs are back to normal

    C- Alternatively you could ask your host provider to check for hacks, and eventually restore and older backup hopefully before the hack happened


    smalbiz is possibly a weaver xtreme subtheme…

    If so, then the error is in the subtheme functions.php.


    Otherwise, the issue has nothing at all to do with the error message.


    As usual Scrambler, you were 100% on the money. I was completely locked out, but managed to get access to the admin side with the help of the host (fatcow), installed Wordfence … found a bunch of hacked files – deleted them and then was able to deactivate, uninstall and reinstall Weaver Xtreme.

    Thank you so much (again)

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.