Home Forums Weaver Xtreme Theme Weaver XtremeVersion: 4.04 Breaks My Site

Topic Resolution: Resolved

This topic contains 42 replies, has 4 voices, and was last updated by  Weaver 2 months ago.

Viewing 16 posts - 1 through 16 (of 43 total)
  • Author
    Posts
  • #55443

    GR8FL
    Participant

    4.0.4 Theme breaks my Site. Puts these strange circles & weird images in the widget boxes. Stretches out the width of header, menu bar & footer.

    I reported this a couple of weeks ago under another person’s thread (see https://forum.weavertheme.com/forums/topic/weaver-update-appears-to-have-made-some-weird-things-happen/#post-55377)

    Scrambler suggested: customizer > Layout > Core site layout > Overall site layout and select nothing or traditional, and see if that fixes

    BUT I have my XTREME CUSTOMIZE OPTIONS DISABLED. I see no advantage to using customizer and it takes up a lot of my limited bandwidth.

    I did enable customizer, but saw no options under customizer > Layout > Core site layout > Overall site layout to select nothing or traditional. All I saw was changing theme width, colors, typography, borders.

    I have since restored site from backup to previous theme version (Weaver XtremeVersion: 3.2.3)

    #55444

    scrambler
    Moderator

    @gr8fl You can find the options mentioned above in the legacy admin too, in Main Options > Full width > One step Site layout.

    Also make sure you clear all your caches, the strange circle are a cache issue after updating

    #55445

    Weaver
    Keymaster

    The strange circles are due to caching. If all caches are cleared, they go away.

    I don’t quite understand the One step layout issue. If you just update the theme, that option is there, but the default is none – traditional, in other words.

    #55446

    Weaver
    Keymaster

    And note that you can’t just update the theme. You have to update the Weaver Xtreme Theme Support plugin as well. If you revert to the 3.2.3 version, you have to revert the theme support plugin as well.

    And the 4.0.4 Weaver Xtreme needs the 4.0.x version of the theme support pluign.

    #55465

    GR8FL
    Participant

    I know it has to have plugins updated.

    I just did it on a demo site I am working on and it’s the same thing > broken theme (header, menu and footer) and those circle things. I’ve cleared the cache.

    I didn’t back it up, so I’m stuck with it until it can get resolved.

    Go take a look. http://demo.littledropup.com/

     

    #55466

    scrambler
    Moderator

    It is not broken, you have Expand / stretch activated for header and footer.

    What do you have in  Main Options > Full width > One step Site layout ?

    You should select nothing or traditional

    AFTER you do the above, what options are checked in Main Options > Full width below that?

    #55470

    GR8FL
    Participant

    I had nothing there.  I changed it to Traditional width options. It looks great.

    Will go back to hattiesgarden.com, backup, update theme and then see what is there.

    I went back to http://hattiesgarden.com/ and updated theme, cleared cache, saw stretch was wrong, tried to do Main Options > Full width > One step Site layout (BTW: I never have used that option when site was set up since it didn’t exist).

    However none of those options are right for the header.

    No option:

    This was setup with two images:
    #header-image {background:url(http://hattiesgarden.com/wp-content/uploads/1600×250-5-4.jpg) center;overflow:hidden !important;} is in the css

    The other is 1100 px that I uploaded to the Header (now it’s customizer, I suppose).

    Also, is it a design to have these lines and with text telling you what the section is? I took screen shots but don’t know how to post here.

     

     

     

     

     

    #55471

    GR8FL
    Participant

    I  just want to verify the plugin: Weaver Xtreme Plus Version 3.1.1 is designed to work with the updated 4.xx theme. Because I’m on another site: lavenderfieldsde.com and plugin is updated, but theme is still Version: 3.2.3 and under Appearance > Weaver Xtreme Admin > Main all that I see are choices for sub menus and tabbing from general to Wrapping Areas, Side Layout, Full Width, etc. doesn’t work.

    #55472

    scrambler
    Moderator

    1- You need to explain what you mean by “However none of those options are right for the header.

    What is the right layout you are trying to get for the header?

    2- on another site: lavenderfieldsde.com and plugin is updated, but theme is still Version: 3.2.3 and under” 

    What is the theme support plugin version, because if the theme support plugin is v4.x, you must update the theme to v4.x also.

     

    @weaver, I think one of the problem with the new One step layout, is that when nothing is selected, people end up with extended/stretch areas, which is not what they had before the update.

    May be nothing selected should be the same as traditional.

     

     

    #55473

    GR8FL
    Participant

    The right layout for the header is the way you helped me set it up some time ago.

    The header is using one image that is 1100 px wide, but it also has an overflow image that is 1600 px wide. If you look at the site header you will see the pictures are no longer seamless. I will try to find the thread from here of your help to get this right when I converted to Weaver Xtreme at least a couple of years ago.

    I have tried all 3 options (including nothing which makes 4 options) to fix header and each time it does a little something different, but it still fails. I will give you admin rights to login if you want to see it for yourself.

    <hr />

    Lavender Fields current status:

    PLUGIN: Weaver Xtreme Plus Version 3.1.1

    Theme: Weaver Xtreme 3.2.3

     

    #55474

    GR8FL
    Participant

    The only site that had no problems once I selected Traditional under Main > Full Width was demo.littledropup.com (Weaver Xtreme 4.0.4 Options – Plus (3.1.1)). However this site is a new one still under development. I used your help back in April (see https://forum.weavertheme.com/forums/topic/full-width-questions/) to set up header.

    Header Image Stretch is checked under Stretch Areas (I notice it is going to be obsolete in future).

    <hr />

    My real live sites were created years ago, and have been using Xtreme theme for at least three years. These are the sites acting wonky. It’s late for me and I need to be up early. Will test out whatever on cloned demo sites instead of live ones.

    I restored from backup lavenderfieldsde.com and imc-lewes.org after updated plugin caused problems with viewing Weaver Xtreme Admin > Main. I have screen shots, but don’t know how to upload here. When I restored from backup, they both function fine. Current versions: Weaver Xtreme 3.2.3 Options – Plus (3.1.1)

    <hr />

    I’m going to restore hattiesgarden.com to where it was before as well. Weaver Xtreme 3.2.3 Options – Plus (3.1.1)

    #55475

    scrambler
    Moderator

    the problem with the image is that it is aligned left instead of center. Go to the Header image options and select align: center.

     

    #55476

    Weaver
    Keymaster

    So, here is what I think the story is with the width settings.

    I’m not sure how to enforce this, BUT if you install Weaver Xtreme 4.0.x and then just look at the site without opening the settings, it seems to show the search box circles and stretched header. As soon as you open either the Customizer or the Legacy Interface (4.0.x version!) and save the settings – without changing anything – then all is well.

    I think that the problem is that the .css generated for 4.0.x is somewhat different than 3.2.x. The settings file is compatible, just not the generated .css. Between supporting inline CSS or loading it from a file, it just needs regenerating, which is done by a simple save of the current settings.

    I will see if I can detect a change from 3.2.3 to 4.0.x and issue a save message, but I’m not overly hopeful. I might be able to add some stuff to the settings file and detect a change from 4.0.4 or earlier to 4.0.5.

    But for now, the issue is not the easy full width choice, but rather the need to regenerate the CSS by saving the existing settings.

    #55477

    Weaver
    Keymaster

    Actually, it seems a bit more complicated. Just opening the Legacy interface will generate and save the latest settings.

    However, opening the Customizer does NOT do this. You actually have to perform a Publish action. And you can’t publish unless you change a setting. I don’t know how to make the Customizer force a settings change without actually making a change. I do know how to detect if the settings aren’t 4.0.x settings (actually, if the .css file isn’t from 4.0.x). Maybe there could be a warning that pops up upon visiting the site only when an admin is logged in. That should cover it. Could do this only if the Customizer or Legacy interface is just opened, but it seems people will often not do that after updating the theme version.

    This is a fairly difficult problem – all caused by very necessary changes to the generated CSS involving both full width and Gutenberg generated CSS.

    #55479

    GR8FL
    Participant

    Changing to center did not fix.

    I’m not onsite until much later tonight (after 8 EST), but will attempt to save CSS to force it to publish under 4.0x.

    Do you have any explanation why the Admin Interface had the hyperlink options over the tabs for Wrapping, Sidebars & Layouts, Full Width, etc? Is there some way I can post the image so you can see what I’m talking about?

    For now, I’ve uploaded to my Dropbox, but there must be a better way.

    Thank you.

    Hatties Xtreme Admin Weirdness

    Hatties Xtreme Admin Weirdness part 2

    #55480

    thesurge
    Participant

    @weaver @gr8fl

    I have also experienced the same issue in weaver legacy admin as shown in the 2 ‘Hatties’ screenshots, it happened on 3 of the sites I have updated to V4.

    I used the same process/order of updates on a number of other sites and this didn’t happen. I didn’t take too much notice of the 3 occasions it did as it was easy to clear – I just visited the front end of the site after saving a couple of small changes from the legacy admin, when returning everything was displaying correctly.

Viewing 16 posts - 1 through 16 (of 43 total)

You must be logged in to reply to this topic.