January 24, 2023 at 19:59 UTC - Views: 17 #71589WeaverKeymaster
WordPress will soon (maybe version 6.2?) will require PHP 7.4. If your host is providing anything before 7.4, you will get this message on the WP Dashboard:
Your site is running on an outdated version of PHP (7.1.33), which does not receive security updates and soon will not be supported by WordPress. Ensure that PHP is updated on your server as soon as possible. Otherwise you will not be able to upgrade WordPress.
Thus, Weaver Xtreme 6.1 will require 7.1 (instead of 5.4) , and the next Weaver Xtreme 6.2 version will require 7.4 to match upcoming WP requirements. Weaver products will no longer work with PHP 5 .4.
From all testing we’ve been able to run, all currently active Weaver products are compatible with PHP 8.1, and should not cause errors when you host updates to PHP 8 or 8.1. We do not believe that any issues upgrading an existing site that using any Weaver product will be the direct cause of upgrade failures. Some users have had issues when sitching to PHP 8, but they are almost certainly not related to Weaver.
The required PHP version will be updated for other Weaver plugins as well. And the active Weaver plugins are being updated to indicate support for WP 6.1 (Theme Support, Show Posts, Show Sliders, Turnkey bbPress, Weaver Xtreme Plus). Other Weaver plugins are no longer being actively supported (Weaver II to Weaver Xtreme, Weaver Themes Shortcode Compatibility, Designer Blocks for Block Editor by Weaver).
- You must be logged in to reply to this topic.