Home Forums Weaver Xtreme Theme Weaver Xtreme und ClassicPress

Topic Resolution: Resolved
Viewing 4 posts - 17 through 20 (of 20 total)
  • Author
    Posts
  • #63716
    scrambler
    Moderator

    @robf  this may be a fake limitation introduced to motivate people to upgrade WordPress.

    If it is, my be @weaver can test for classicpress and not issue the warning / limitation.

    If it is not, he can answer your question about the last version without that limitation, and where to get it

    #63763
    robf
    Participant

    @robf  this may be a fake limitation introduced to motivate people to upgrade WordPress.


    @scrambler
    not sure why access to the whole admin interface needs to be blocked if that is the case!

    If it is, my be @weaver can test for classicpress and not issue the warning / limitation.

    The error occurs both on a site running WP 4.9.13 and under ClassicPress so would need to be addressed on both really.

    If it is not, he can answer your question about the last version without that limitation, and where to get it

    OK, I look forward to that, thanks.

    #63792
    Weaver
    Keymaster

    WordPress REQUIRES themes to only have compatibility 2 versions back. Thus, I update to 2 versions of WP ago on each release.

    This is actually not really true, but we have to meet WP standards.

    If you want, you can edit the /themes/weaver-xtreme/settings.php file and change this value:

    define( ‘WEAVERX_MIN_WPVERSION’, ‘5.1’ );

    to be about any version you want. I’m almost certain that going back to 4.9 will still work.

    #63794
    robf
    Participant

    Great, thanks for that work-around.

    I have just done the above for 10 of my sites running Xtreme (both wp4.9.13 and ClassicPress) and they seem to working fine with access to theme admin restored.

Viewing 4 posts - 17 through 20 (of 20 total)
  • You must be logged in to reply to this topic.