Home › Forums › Weaver and Plugin Interaction › Weaver Xtreme Theme Support Plugin Version 3.2 Won't Activate
- This topic has 6 replies, 3 voices, and was last updated 5 years, 2 months ago by Weaver.
March 4, 2018 at 15:53 UTC - Views: 43 #53660dmarsteinParticipant
Weaver XtremeVersion: 3.1.12 installed.
This is the error:
Parse error: syntax error, unexpected ‘[‘ in /home/content/78/5412778/html/wp-content/plugins/weaverx-theme-support/includes/wvrx-ts-widgets.php on line 270
Good News: This occurs only on one of my 18 sites using Xtreme.March 5, 2018 at 00:29 UTC - Views: 46 #53669
Do you know what version of PHP that site has? I suspect it is older that 5.4. I just made some changes in the code that requires php 5.4, which I thought was a safe thing to do. I may have to revise that assumption.
PHP 5.4 and later allow you to write $list = ; instead of $list = array();. This syntax is nicer. And any plugins related to Elementor will also fail since they commonly use the new syntax. I’m not sure I should accomodate that change since it really is not a good idea to be using that old of a php version…
I think I will simply add a check for the PHP version and put up a warning if the older version is being used.March 5, 2018 at 22:50 UTC - Views: 31 #53681dmarsteinParticipant
It is older: 5.2.17
My client’s website in running on the old GoDaddy Linus Economy web server. I need to convince her to upgrade it to something newer.
Thank you.March 5, 2018 at 23:43 UTC - Views: 32 #53683htouzelParticipant
I have a similar issue but in my case I now cannot get into my site.
<b>Parse error</b>: syntax error, unexpected ‘[‘ in <b>/home2/htouzel/public_html/stopworkingandstartliving.com/wp-content/plugins/weaverx-theme-support/includes/wvrx-ts-widgets.php</b> on line <b>270</b>
I need some urgent help, as this site is a support for a book I am just launching, so would also appreciate any referrals. Using Hostgator, and they say the are using PHP 5.4 or higher. I have no (or very little) tech skills and my site is really basic.March 6, 2018 at 00:43 UTC - Views: 24 #53684
I don’t think it can be possible that they have 5.4 or later. That error won’t show on that version or later.
If you have access to your hosting company control panel and a file browser, you should be able to delete the plugin from /wp-content/plugins/weaverx-theme-support. Your site should then at least run.
I will try to revert to the older compatible code, but that does not make it a good idea to use older versions of PHP.March 6, 2018 at 01:19 UTC - Views: 22 #53686htouzelParticipant
Thanks. I fixed the problem by disabling the plugin. However, Hostgator indicates that they do have PHP 5.4 or above. I checked at. https://support.hostgator.com/articles/articles/hosting-guide/hardware-software/what-version-of-php-are-you-using#change. This is also what they say “PHP versions 5.4 and earlier, available on many legacy servers, are deprecated software and no longer receive security updates from the PHP development team. As such, we recommend that you prepare your scripts for PHP 5.6 or higher.” Not sure if this helps you with the development. I am going to see if they have me on some sort of legacy system. No need to reply, thanks for the help.March 6, 2018 at 02:07 UTC - Views: 17 #53687
A new version of the theme support plugin – 3.2.2 – should be available now (or very soon depending on WP plugin propagation) and should not have the PHP issue.
- The forum ‘ Weaver and Plugin Interaction’ is closed to new topics and replies.