Home Forums Weaver Xtreme Theme Weaver Xtreme Plus Plugin – Visual Editor

Topic Resolution: Resolved
Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #67313
    dnadesign
    Participant

    Hi Guys

    As soon as I Activate the Weaver Xtreme Plus Plugin the Toolbar in my Visual Editor disappears. Please see below a link to my site

    http://maxinemodeling.com/

    I am disabling the plugin in the interim as its a new site that I need to start building

     

    #67314
    scrambler
    Moderator

    There is no known problem of the sort, so there must be some other interaction at play.

    Are you using the default Block editor, or are you using the Classic Editor plugin, or are you using a different Editor plugin?

    Paste here the Content of the system Info box found on Xtreme Admin > Main Options > Theme Help page.

    You may want to try and deactivate ALL non weaver plugins and see if the issue still exist in that configuration.
    If it does not, reactivate one by one testing in between to find the one with the interference.

    #67315
    dnadesign
    Participant

    Thanks for reverting Scrambler

    I am using Classic Editor plugin

    I have deactivated all plugins and the only one that turns off the visual editor plugin is Xtreme plus. I also tried earlier versions of Xtreme plus (which have never done this in the past) But still switches off the tool bar – Must be some conflict somewhere – Maybe new version of wordpress? I have also noticed a couple of completed websites after upgrading the Plus plugin are giving similar results where you cant even access the visual editor and can only use the text editor.

    Let me know if you need access to the backend

    And thanks

    ### Weaver System Info ###

    — WordPress Configuration —

    Site URL: http://maxinemodeling.com
    Home URL: http://maxinemodeling.com
    Multisite: No
    Version: 5.6.1
    Language: en_US
    WP_DEBUG: Disabled
    WP Memory Limit: 40M
    Permalink: /%postname%/
    Show On Front: posts
    Page On Front: n/a
    Page For Posts: n/a
    Current Theme: Weaver Xtreme (4.4.4.1)
    Post Types: post, page, attachment, revision, nav_menu_item, custom_css, customize_changeset, oembed_cache, user_request, wp_block, wpcf7_contact_form, atw_slider_post

    — Weaver Xtreme Configuration —

    Weaver Xtreme Version: 4.4.4.1
    Theme Support Version: 4.4.1
    Xtreme Plus Version: 4.0

    — Server Configuration —

    Operating System: Linux
    PHP Version: 7.4.14
    MySQL Version: 5.5.5
    jQuery Version: 3.5.1
    Server Software: Apache

    — PHP Configuration —

    Local Memory Limit: 256M
    Server Memory Limit: 96M
    Post Max Size: 32M
    Upload Max Filesize: 32M
    Time Limit: 60
    Max Input Vars: 2500
    Display Errors: N/A

    — WordPress Active Plugins —

    Akismet Anti-Spam: 4.1.8
    Animate It!: 2.3.7
    Classic Editor: 1.6
    Contact Form 7: 5.3.2
    Photo Gallery by Supsystic: 1.14.10
    Weaver Show Posts: 1.5.1
    Weaver Show Sliders: 1.5.1
    Weaver Xtreme Plus: 4.0
    Weaver Xtreme Theme Support: 4.4.1

    — WordPress Inactive Plugins —

    ### End System Info ###

    #67316
    scrambler
    Moderator

    It works for me.

    Did you check if the “Disable Visual editor” or  “Allow Raw HTML or script” was not checked in the Misc Options TAB?

     

    #67329
    dnadesign
    Participant

    Yes – I checked both of those. Have sent Weaver login details – Any news?

    #67334
    scrambler
    Moderator

    I assume you mean you verified that they are NOT checked right.

    Because if you checked them then there is your problem 🙂

    Otherwise and if you sent @weaver a login, he will let you know. I did find an old thread that had some similar report

    Visual Tab in Xtreme – Weaver Support Forum (weavertheme.com)

     

    #67335
    Weaver
    Keymaster

    OK, I’m totally stumped at the moment. There is indeed an issue with Weaver Xtreme Plus on your particular installation. I’ve tried a bunch of things, and given your site is really basic, it is fairly easy to try things.

    When Weaver Xtreme Plus is activated (going all the way back to Plus 3.1 versions), the editors behave badly. When Plus is activated, I notice:

    1. If just the block editor is enabled, it doesn’t know how to edit old Classic Editor elements (e.g., just a simple <p>content</p>). It says it can’t edit it.
    2. When trying to exit for either the Classic or Block editor without making any changes at all, it loads the “leave page” warning as if it thinks content was changed.
    3. The  classic editor won’t display the Visual tab content (the tab is there). I suspect the same issue that the Block editor is having.

    Now why this would be is totally confusing, and I have only two theories at the moment:

    1. Your host’s version of PHP – 7.4.14. I can only test up to 7.4.1 at the moment. Will need to update my development site to get later versions, and I may not be able to try 7.4.14 exactly.
    2. Your Database host. I don’t know why this would affect code, but your host has an unusual database host setup – it not using the same host as the file and php host.
    3. EDIT: Your site isn’t https:// configured yet. Don’t know why that would be an issue, however.

    I tried the normal WP_DEBUG, true setting (using a plugin that lets one modify the wp-config.php file), and that did not generate messages. It is possible that your host error log file might have some useful information, but you can’t access that from WP Admin.

    Do you have any other sites using the same host or config? I didn’t try reinstalling WP, but there could be a glitch there. But I’ve not seen this before, and I certainly can’t reproduce any issues with Weaver Xtreme Plus activated on any of my own hosts, nor have there been other reports.

    So, if you don’t seen any error log file errors, I will have to see if I can test with PHP 7.4.14. This is one of the biggest stumpers I’ve ever encountered, I think. It is likely some small change to Weaver Xtreme Plus’s code would fix the incompatibility, but I can’t fix it if I can’t find it.

    Thanks for your help on this. I’ll upgrade your Weaver Xtreme Plus license as thanks.

    #67337
    Weaver
    Keymaster

    I switched to PHP 7.4.14 and have no issues with the visual  editor.

    So, I really don’t have any ideas at this point.

    #67341
    scrambler
    Moderator

    At this point it may be worth doing the refresh below

    • Save All Weaver settings and download a copy for good measure.
    • Switch to a different theme
    • Delete all weaver Theme and plugins
    • Redo the Last WordPress Update.
    • Install and activate the weaver Xtreme Theme from WordPress.org
    • Install and activate the Weaver Xtreme Theme support Plugin and activate
    • Download a fresh copy of the Xtreme Plus Plugin, Install and activate
    • All settings should be back automatically
    #67349
    dnadesign
    Participant

    Hi Weaver & Scrambler

    Firstly many thanks on the offer of an upgrade – working in ZAR’s is never easy 🙂

    Just to follow up on this issue – I did try change the php version but could only go as far back as 7.2 – It had no effect.

    I did a reinstall from scratch – Dumped the site and started again. All seems to be working perfectly as the Weaver Theme always does.

    Thanks again for your help on this one!

    #67358
    Weaver
    Keymaster

    Whew! That was a difficult one. A bad install shouldn’t happen, but obviously somewhere along the way, some file must have been corrupted. It happens, but not very often. Could even have been a database error. Fortunately you discovered the issue before you had really done much work on the site! Thank you for reporting back!

    #67359
    Private Reply
    Weaver
    Keymaster
    This reply has been marked as private.
Viewing 12 posts - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.