Home Forums Weaver Xtreme Theme *** Weaver Xtreme File Access Error! ***

Topic Resolution: Resolved
Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
  • #61740


    I am receiving the following error when I try to access the wp-admin of my site pirateheartrecords.com

    *** Weaver Xtreme File Access Error! *** <small>( But don’t panic! )</small>Weaver Xtreme is unable to process a file access request. You may need proper FTP credentials set in WordPress, or in your wp-config.php file. It is unusual to see this error. It may be displayed after you move to a new host.

    You may have to change the directory permissions on your web hosting server.

    Diagnostics:Directory not writable to save editor style file. You will have to check with your hosting company to have your installation fixed to allow directories to be created. Directory: /home/content/33/10304233/html/pirateheartrecords/wp-content/uploads/weaverx-subthemes/

    The site is experiencing technical difficulties. Please check your site admin email inbox for instructions.


    I am using the latest version of wordpress and the theme. I tried contacting my host (GoDaddy) as suggested but they insist that this is a theme related issue and they can’t help. The file permissions seem to be correct also.

    Any help would be appreciated as I am a big fan of the theme.







    I have had this exact same error happen to me on two occasions, both were directly after migrating the sites to a new web host. Oddly I have migrated many Weaver Xtreme sites and it isn’t something that has happened more than these two times.

    I can’t remember exactly what I did to get past the problem (I really should make notes when working out solutions) but I think it was as simple as accessing the server via FTP and deleting the Xtreme theme folder. This gave me access to admin as the site reverted to the default theme, I then reinstalled Xtreme and everything worked OK.

    ‘Directory not writable to save editor style file’ was the important aspect when it happened to me, I think Xtreme was still looking for the old web server instead of the new one.

    hope this is of some help.


    Thank you for your reply. Unfortunately I am still getting the error with a fresh install of the theme.


    Did you read the help instructions that go with the message? I think they really explain the issue.

    It is host related – and only happens with hosts that don’t use the currently most up to date (as of several years ago, at this point!) file access settings when installing your site on their host.

    There are TWO things that can cause this message:

    1. The host is not properly configured for direct access to create new files. The site requires what is called FTP access to write files to your system. While this used to be a fairly common issue (like 5 or 6 years ago), it is very seldomly encountered these days.
    2. The host is not using the most recent file access interface to your files. What happens is that your host does not allow new directories to be created in the /wp-content/uploads directory. Sometimes using your cPanel or other host file system access while logged in directly to your hosting account you will be able to set the directory to have write access.

    In any event, this message is caused by a host that does not use the most typical file access protocols used by most web hosts. If you don’t have the tools with your hosting account to set file permissions, or if that just doesn’t seem to work, you will most likely have to contact your hosting company directly to get this issue resolved.



    Follow up:

    I just noticed that you said you’re using GoDaddy. We know that many Weaver Xtreme users have successfully created sites using GoDaddy.

    This is really not a theme issue as there are many thousands of sites that don’t have any issues. There MUST be some host configuration issue with your particular host plan or other settings.

    I’m personally not familiar with all the file system access settings you have have with a GoDaddy account, but there must be something different about your particular site.

    You might try to create a new site (say as a subdomain site: sub.yourdomain.com, for example) and see if creating a new site works.

    Note that the file permissions shown in the cPanel file browser don’t always correspond to what really goes on at runtime. Most hosts use a file access procedure that is actually independent of the file permissions shown by cPanel. (This technique is more secure than the native Linux based file system.)


    I did read it yes but like I said, unfortunately my hosts refused to help as they said it was a theme related issue and there was nothing they could do. I was hoping there was another solution.


    It wasn’t an issue before, but I have had to move to a new hosting plan as the one I had was outdated and incompatible with the latest PHP and WordPress updates. I have 5 sites all using Weaver Xtreme so I really hope I can resolve this.


    GoDaddy is notoriously bad at WordPress, which does not help you.

    Their reaction is another display of it.

    Do you have access to File permissions in your Cpanel?


    Luckily I got through to another person at my host that was more helpful. If anyone else migrating sites hits this issue it was resolved by going to MyPHPAdmin and changing the upload path in wp options. It was still calling to my old hosting. Thanks for your responses.


    Thank you for reporting back


    Thanks –

    This is an interesting discovery. Normally, one doesn’t ever change the upload path, but there certainly are some cases to do that.

    But if you migrate – then as you’ve most helpfully discovered – the path can become nonsense in the new environment.

    Because it is not common to have a custom setting on that WP option, I don’t think many people would think to check that out.

    We will add that as a 3rd thing that can go wrong – might even add that to the error message suggestions!

Viewing 11 posts - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.