Home Forums Weaver Xtreme Theme Weaver Xtreme Appearance Admin not working

Topic Resolution: Resolved
Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
  • #71755

    We have two sites based on Weaver Xtreme.

    The one is a clone of the other same pluggins etc.

    Call them A (works) and B (problem)

    When going into Appearance / Weaver Xtreme Admin on A – all good

    When going into Appearance / Weaver Xtreme Admin on B – all options are shown. In other words the various sections that are usually only displayed when a tab is clicked at the top are all displayed in one long form.

    Clicking the tabs (B) does nothing but scroll to the section on the page where as in A it opens the new tab.

    Attempting to save on B results in a message “your host seems to be configured to limit how many input form options” with a recommendation to increase this value – however increasing the value results in the same message with an updated recommendation on what to make the value. At 17K we stopped trying.

    We have copied the plugins folder from A to B – same issue.

    Any ideas?


    @weaver would have to comment on what could screw up the Admin side of the theme


    That message is normally triggered only when there is in fact a memory limit on your host. It is normally the number of input options, and 1000 should be plenty. It could also be related to the local or server PHP memory limit.

    Are your two sites on different hosts? Is PHP configured the same?

    Can you open the normal Legacy Weaver Xtreme Admin interface and look at the Theme Help tab? If you can, then copying and posting the System Configuration report here might help.


    No subfolders on the same URL.

    Something changed on B – not sure what but whatever it was has made it impossible to manage WeaverSettings

    a) The interface does not render properly – broken – cannot get to fonts and custom for example (at all).

    b) Any attempt to save settings that are available results in that message. Message says you have 1000 recommend you change to 2000. Change to 2000 and it says you have 2000 recommend you change to 3000 and so on – stopped after I got over 17000+

    As I said A is identical – B is a clone – plugins folder are identical. A works perfectly B doesn’t

    Sidebar: The Weaver options that usually appear at the bottom of the page that allow per page settings does not show – block is completely absent. Again on A this is not a problem.

    Memory 512M – upped it to 1G – no change

    Error log is empty.

    Right now I am having to find settings in the dB and change them manually – my client has no way of being able to do this themselves.


    Have you tried to do a reset:

    • Save your settings and download a copy for good measure.
    • Switch to a different theme
    • DELETE all weaver theme and plugins.
    • Reinstall weaver Xtreme from WordPress and activate.
    • Reinstall weaver plugins an activate.

    Firstly – just want to express my appreciation for taking the time to respond. People who give of their time to help others is what makes this industry so uniquely inspiring.

    No I have not tried your suggestions – I wanted to explore all other avenues first.

    Here is what I tried

    1. Copied the theme folder from working site – no luck
    2. Upgraded to latest WP – no luck
    3. Incrementally updated plugins – I did try this on an earlier iteration and had no luck – in fact one of the updates broke the site and I had to restore from backup. On the second attempt (one at a time – and after the WP update) the problem resolved after updating theme support for Weaver.

    Site seems to be operational again. Not sure why it was broken to begin with given that site A is still functioning perfectly fine on its version of WP and Theme files – but there it is.

    Again thanks for taking the time to respond.


    Thank you for reporting back.

    An out-of-date Theme support plugin could definitely screw things up.

    It is important to keep theme and plugins up to date at all times.

Viewing 7 posts - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.