Home Forums Weaver Xtreme Theme Weaver Xtreme 4.0 and Weaver Xtreme Theme Support 4.0 now live

This topic contains 65 replies, has 4 voices, and was last updated by  scrambler 5 months, 2 weeks ago.

Viewing 16 posts - 49 through 64 (of 66 total)
  • Author
    Posts
  • #55219

    Dave
    Participant

    Greetings again-

    Should I center align the header image again and continue testing? Not sure if after @scrambler’s post I should leave it [broken] for follow-up?

    I only ask because I haven’t heard anything relative to @scrambler’s last post.

    Best

    David

    #55220

    scrambler
    Moderator

    Given this is a test site, it would be best to leave it broken, so @weaver can comment on my last post

    https://forum.weavertheme.com/forums/topic/weaver-xtreme-4-0-and-weaver-xtreme-theme-support-4-0-now-live/page/3/#post-55193

    He has been busy with some fire warning around his home the last few days…

    #55222

    Dave
    Participant

    @scrambler

    OK, will do. Anything you need for testing purposes I’ll gladly help.

    @weaver

    Hope everything is OK. Remember, family/safety first.

    Best,

    David

    #55226

    Weaver
    Keymaster

    There is an option to have the header image link to the site or not. That seems to be the difference.

    #55227

    Weaver
    Keymaster

    Putting a z-index: -1 on #header-widget-area seems to fix it, but it would be good to understand what set of options left the image hidden.

    #55228

    scrambler
    Moderator

    @weaver, I can confirm it is the “link to site” option causing the problem.

    The main reason is that when there is no link, you use display block for the image and align using margins, but when there is a link, you are using display:inline-block, and a float (left or right) which is causing the expansion of what comes next.

    So rather than using z-index, I think what you need is to use the same alignment method as when there is no link.

    Instead of using
    #branding #header-image img{display:inline-block;float:left;}
    or
    #branding #header-image img{display:inline-block;float:right left;}

    Use display block and use margins as you do when there is no link.

    #branding #header-image img{display:block;margin-left:0;margin-right:auto;}

    and
    #branding #header-image img{display:block;margin-left:auto;margin-right:0;}

    If, for some reason I am overlooking, you need to use inline-block and float, then add a clear-both to what comes after.

    #55244

    Weaver
    Keymaster

    Thanks. Did you mean float:right in the 2nd example of the old method?

    I think this same thing would be in 3.2 as well, unless I introduced the add link in 4.0. But I think I did that before 4.0.

    #55246

    scrambler
    Moderator

    Yes, sorry, copy paste too fast

    #55272

    Dave
    Participant

    Greetings-

    I just updated the beta/test site to the latest theme 4.02 and updated the Extreme Support plugin update as well, and still have the header image issue.

    Also, should I remove the two custom CSS code I was provided to really brake the site for testing purposes?  If I remove the custom codes listed, the site will really go haywire.  🙁

    You guys are also right.  If I “uncheck” link header to site, I get the header image back.  When I rechecked that option, the header image stayed do now it seems to be working.  Hmmmmm, I had to toggle that feature (off-save, then on-save) I suppose?

    table { table-layout: auto; }
    table,td,th{border:none;}

    Please let me know.  Anything I can do to help out.

    Also, could this be because I have the paid version of the theme/plugin on the main site and not the test site that it’s not updating correctly?

    Best
    David

    #55275

    Dave
    Participant

    Update:

    I removed the following custom codes:

    table { table-layout: auto; }
    table,td,th{border:none;}

    The wrapping is OK (maybe the new build addressed that), not like it was before where everything was crunched on the left. However, I still see the table borders and note the “Additional Comments (optional)” field toward the bottom.  For some reason, it resized to a smaller version on the new 4.02 version, vs. the original.

    Original site: http://cityofbonitaspringscd.org/zoning/cccl
    Weaver v. 4.02 site: http://cdvps.org/bu/zoning/cccl

    I can place the custom codes back if you prefer.

    Best,
    David

    #55282

    scrambler
    Moderator

    For now you still need the border rule below, it is not yet fixed

    table,td,th{border:none;}

    I don’t see any difference on the “Additional Comments (optional)”

    #55283

    Dave
    Participant

    OK, thanks Scrambler.  I put it back.

    table,td,th{border:none;}

    Best
    David

    #55303

    dtlandry2
    Participant

    Hi all – I just upgraded my theme and now my header and entire site has gone full width, although full width is not enabled.

    Here is my site: http://mindstudents.com

    Please advise.

    Thank you!

    #55304

    dtlandry2
    Participant

    I was able to fix it. I changed “Overall Site Options” to “Traditional” and it fixed.

    Thank you!

     

    #55378

    Dave
    Participant

    Greetings.

    Here’s the latest:

    I upgraded to Weaver 4.03, removed the following code and the table border issue has returned.

    table,td,th{border:none;}

    There appears to be some field discrepancies which are not found in the original (not updated) site.

    For example:

     

    I’ll leave the CSS code out for testing purposes and will delay upgrading the live site. 🙁

    Best,
    David

    #55379

    Weaver
    Keymaster

    You will need to change the table to no borders in the Weaver  content option. This is a change in the 4.0 default table styling – somewhat due to the default table styling introduced with Gutenberg.

    I can’t figure out why the blank form info field is narrower. Spent a good deal of time with a broswer developer tool to try, and failed. The styling adopted by the form plugin is quite complex.

    I must, however, express my disappointment in the form styling of the form plugin. It is completely table based, and has a fairly big set of CSS styling loaded with it, yet it fails to properly override simple table styling from the theme. There really is no excuse for that.

    So:

    1. You can fix most of the problems by selecting the no border theme table style.
    2. You should complain to the form plugin authors that they have failed to properly style the tables used in their form.

     

Viewing 16 posts - 49 through 64 (of 66 total)

You must be logged in to reply to this topic.