Home Forums Weaver Show Posts & Show Sliders Weaver Slider Post images not showing on MOBILE

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #18064
    mafgirl
    Participant

    Hello all!

    I’m talking about this site here (still under construction). The images are not the final ones yet and are not wide enough at the moment, but I don;t want to do any more work until i can sort this issue out

    The Issue: I used http://forum-archive.weavertheme.com/discussion/8519/slideshow-link-image-to-a-page and http://forum-archive.weavertheme.com/discussion/8749/revisit-custom-url-link-in-show-sliders to create a slideshow using images that link to a custom URL (in this case, a part of the page –  as this is a one page website) It works and looks great on a PC (hopefully a Mac too!), but on a mobile I see the underlined text: Continue reading rather than the image. the link also doesn’t work as it is trying to link to the image and you just see the name of the image.

    Any ideas what I’ve done wrong here?

    Thanks ever so much 🙂

    #23549
    scrambler
    Moderator

    Your images do not display on IE, (I get a small cross box).

    Your URLS like this one lead nowhere http://bestfaceforward.loc/wp-content/uploads/2015/07/fotolia_81174632.jpg

    #23550
    mafgirl
    Participant

    DOH! I’d forgotten that WP puts the full url when uploading media and that’s the URL of my local WAMP site. I’ve fixed that now and the links are now all /wp-content/uploads/2015/07/fotolia_81174632.jpg etc.
    However, I still only get ‘the continue reading’ on a mobile rather than the image… when i click it it shows the photo now, so that is not the issue..

    #23551
    scrambler
    Moderator

    There is indeed something strange going on, because if I reduce the browser down to a phone size I always see the image, but if I look at it on a phone I do see the continue reading.

    Can you try deactivating ALL non weaver plugin and see if the issue remains?

    #23552
    mafgirl
    Participant

    I only had Weaver plugins activated (or plugins which were recommended by Weaver). Nevertheless, now only have show posts and show sliders active (which I need to get the slideshow to work/show) and I am still getting the continue reading on mobile…

    Am I able to tag weaver in this so maybe he can take a look? Thanks scrambler!

    #23553
    scrambler
    Moderator

    @weaver

    Can you help with this one.

    on the site http://www.bestfaceforward.testurl.net/  there is a post slider at the top of the page content, showing full posts, only made of images (this is so images can link to whatever is wanted).

    On desktop   we see the full posts image content, and if I shrink the desktop to a small (phone like) size we still see the images.

    But if I look at the page on a phone, instead of seeing the full post, the slider now shows excerpts, which means that we only see the continue reading message.

    I don’t know of any slider or filter option that would show full pots on desktop and small tablet, but excerpt on phones, so could that be a bug ?

    But I cant reproduce it on a post slider so far.

    @mafgirl can you confirm what options you have in the filter Post Display options box ?

    #23554
    Weaver
    Keymaster

    @scrambler, @mafgirl,

    This is a designed “feature” of smart mode mobile display.

    To fix, on the Mobile option tab under Small Screen Devices, check “Show Full Blog Posts”

    Basically, it is one of the main differences between smart mode and pure responsive. Switching to responsive mode would fix it, too.

    #23555
    scrambler
    Moderator

    Completely overlooked that one 🙂

    Better, switch to responsive mode instead of smart mode so you can get rid of the now awkward Full View Mobile View Icon on mobile ðŸ™‚

    #23556
    mafgirl
    Participant

    Fantastic!!! Thank you @weaver that did the trick!!!
    Thanks for your help too @scrambler I can always count on awesome support on here!! I did check my filters too, bit had nothing changed there apart from the slider group

    Thanks guys 🙂 🙂

    #23557
    Weaver
    Keymaster

    @scrambler

    Well, I actually had to read the code to see why that might have happened, and (re)discovered that setting. So easy to forget about the “features” that smart mode mobile allowed.

Viewing 10 posts - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.