Home Forums Weaver Show Posts & Show Sliders Weaver Show Posts widget

Topic Resolution: Resolved

This topic contains 18 replies, has 4 voices, and was last updated by  sanderstina 3 months, 1 week ago.

Viewing 16 posts - 1 through 16 (of 19 total)
  • Author
    Posts
  • #54943

    sanderstina
    Participant

    I would like to use the Weaver Show posts widget on my home page since it gives me better control over display etc.

    On the home page I have several widgets arranged in three columns in rows. One of the widgets is a Recent Posts one.

    When I replace the Recent posts widget with a Weaver Show Posts widget all the widgets after it in lower rows are spread over the three columns.

    I know it must be a spacing issue but I cannot figure it out.

    Any help would be much appreciated. You folks are so helpful.

    Thanks

    Tina

    #54945

    scrambler
    Moderator

    We need to see the page with the Show post widget in place.

    But right now you have the recent post widget, and all widgets after that spread over the three columns.

    Also, do you have plus, or are you just using the 3 column setting of the Widget Area?

    #54952

    sanderstina
    Participant

    Hi there

    I have both widgets there – one called What’s New (using WVR show posts) third one in first row

    and the next one called What’s New using recent posts

    And I do have plus.

    Thanks

    T

    #54953

    scrambler
    Moderator

    Something is going on as the first three widgets do have the 3 column class, but not the ones after.

    Can you remove the recent post widget so we can see what happens then?

    #54954

    sanderstina
    Participant

    I have removed the Recent post widget and there is still the issue of the other widgets spreading out.

    Thanks

    T

     

    #54962

    Maureen
    Participant

    The top 3 posts are set up using Weaver show posts 3 per row (under Filters / Define Content Selections Filter Options / Display Posts in Cols 1-3).

    The wide 3 at the bottom do not seem to be set up that way. Did you add them to the Weaver Slider Posts that you set up for the top 3?

    #54964

    sanderstina
    Participant

    All of the widgets that appear on the home page were set up as individual widgets in a per page widget area that is placed in the TOP widget area.  The area is set up with 3 columns and equal height widget rows in the TOP WIDGET AREA settings in the Admin menu.

    There are 11 widgets showing right now (I will limit to 6 eventually) – there are 4 TEXT widgets, 4 Feature a Page widgets, one Navigation Menu widget, Weaver show posts (not a slider), Recent Posts.

    It is the addition of the Weaver Show Post widget (title on home page is What’s New (using WVR show posts) that is causing the issue.

    Hope that clarifies  the setup.

    T

     

    #54969

    scrambler
    Moderator

    @weaver will need to have a look.

    @weaver, apparently when adding the showpost widget in the widget area, all the widgets after it are missing the widget area 3 column class.

    Any idea what could cause this.

    Will try on my test site and report if I can reproduce

    #54970

    scrambler
    Moderator

    @sanderstina, I cannot reproduce the problem, so it is something specific to your configuration.

    two tests you can make:

    1- Test removing all plugins widgets from that widget area and only using text widgets and the show post widget. In that configuration it works for me.

    If it works for you too, then add your plugin widgets one at a time to see if one of them causes the bad interaction.

    2- If the test above is unsuccessful. Try creating a new show post filter with all defaults, except display posts as title list only, and see if that one work.

    #54971

    sanderstina
    Participant

    Okay thanks I knew I was ‘special’  I will test and let you know what happens.

    T

    #54974

    sanderstina
    Participant

    Results of testing:

    1- Test removing all plugins widgets from that widget area and only using text widgets and the show post widget.

    Weaver Show Posts widget still causing any following widgets to lose 3 column setup.

    2- Try creating a new show post filter with all defaults, except display posts as title list only

    Unfortunately still having the same problem.

    Maybe I need to just go back to using the Recent Posts widget and try to get it to only show the What’s New category.

    Thanks for your time.

    t

    #54975

    scrambler
    Moderator

    Have you tried deactivating ALL non weaver plugins and see if that makes a difference.

    If it does reactivate one by one testing in between to find the culprit.

    #54976

    scrambler
    Moderator

    Also, I see you have Plus, so as a potential workaround, instead of using the Top widget area Column option, put 1 in the column box, and use the custom widget width boxes below.

    For equal three columns use 33.33 separated by a semi colon as many times as you have widgets (10 below)

    desktop: 33.33;33.33;33.33;33.33;33.33;33.33;33.33;33.33;33.33;33.33;

    And if you want a different number of columns on mobile, use the tablet and phone box to create a different layout like using 50 for two columns

    #54981

    sanderstina
    Participant

    Hi

    I used the work around mentioned above and yippee it seems to have worked.

    Thanks for all the help.

    Tina

    #54993

    Weaver
    Keymaster

    The only issue I see now is that not all of the 6 blocks display when going to a phone. Just one column with 4 blocks.

    #54998

    scrambler
    Moderator

    @weaver, her page is no longer showing the problem as she used Custom widget width as a workaround to the issue.

    the issue was that when creating the three columns with the widget area column option (not custom widget width), All widgets after the show post widgets were not getting the column class, and therefore were using the whole width (single column)

    I could not reproduce it, but apparently, in some configuration, something breaks whatever is putting the column class on the widgets

Viewing 16 posts - 1 through 16 (of 19 total)

You must be logged in to reply to this topic.