Home Forums Weaver Xtreme Theme Weaver Show Posts suddenly not displaying correctly

This topic contains 5 replies, has 4 voices, and was last updated by  Weaver 4 years, 8 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #17472

    treacle
    Participant

    Hello
    Everything has been fine on the is page http://new.gmdf.org/cues/
    but after updating the plugin the page has suddenly started to display incorrectly in that the second row of posts shows blank in the left hand column and places the post on the next row.
    It displays like this in both Firefox and Chrome.
    If I remove the costume post from the list of posts to display the left hand column of the second row is blank.
    I didn’t touch any of the settings.
    many thanks
    Treacle

    #20559

    on4ya
    Participant

    I have the same problem, see link  http://www.on4ya.be/

    Many thanks,

    Robert
    #20560

    Weaver
    Keymaster

    Same problem, 2 different causes.

    The problem with Weaver Show Posts will be fixed shortly, and you should see an update notice for Weaver Show Posts plugin soon.

    The other is the same issue, but i in Weaver Xtreme 1.0.2.6, and unfortunately, that is not fixable quickly. I will endeavor to get a new version released as soon as possible, but it still may be a week or so, and longer before it is on WordPress.org.

    There is no exact workaround for either (but Weaver Show Posts will be updated very soon.). For @on4ya, I might suggest trying the Masonry option. That may not be the exact effect you wanted, but it will be correct in layout.

    All this was due to adding a feature to support using the nth-child CSS rule on posts to allow the FI to alternate left and right aligned. Failed to properly test that change’s affect on regular old multi-column layouts. My apologies.

    #20561

    scrambler
    Moderator

    Until it is fixed, you should be able to use the following rules.

    @treacle
    Add the rule below in Main options > Fonts & Custom > Custom CSS Rule box for now

    .atw-show-posts .atw-content-3-col:nth-of-type(3n+1) {clear:both;}

    @on4ya Add the rule below to the same location But you will need to try 2n+1  or 2n as there is something strange on your page

    #content .content-2-col:nth-of-type(2n) {clear:both;}

    @weaver, there is something I don’t understand on on4ya’s page, the second rule for the 2 columns should be using nth-of-type(2n+1) , but for some reason, when I test 2n is what works on his page, I have no idea what is going on.

    If I do a test page on my test site, the rule that works is the one using 2n+1  as it should

    EDIT-1: Testing some more, it appears that if the navigation is present 2n is what works, but if the navigation is not present, 2n+1 is what works.

    It is like the navigation is counted as one element although it does not carry the content-2-col  class. I must be missing something about the logic of that CSS, will keep digging

    EDIT-2: I just realized that nth of type does not care about the class… It is only caring about the HTML tag so in that case divs, which explains why if the Navigation is there, you need to use 2n.  Because the navigation counts as the first element type.

    #20562

    treacle
    Participant

    Many thanks, page now displaying correctly – will watch out for update etc.
    Thank you
    Treacle

    #20563

    Weaver
    Keymaster

    The fact that nth-of-type “counts” all divs was what caused this whole problem to begin with. Tried to change a div to a span which worked some of the time, but broke others.

    The new version does the clear:left in the wrapping div rather than trying to add a new one.

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.