Home Forums Weaver Xtreme Theme Weaver show posts is showing wrong category

Topic Resolution: Resolved

This topic contains 12 replies, has 3 voices, and was last updated by  TheBean 1 week ago.

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #51833

    TheBean
    Participant

    Weaver Xtreme is my goto theme (always)

    I have a page where I’m listing posts in a specific category [show_posts filter=before-you-start]

    two of my posts are being listed however a third post that is NOT part of the ‘before you start’ category, is also being listed.

    I’ve removed all the categories for that one post (still shows up)
    I’ve check the categories table and only the 2 posts are listed (as expected)

    Why does this post think it belongs on that page? (sorry having a confusing day today for some reason)

    Using WP 4.8.2 and Weaver Xtreme 3.1.9
    I cleared the cache

    This is the post in question
    http://websitedesignanswers.com/how-to-register-your-website-name

    This is the page with posts
    http://websitedesignanswers.com/start-at-the-beginning

    As always …. thanking you in advance
    B

    #51834

    Weaver
    Keymaster

    I am unable to reproduce this on my test site.

    I can see that the page you link is showing an extra post, but I can’t guess why.

    #51835
    Private Reply

    Weaver
    Keymaster
    This reply has been marked as private.
    #51838
    Private Reply

    TheBean
    Participant
    This reply has been marked as private.
    #51844
    Private Reply

    TheBean
    Participant
    This reply has been marked as private.
    #51849

    scrambler
    Moderator

    I remember having problems with category names that have dashes (or underscore, not sure which).

    I would also try to get rid of these

    #51861

    TheBean
    Participant

    Good Thinking!!!! Will do that first thing!

    #51877

    TheBean
    Participant

    I’m STUNNED… still no luck
    I changed the category name/slug to 1 word
    I deleted the post that keeps showing up
    I recreated and saved the post under a different URL
    I changed the URL and updated the shortcode with the proper category name on the page that contains the posts in the ‘starting’ category.

    The new post/url is now showing up on that page

    http://websitedesignanswers.com/read-this-first/

    Your problem client….
    B

    #51878

    scrambler
    Moderator

    Can you give us the detailed shortcode that shows up at the top of your filter page.

    Not the one that has the filter name, but the one that shows all the options.

    Also is the post that should not be there the first one, which is the one in the registering category?

    Any chance you have a plugin that forces that post to be on every post page?

    Try to deactivate ALL non weaver plugin, and see if that fixes the issue.

    #51879
    Private Reply

    Weaver
    Keymaster
    This reply has been marked as private.
    #51883
    Private Reply

    TheBean
    Participant
    This reply has been marked as private.
    #51884

    scrambler
    Moderator

    I asked you for the shortcode that shows the options, not the filter name…

    #51885
    Private Reply

    TheBean
    Participant
    This reply has been marked as private.
Viewing 13 posts - 1 through 13 (of 13 total)

You must be logged in to reply to this topic.