Home Forums Weaver Xtreme Theme Weaver Plus installation failing because of missing style.css

Topic Resolution: Resolved
Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
  • #71914

    I am trying to install the weaver theme plus on a site that had the free weaver theme previously installed  but am getting the following message:


    Installing theme from uploaded file: weaver-xtreme-plus-4-0 (1).zip
    Unpacking the package…

    Installing the theme…

    The package could not be installed. The theme is missing the style.css stylesheet.

    Theme installation failed.


    I have been able to successfully upload the pro version on other sites and am at a a loss as to why I am having this problem. Please urgently assist. I am needing to work on this site

    MODERATOR’S NOTE: This is a fairly common “problem”. Weaver Xtreme Plus is a PLUGIN, and needs to be installed as a Plugin.



    What is the site URL?


    The site url is https://industryhelp.co.za

    I have tried the following:

    1. I removed the wordpress installation completely for  industryhelp  and installed a clean copy. Same error message when trying to install the pro version of the theme

    2. Installed the free version (no problems) and then tried installing the pro version (same error)

    3. Uploaded the necessary plugins for the free weaver  and then tried installing the pro version (same error). (no other plugins were uploaded)

    4. I downloaded another version of the theme from your licences page in case the one I was using had become corrupt somehow and repeated the above steps, same error.


    I have successfully uploaded the pro version on other sites on the same server and had no problems.

    Any help would be appreciated



    I also tried loading the pro version on this debug site:


    and I get the same error


    Have you tried load Xtreme+ with all plugins deactivated?


    Yes. I deleted the site and did another clean install of wordpress. Before uploading the weaver pro theme I made sure that there were no plugins whatsoever installed. Same error messsage


    I’ve figured out what was wrong (terribly embarrased – So sorry), I was trying to upload the file as a theme file when I should’ve been uploading it as a plugin! Well at least my mistake will teach others :-). Thank you for your help.


    Welcome to the Club…..! 🙂

    Been there…. done that too!

    So glad this story has a happy ending 🙂

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.