Home Forums Weaver and Plugin Interaction Weaver Main Menu overlays lightbox from Lightgallery plugin

Topic Resolution: Answered

This topic contains 2 replies, has 2 voices, and was last updated by  Ned 3 weeks, 1 day ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #61465
    Answered

    Ned
    Participant

    Purchased this plugin extension, https://dfactory.eu/products/lightgallery-lightbox/, for lightbox / slideshows.

    The Weaver Main Menu displays in front of (evidently higher z-index) the lightbox.

    You can see this anomaly here: https://staging2.imagined.com/blog/daybreak-window-photo-series/
    (click any photo in the gallery to launch the slideshow)

    How can this be fixed? Lower the z-index of the main menu?

    Here’s my config info:

    ### Weaver System Info ###

    — WordPress Configuration —

    Site URL: https://staging2.imagined.com
    Home URL: https://staging2.imagined.com
    Multisite: No
    Version: 5.2.2
    Language: en_US
    WP_DEBUG: Disabled
    WP Memory Limit: 128M
    Permalink: /blog/%postname%/
    Show On Front: page
    Page On Front: Conceptual Artistry with Memes, Puns, Quips and Imagery (ID# 309)
    Page For Posts: (ID# 0)
    Current Theme: Weaver Xtreme (4.3.1.5)
    Post Types: post, page, attachment, revision, nav_menu_item, custom_css, customize_changeset, oembed_cache, user_request, wp_block, jp_mem_plan, rl_gallery, jp_pay_order, jp_pay_product

    — Weaver Xtreme Configuration —

    Weaver Xtreme Version: 4.3.1.5
    Theme Support Version: 4.0.3
    Xtreme Plus Version: 3.1.1

    — Server Configuration —

    Operating System: Linux
    PHP Version: 7.1.30
    MySQL Version: 5.6.40
    jQuery Version: 1.12.4-wp
    Server Software: Apache

    — PHP Configuration —

    Local Memory Limit: 768M
    Server Memory Limit: 768M
    Post Max Size: 128M
    Upload Max Filesize: 128M
    Time Limit: 120
    Max Input Vars: 3000
    Display Errors: On (1)

    — WordPress Active Plugins —

    Akismet Anti-Spam: 4.1.2
    Classic Editor: 1.5
    Easy Columns: v2.1.3
    Fast Secure Contact Form: 4.0.56
    Jetpack by WordPress.com: 7.6
    Responsive Lightbox & Gallery: 2.1.0
    Responsive Lightbox – Justified Gallery: 1.1.2
    Responsive Lightbox – Lightgallery: 1.1.1
    Responsive Lightbox – PhotoSwipe: 1.1.2
    SG Optimizer: 5.2.5
    Twitter Widget Pro: 2.9.0
    Weaver Show Posts: 1.3.16
    Weaver Xtreme Plus: 3.1.1
    Weaver Xtreme Theme Support: 4.0.5
    Wordfence Security: 7.4.0
    Yoast SEO: 11.9

    — WordPress Inactive Plugins —

    ### End System Info ###

    #61466

    scrambler
    Moderator

    You need to set the z-index of the gallery higher than the menu.

    If you have an option for that in the plugin, use 2000.

    If not, add the rule, below to the Theme Global Custom CSS Rule box

    .lg-outer {z-index:2000;}

     

    #61467
    Best Answer

    Ned
    Participant

    This reply has been accepted as the best answer.

    Thank you so much, scrambler. That worked, almost. We needed another rule. Here’s the code that worked:

    .lg-backdrop {z-index:2010;}
    .lg-outer {z-index:2020;}

    Thank you again for the fast response on a holiday weekend.

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.