Home Forums Weaver Xtreme Theme Weaver Extreme & Theme support plugin inoperable

Topic Resolution: Resolved

This topic contains 10 replies, has 3 voices, and was last updated by  Weaver 3 months, 1 week ago.

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #53282

    sasman
    Participant

    Having updated both the theme & support plugins, I now cannot access my WordPress site, until removing the support plugin via  my hosting site, then find the customiser locks up the site on clicking the X (exit)

    Having just paid for the update of my licences, yet cannot work with the software provided

    I have deactivated all plugins and still no luck

    Is there a solution to this, or is it time to look elsewhere?

     

    #53286

    scrambler
    Moderator

    A few things.

    • Do you mean the weaver Xtreme Theme support plugin?
    • Do you mean you also have the Plus Plugin.
    • Can you list the versions of all three (theme and both plugin).
    • Do you get any specific error message when trying to access the site?

    Also, can you do Copy paste the content of the system and configuration info box from the Theme page.

    One thing to try, is:

    • Save your settings and download a copy from the save / restore page for good measure.
    • Switch to a different Theme.
    • Delete all Weaver theme and plugins
    • Deactivate all other plugins
    • Reinstall & activate Weaver Xtreme latest version from WordPress.org. make sure all works
    • Reinstall & Activate Xtreme Theme Support plugin from WordPress.org. Does all work fine?
    • If so, reinstall and activate Xtreme Plus plugin.
    • Then reactivate your other plugins.

     

    #53287

    Weaver
    Keymaster

    We are not getting other reports of this sort of behavior, so there should be a way to get  these working again.

    First, you have not given much information.

    But something else must have changed other than a simple update of Weaver Xtreme and support plugin. Perhaps your host updated to a newer version of PHP? Perhaps some of the PHP memory limits were changed (this is the only know reason known to make the Customizer have issues.)

    Try switching to another theme (such as a WP Twenty-something theme), deleting the Weaver theme and plugins, then reinstalling them. You should not lose any information as the settings are stored in the WP database. Since you can’t get the support plugin to work, then you can’t save settings to your own computer.

    Another thing to try (perhaps first) it so examine the errorlog file on you host for this domain. That may have messages that show where things are failing.

     

    #53289

    scrambler
    Moderator

    @weaver

    “Since you can’t get the support plugin to work, then you can’t save settings to your own computer”

    Are you saying that the save restore options in the customizer also rely on the theme support plugin ?

    #53296

    Weaver
    Keymaster

    Customizer wasn’t working either, if I read that correctly. But the Customizer version is independent of the legacy plugin.

    #53333

    sasman
    Participant

    It is weaverx-theme-support that is causing the problem, as soon as that is uploaded and activated, I get an Internal Server Error

    All plugins have been deactivated, apart from the relevant Weaver ones

    My php version is 7

    Re Customiser, it appears to be working, whilst working within it, but upon leaving, the Internal Server Error appears again

    Everything is fine until weaverx-theme-support is uploaded

    #53354
    Private Reply

    Weaver
    Keymaster
    This reply has been marked as private.
    #53386

    sasman
    Participant

    I have now updated other sites to Extreme Theme 3.1.12, Extreme Plus 3.1.1 and Theme support 3.1.11 and found that Theme support on any update since 3.1.8 brings up an Internal Server Error and states it is unable to complete my request

    #53428

    Weaver
    Keymaster

    @sasman,

    Don’t know if you’ve given up on this, or found a solution, but I’ve not heard back regarding my previous private message.

    #53429

    sasman
    Participant

    Apologies, but have found the solution, I updated the PHP to version 7 and everything worked

    #53431

    Weaver
    Keymaster

    Thanks – I don’t understand what the issue might have been as the current versions of Weaver and plugins work under PHP 5.4. But good to know that for once, an upgrade to a newer version of PHP fixes things instead of breaking them!

Viewing 11 posts - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.