Home Forums Weaver Xtreme Theme Weaver Extreme – Header shows in multiple places on a post

Topic Resolution: Resolved
Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #64695
    Chinwagger
    Participant

    Weaver Extreme – Header shows in multiple places on a post

    I want to be able to use a Featured Image as the header of a blog page. I appear to be able to do this just fine. However a copy of the same image appears as the first image in my blog. I don’t want this I would like it to be my Featured image my Page header image and nowhere else on the blog.

     

    I am using Weaver Extreme

     

    I have a couple of Widgets in the side bar Content Block x 2 and Sub Categories both of these show the same picture so it appears 4 times on a blog very frustrating.

    #64696
    scrambler
    Moderator

    You don’t explain what method you used to do what you wanted.

    The proper method would be to do the following:

    Make sure you are not using the WP default blog page by going to Settings > Reading, select “a static page” for your home page, and make sure NOTHING is select in the posts page drop down list (showing -select-)

    Then create your blog page using the “page with posts” template.

    Then select a featured image for that page (bottom right of the page editing page), and then in the Xtreme options for this page > Layout tab, > Featured image drop down list, select header image replacement.

    That should only make that image be used as the header replacement on that page.

    Alternatively, you can create a blog page using a regular page based on the Default template and  show posts shortcode(s). but changing the header on that page would be done the same as the above.

    If that does not work, please provide a link to the page showing the issue and explain what method you chose as well as how you created your blog page.

    #64698
    Chinwagger
    Participant

    Weaver Extreme Header shows in two places.

     

    I want to be able to use a Featured Image as the header of a blog page. I appear to be able to do this just fine. However a copy of the same image appears as the first image in my blog. I do not want this I would like it to be my Featured image and my Page header image and nowhere else on the blog.

     

    Example of Blog Page Exploding Wheel Barrows

     

    I am using Weaver Extreme

     

     

     

    To achieve my aim

    My Home page is a fixed static page with a specific layout including a video header and TABS

     

    My Post Page is – Select –

     

    Customise – Images – Post Specific – Feature Image Location – Full Post – Header Image Replacement

    Customise – Images – Page Specific – Feature Image Location – Full Post – Header

     

    On the actual Post in the Weaver Xtreme Options for this post as below

     Specific Page Options

     

    That’s it

     

    I do not have any page templates other than the normal WordPress templates and cannot find how I would even include them. Nothing in the documentation I read told me where to go to make them happen.

     

    I have a couple of Widgets in the side bar Content Block x 2 and Sub Categories both of these show the same picture so it appears 4 times on a blog very frustrating.

    #64699
    scrambler
    Moderator

    There seem to be some confusion on terminology here.

    the link you gave me is NOT a blog page, it is a single Post page.

    So are you saying you want all single post pages to use the post featured image as the header image replacement?

    If  so are you saying that you do not want that featured image to show in Blog pages (pages showing all posts as excerpts) or post widgets?

    If so, then go to Main options > Post Specifics > Featured image section.

    Then in FI locations- Excerpts  AND FI locations- Full posts select “hide on blog view ”

    And on FI locations- Single Page select “Header Image replacement”

    This will  use the post featured image as the header on the Single post page, but hide the featured image from the blog page and widget

    In the customizer these settings are Images > post Specifics > Featured Image – Full Blog Posts set to Hide on blog page

    Images > post Specifics > Featured Image – Excerpt Posts set to Hide on blog page

    Images > post Specifics > Featured Image – Single page set to Header Image replacement

    #64700
    Chinwagger
    Participant

    Sorry about the confusion in type I didn’t know there was a difference. It is a single Blog Post or in WP terminology a Post.

    I want this post to have the Featured Image as the Header for the Post I do not need it to show anywhere else in the post.

    I followed your instructions below is the setting from Weaver Xtreme Admin

     

    Changes to FI

    However when I go to the Customizer I don’t have the same options its quite different. I do not have the options you say

    Images > post Specifics > Featured Image – Full Blog Posts set to Hide on blog page – This option does not exist. It doesn’t exist anywhere in the customizer

    Images > post Specifics > Featured Image – Excerpt Posts set to Hide on blog page. This option does not exist in customizer.

    So I’m at a loss, what you are telling me makes sense I just don’t have that option on Weaver Extreme am I missing something here?

     

    Regards

     

    Vic

     

     

     

    #64701
    scrambler
    Moderator

    I cant think of a way you would have different options in the customizer.

    DO make sure that at the top of the customizer you have Weaver Interface level set to FULL.

    Also make sure you have the latest versions of everything

    Theme:
    Weaver Xtreme Version: 4.3.4
    Plugins:
    Theme Support Version: 4.0.3
    Xtreme Plus Version: 3.1.1

    Eventually take a screen grab of the customizer options under Images > Post Specifics

    In the mean time, you can set the options in the Legacy interface (Main options > Post Specifics)

    #64702
    scrambler
    Moderator

    That said, the image of the Wheelbarrow in the post itself does not appear to be a featured image, but an image inserted in the content.

    Are you sure you have not inserted the image in the post content?

    If not, the image also has a strange class pf-content that I don’t recognize as a weaver class, Are you using a plugin by any chance that would be interfering?

    To be sure, deactivate ALL non weaver plugins and see if that makes a difference

    #64706
    Chinwagger
    Participant

    Scrambler,

    Thank you so much for your time and effort on my behalf, you are correct the I have a plugin Featured Image from URL, switching it off solved my problem. It has some options I will try and see if I can make it work with the theme but otherwise, I will ditch it.

     

    Thanks

     

    Chinwagger

     

     

     

    #64707
    scrambler
    Moderator

    If there are things the plugin was doing you still need, explain in details and we can check if we can figure a way to do that

    #64708
    Chinwagger
    Participant

    Scrambler,

    Thank you for your offer, I am successfully running Feature Image from URL and Weaver with the correct result, my previous URL will show that. I have all my photos and videos on other websites. Smugmug handles most of them, I use this and don’t store on my server as I have extremely limited space. I found that the combinations of options were causing my problems, I hadn’t configured Weaver or FI from URL properly and with your help I found my way around the issues. Thanks again

     

    Regards

     

    Chinwagger

Viewing 10 posts - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.