Home Forums Weaver Show Posts & Show Sliders Vimeotheque Videos

Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #64059
    AlanW
    Participant

    Hi,

    I installed the Vimeotheque Lite plugin for a client to pull in their Vimeo videos. When importing, the plugin creates it’s own content type, categories, and tags in WordPress. Everyting shows correctly on the video page.

    The problem is that when creating a ‘Weaver Show Posts’ filter, with the setting “display posts as full post”, it does not display the actual video, only the title and part of the content.

    Your help is greatly appreciated.

    #64061
    Weaver
    Keymaster

    Can you provide a link to a site for both the working page and the show posts page?

    To otherwise answer this question (and we still may not have an answer) would be to install and learn the plugin, create a page, hope we duplicated your settings, etc. That is beyond the level of support we can provide.

    #64063
    AlanW
    Participant

    Sure:

    Video Test

    The link to the source post is linked in the paragraph.

    #64064
    scrambler
    Moderator

    The link you gave us is https://lamiradanazarene.org/

    That page which is not a weaver site, does not seem to contain a weaver show post shortcode either.

    Are you sure this is the link to the page with the showpost shortcode?

    The 8 images at the bottom come from a widget with the class pt-cv-wrapper

    #64065
    AlanW
    Participant

    It seems that the post altered the link. Here’s the page:

    lamiradanazarene.org/video-test

    It has a Weaver shortcode.

    #64066
    scrambler
    Moderator

    Do you know if these posts are regular WordPress post or special custom Post Types generated by the plugin?

    If you go to the filter, can you copy paste what is next to “Shortcode using parameters” located at the top of the filter page.

    It shows the shortcode in a form that lists all its options.

    #64067
    scrambler
    Moderator

    Also have you tried to play with the option called “Disable automatic post display integration with Weaver Themes.

    at the top (on or off)?

    #64069
    AlanW
    Participant

    Hi Scrambler,

    The source page is a special post type created by the Vimeotheque plugin.

    I’ve updated the page with both versions of the Weaver shortcode. Using all parameters actually outputs a bit more of the content, but still no video.

    As for the “Disable automatic post display integration… ” I did not find that option anywhere in the filters tab.

    Video Test Link

     

    #64070
    scrambler
    Moderator

    I would asked the plugin developer if they can think of a reason why the video content is not added.

    I suspect they have a way to add that content that somehow does not work with show posts. Given they are the ones who know how their plugin works, they are the better placed to figure out what is going on.

    Once the issue is identified, @weaver can determined on what side the fix should be implemented.

    #64071
    AlanW
    Participant

    Here’s a screenshot of the vimeo-video post type:

    Screenshot

     

    #64075
    AlanW
    Participant

    I’ve sent a message to the Vimeotheque team to see if they can shed some light into the issue:

    Vimeotheque Forum Topic

     

    #64076
    AlanW
    Participant

    So here’s Vimeotheque’s plugin author’s answer:

    Hi,

    Vimeotheque embeds the video by using the “the_content” filter. If your plugin doesn’t trigger “the_content” filter when it displays the post, the video won’t be embedded.

    Let me know if there’s anything else I can help you with.

    #64077
    scrambler
    Moderator

    Thank you, that should help @weaver.

    #64098
    Weaver
    Keymaster

    I suspect there is a fairly low level conflict with how show_posts and their video plugin uses the_content filter.

    It probably is related to embedding a shortcode within a shortcode. Normally, show_posts doesn’t have an issue with using shortcodes within a post.

    I do know that [show_posts] will show full posts that have other shortcodes. It is possible that there is some order sensitivity on when the plugins are used.

    I looked at Vimeotheque, and it is really too complicated to get running to make it worth my time to see if I could figure out a workaround.

    Short answer: I am unable to ensure that show_posts works with Vimeotheque, especially for non-Weaver themes.

    Sorry.

Viewing 14 posts - 1 through 14 (of 14 total)
  • You must be logged in to reply to this topic.