Home Forums Weaver Xtreme Theme Viisual Editor Issues

This topic contains 30 replies, has 9 voices, and was last updated by  netgreen 2 months ago.

Viewing 15 posts - 17 through 31 (of 31 total)
  • Author
    Posts
  • #50443
    Private Reply

    businessnaples
    Participant
    This reply has been marked as private.
    #50543

    knucklas
    Participant

    I also have this issue. It is very frustrating.

    #50544

    knucklas
    Participant

    I just solved it – I deactivated Weaver Xtreme Theme Support (3.1.8) and it was solved. Then re-activating it left the visual editor working!

    #50548

    businessnaples
    Participant

    This knucklas  solution did not work for me. Deactivating did not solve the problem nor did reactivating. When I deactivate the Weaver Plus plugin the problem is resolved but reactivating just causes the problem to return.

    #50554

    Weaver
    Keymaster

    I am working on this. Likely has something to do with recent WordPress changes to how it uses TinyMCE editor.

    #50555

    Weaver
    Keymaster

    The problem seems to be related to loading a font picker on the visual editor tool bar.

    There is a work around for now – requires Weaver Xtreme Theme support plugin.

    On the Appearance : Weaver Xtreme Admin : Advanced Options : Admin Options page, check:

    Disable Page/Post Font Family/Size Selection – Checking this box will disable the Weaver Xtreme Plus Font Family and Size options in the Page/Post editor. This option does not apply to the base Weaver Xtreme theme

    That removes that button, but the visual editor works. Should be able to find a fix soon.

     

    #50561

    Weaver
    Keymaster

    @businessnaples

    I found the issue – and it is not the theme, but rather bad values when you added the Spinnaker google font.

    The correct values for Spinnaker should be:

    <link href=”https://fonts.googleapis.com/css?family=Spinnaker” rel=”stylesheet”>

    and

    font-family: ‘Spinnaker’, sans-serif;”;

    Your values were:

    <link href=”https://fonts.googleapis.com/css?family=Allura|Spinnaker” rel=”stylesheet”>

    and

    font-family: ‘Spinnaker’, sans-serif;
    font-family: ‘Allura’, cursive;”;

    Apparently TinyMCE (the visual editor) does not like getting two fonts at a time. Each font must be added separately. I will try to add some check to the Font interface to prevent this in the future.

    I changed the setting on your site to use the correct Spinnaker entry. If you also want Allura, you will have to add it separately.

    But – this was not exactly a theme error – just a failure to completely validate the data provided.

     

    Thank you for providing access to your site to check this out.

     

    #50562

    businessnaples
    Participant

    Thank you very much for finding and fixing this. I could have never found it! This is why I use Weaver Themes for all my sites! Great support!

    #50563

    Weaver
    Keymaster

    After looking at the Weaver font interface, it does say add only one font at a time, but it is not very obvious. But really, having invalid font specifications for a font provided to TinyMCE should not make it fail. I’m guessing the bug in TinyMCE was having the font-family specification on separate lines, but who knows.

    I made the “only one font” note a bit more obvious, and will check for more than one theme specification per <link> value. Having more than one font selected from the Google Font interface is relatively new – and it is natural to simply copy the values for the Weaver link/font-family fields when you’ve selected a couple of fonts. Hopefully your experience will help prevent this for other users in the future, and will also help us provide an alternate suggestion for why the visual editor doesn’t work.

    #50712

    Miriam
    Participant

    I’m also having the same issue with the Visual Editor (tab is there but will not activate on click).

    I have not checked off “Disable Visual Editor..” or “allow raw html” on Post Editor Options.

    This issue happened after I installed and activated the Weaver Show Slider Plugin.

    This issue goes away when I deactivate the Weaver Xtreme Plug Plugin.

    http://mirsites.com/test-joyrenc/
    I have WP 4.7.5, Weaver Xtreme 3.1.8, Theme Support 3.1.8, Xtreme Plus 3.1.1

    Thank you.

    *** UPDATE – I just read @weaver most recent reply about adding two fonts at a time. OOPS, I did this too!  Where do I go to correct this?

    #50713

    Miriam
    Participant

    I figured it out.  I used the inspect tool in Chrome to look at the <head> section.

    Like @businessnaples, I had added two fonts at the same time, which resulted in this:

    <link href=”https://fonts.googleapis.com/css?family=Oregano|Roboto” rel=”stylesheet”>

    and

    <link href=”https://fonts.googleapis.com/css?family=Oregano” rel=”stylesheet”>

    My list of added fonts showed both fonts – Oregano and Roboto – but there was no separate <link href…> for Roboto.

    I checked the Roboto font to delete it.

    And the Visual Editor was restored!

    Thank you so much @weaver for finding the needle in the haystack.

    #50721

    Weaver
    Keymaster

    The next release of Weaver Xtreme Plus will be able to detect when you’ve specified more than one font and warn you.

     

    But the only solution now is to delete the font that is listed (probably the first one in the multiple added list), and then readd each font one at a time.

    #50761

    dogwebs
    Participant

    I have had a similar issue, the background color and text color in the visual editor would not change when updated inder Page/Post Editor BG:

    I have just rolled back the Weaver Xtreme Theme Support plugin to 3.1.6 and it now works again.

    Just tested this in firefox, edge and IE it only appears it was an issue in Chrome.

    #50766

    Weaver
    Keymaster

    @dogwebs – I don’t think your issue was related to the font issue.

    #51009

    netgreen
    Participant

    Thanks, Weaver, this fixed my problems with the visual editor as well!

Viewing 15 posts - 17 through 31 (of 31 total)

You must be logged in to reply to this topic.