Home Forums Weaver Show Posts & Show Sliders Vertical Scrolling

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #18174
    computers
    Participant

    I have setup a couple of sliders on my home page. One of which is set to scroll vertically. However it does not scroll evenly, as in the Excerpt, one to the next one. Instead it scrolls most of the way but leaves or includes the last or next post. Can’t seem to find anyway to fix it, ie. adjust the box size perhaps.
    I would put my URL on here for you to view, but every time I do this my site gets seriously bombarded with attempted hack ins.

    Also what I really wanted was the vertical scroller, but to display 2 or 3 items at a time. In this case would not mind if it only partially got the last post so long as when it scrolled it stopped evenly at the top of the box area, for that post. Which is what is NOT happening now with the single item.

    Look forward to your advice, thanks.

    #24181
    scrambler
    Moderator
    Really hard to figure out what you mean or what may be going on without seeing the site.
    I dont believe you can do a vertical carousel either.
    #24182
    computers
    Participant

    Slider Options/Type Set to; Slider – one item, slide to next

    Check box, Ticked. Use Vertical sliding for single-image Slider Type (not Fader or Carousel). Only looks good with borderless, equal height slides.

    All in the Sliders Tab.
    Can you give a PM or something so I can give you the address.

    #24183
    scrambler
    Moderator

    You can PM me by clicking on scrambler.

    But if your issue is that you see a piece of the other image with the current image, I believe I have reproduced your problem here.

    Link removed (no longer valid)

    If this is your problem, It looks like it may be a BUG. @weaver will have to look at it.

    Weaver, The test page above has a simple slider made with a group of slider posts each containing one image. There are no borders and all images are the exact same size, yet, the height of the slider is OFF, causing an increasingly bigger piece of the previous image to show at the top of the current image.

    #24184
    computers
    Participant

    Hi Scrambler.
    Will PM you with the URL in a moment.
    Yes that is essentially the issue, except I’m doing the same thing with post’s rather than the images, but the same result.
    PM Sent
    Thank you

    #24185
    Weaver
    Keymaster

    There is an issue with Vertical Scrolling – Flex Slider has some trouble with margins on the vertical sliding. For now, the fix is to set the “border width around slider” option to 0 for vertical sliders. The 1.3.1 release (about to do that) will have that automatically enforced. There might be a different CSS solution, but it would have to be unique for vertical scrolling.

    #24186
    scrambler
    Moderator
    I had only checked the option “hide the border shadow around slider” thinking that was enough.
    But I confirm that putting a zero in the px border width box just above that does fix the issue
    #24187
    computers
    Participant

    Hi.
    I have updated the Waever updates this morning, but this has not fixed the issue.
    There seems to simply be an issue where the slider has no definition to stop at the top of the next post, like the horizontal scroll has. AND OR being able to adjust the box size, may help of fix the issue.
    Yes have made sure all border etc have been turned off and added “0”px to border width.
    Any advice please

    #24188
    scrambler
    Moderator
    As I said if the posts are not all the same width there may be an issue.
    To see if we can do something about it, give us a link to the page with the slider
    #24189
    computers
    Participant

    Scrambler. I have set any width’s in anyway. I’m not sure what you are referring too, when you say Post width’s?

    I did give a link to the page via PM the other day.

    #24190
    scrambler
    Moderator
    Sorry, I meant Height…
    I did test a post slider with vertical, scrolling, and if all the posts have the same height it works. But if some posts are higher than other it wont.
    Eventually we can add CSS to impose a minimum height for all posts, but that will only work when the browser is as wide as the site. When the browser gets smaller and the text needs to reflow, the posts will increase in size and wont be the same height any more.
    The only solution I see if to set a fixed height for the posts and let  a vertical scroll bar come up if the posts becomes higher than that fixed height when the browser gets smaller
    You would do that by adding the rule below in The SLider Custom CSS box ( at the bottom of the slider options).
    .this-slider .slide-content {height:300px !important;overflow-y:auto;}
    Adjust the height to be as tall as the tallest posts, so that on a large browser there wont be a scroll bar.
    #24191
    computers
    Participant

    Problem is Totally solved. Adjusted the height to 400px and it even works great on my phone.

    #24192
    computers
    Participant

    Thanks Scrambler.

Viewing 13 posts - 1 through 13 (of 13 total)
  • You must be logged in to reply to this topic.