Home Forums Weaver Xtreme Theme Updating Plugins Since PHP 8 update

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #71575
    arctexas
    Participant

    Hi,

    I love Weaver Xtreme. Since I updated my php, I cannot update all my plugins. I do have several of them updated and working such as wp to twitter, xtreme plus, theme support, the various editors. However, when I go to update Yoast SEO, the system shuts down.

    When i go to the cPanel error messages, I find (these are from just a bit ago)

    “[Tue Jan 24 15:52:51.917593 2023] [authz_core:error] [pid 6867:tid 47758080964352] [client 112.217.190.170:44860] AH01630: client denied by server configuration: /home/arctx/public_html/2007

    [Tue Jan 24 13:20:14.879219 2023] [authz_core:error] [pid 6865:tid 47758064154368] [client 50.202.35.150:51874] AH01630: client denied by server configuration: /home/arctx/public_html/2006

    [Tue Jan 24 08:43:51.829560 2023] [authz_core:error] [pid 27781:tid 47758047344384] [client 84.226.106.115:40878] AH01630: client denied by server configuration: /home/arctx/public_html/2005

    [Tue Jan 24 06:38:23.858646 2023] [authz_core:error] [pid 27781:tid 47758070458112] [client 165.246.153.84:35700] AH01630: client denied by server configuration: /home/arctx/public_html/2005

    [Tue Jan 24 04:08:12.210054 2023] [authz_core:error] [pid 6867:tid 47758074660608] [client 59.148.249.146:32904] AH01630: client denied by server configuration: /home/arctx/public_html/2004

    [Tue Jan 24 02:05:16.294015 2023] [authz_core:error] [pid 6866:tid 47758089369344] [client 112.169.90.7:36509] AH01630: client denied by server configuration: /home/arctx/public_html/2004

    If I use File Manager to look at the structures, there are no folders 2004-2007

    I have to go into my WP database and tell the system no plugins are active.  Any ideas on what is going on?

    Thanks

    #71577
    scrambler
    Moderator

    Have you spoken to your host provider?

    #71578
    arctexas
    Participant

    Yes, unfortunately the problem only occurs with the Weaver, my other sites using other themes all work as they always did.

    #71579
    scrambler
    Moderator

    Someone had a similar problem recently and it turned out to be because her site had been hacked and some extra/corrupt files had been installed causing the problem.

    Easiest to try first, is to install the Wordfence Security plugin and run a scan of your site.

    You can also attempt a big cleanup by doing the following.

    • Save ALL your settings and download a copy for good measure.
    • Switch to a different theme like 2021
    • Deactivate and DELETE ALL weaver themes and plugins.
    • Redo the last WordPress Update.
    • Reinstall Weaver Xtreme from WordPress and activate.
    • Reinstall and activate Weaver Xtreme Theme Support PLUGIN and activate
    • Reinstall other Weaver plugins if you had any (Plus, showpost, showslider…)
    #71581
    arctexas
    Participant

    I’ll look into that, the folks at HostGator are looking at the issue again

    #71583
    arctexas
    Participant

    HostGator rolled PHP back to 7.1 and it fixed everything

    #71584
    Weaver
    Keymaster

    You should see if they can switch to PHP 7.2 as that is the only version still supporting PHP security updates.

    AND the new version of Weaver Xtreme (to be released very soon) will only work with PHP 7.2 or later due to some security updates.

    #71585
    Weaver
    Keymaster

    Note: if I try to run WordPress on anything before 7.4, I get this message on the WP Dashboard:

    Your site is running on an outdated version of PHP (7.1.33), which does not receive security updates and soon will not be supported by WordPress. Ensure that PHP is updated on your server as soon as possible. Otherwise you will not be able to upgrade WordPress.

    That is also why Weaver Xtreme 6.1 will require 7.4 – to match upcoming WP requirements.

     

    See this:

    Get a faster, more secure website: update PHP today

    #71586
    arctexas
    Participant

    Is there an ETA on Weaver 6.1?

    #71587
    Weaver
    Keymaster

    I’m hoping a couple of weeks. And due to this discussion, Weaver Xtreme will still work with 7.1, but note that WP itself will no doubt require 7.4 soon.

    #71591
    arctexas
    Participant

    Thank you

Viewing 11 posts - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.