Home Forums Weaver Xtreme Theme Updated to 4.4 – This theme failed to load properly and was paused

Topic Resolution: Resolved
Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #65762
    roadside
    Participant

    Just updated to 4.4 a bit ago and it crashed the site for some reason.  I had to go into recovery mode.  And it gave me the message “This theme failed to load properly and was paused within the admin backend.”

    Site comes back up if I set it to the stock 2020 theme.  Not sure what I should do to get Weaver Xtreme working.  I don’t have the Plus version, so it’s not a license key problem.

    In the customizer there’s no place to download my settings.  If I delete the theme and reinstall, will settings still be there or will I need to reset everything.

    Glad this happened when it did.  It’s on a staging site and happened just before I was going to push it live for a soft opening later today. 🙂

    Happy to hear any advice you might have here.  Thanks!

    #65763
    scrambler
    Moderator

    Normally if you delete the theme and plugins, then reinstall from scratch, all the settings will be back.

    That said it is always better to download a copy for safe keeping beforehand, but it seems you do not have that option.

    You also normally always have the option to restore your whoile installation from your ISP daily backups.

     

    #65764
    roadside
    Participant

    Thanks for the advice… Stupidly I had a back up of the settings that I took when I was tweaking some stuff and trashed it just yesterday thinking I wouldn’t need it.

    I’m going to try deleting the them and reinstalling to see how that goes.

    #65765
    roadside
    Participant

    Ok, here’s where I am now…

    – Deleted the theme and reinstalled from the WordPress repository.
    – Used Live Preview and it gave me the same error.
    – Disabled all my plugins and the Live Preview of the theme worked.  With all the settings still intact.  Yay!
    – Started turning plugins back on one by one and checking Live Preview each time to find a conflict.
    – Everything worked fine until I turned WooCommerce back on and then I got the same error again.
    – Turned Woo off, same error.
    – Turned off all the other plugins that I’d turned back on, same error.
    – Deleted and reinstalled the theme again, all plugins still off.  Same error.

    So, I don’t think it’s Woo related really.  I think that just happened to be the one that I’d turned on when it went haywire.

    Also, when I go to my Themes page is says Weaver is “installed but incomplete”.

    Thoughts on a next step?

    #65770
    Weaver
    Keymaster

    We tested Weaver Xtreme 4.4 on many sites, including this one had haven’t had issues, but others are. We did use the WP Repository version for the version on the forum, for example.

    You can get the 4.3.9 version of Weaver Xtreme here:  https://weavertheme.com/archive-downloads/

    Download it, then use the Appearance -> Themes menu to upload new theme, and use it to replace 4.4.

    We will hopefully be able to get access to a site with issues and find the issue.

    #65771
    roadside
    Participant

    Thanks… I’m responding to your email too.  I can drop down to the old version after you’ve had a chance to look at it.

    #65773
    Weaver
    Keymaster

    Our apologies for this issue!

    The issue seems to be fixed with 4.4.0.1 – a filename issue with the woocomerce-support.php filename. The accidental renaming of the file happened sometime after we had had tested the woo support. Really don’t know how that happened, but was likely related to keeping the 4.4 and the new 5.0 version underdevelopment in “sync”. There has been a phase of adding new 4.4 features that needed to be propagated to the new 5.0 development version.

    So this issue will affect only those using Woocommerce, which is probably why we haven’t been totally flooded with reports.

    #65779
    roadside
    Participant

    Looking good now!  Thanks for the assist!   Glad it was something fairly easy. 🙂

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.