Home Forums Weaver Xtreme Theme Trying to install Goldenbook font – not working

Topic Resolution: Resolved

This topic contains 5 replies, has 3 voices, and was last updated by  netgreen 1 week, 5 days ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #51379

    netgreen
    Participant

    I purchased the Goldenbook and Goldenbook-Bold fonts by Mark Simonson from MyFonts and I am trying to get it to work with your Weaver Xtreme Plus theme.  It appears to have installed OK as I can see and select the fonts whenever I choose default fonts in the Weaver theme admin options and when editing pages using the Visual Editor.  However, the font never appears on the pages!

    The CSS file that they provide has this code in it:

    /* @import must be at top of file, otherwise CSS will not work */
    @import url("//hello.myfonts.net/count/3446f1");
    
    
    @font-face {font-family: 'Goldenbook-Bold';src: url('webfonts/3446F1_0_0.eot');src: url('webfonts/3446F1_0_0.eot?#iefix') format('embedded-opentype'),url('webfonts/3446F1_0_0.woff2') format('woff2'),url('webfonts/3446F1_0_0.woff') format('woff'),url('webfonts/3446F1_0_0.ttf') format('truetype');}
     
     
    @font-face {font-family: 'Goldenbook';src: url('webfonts/3446F1_1_0.eot');src: url('webfonts/3446F1_1_0.eot?#iefix') format('embedded-opentype'),url('webfonts/3446F1_1_0.woff2') format('woff2'),url('webfonts/3446F1_1_0.woff') format('woff'),url('webfonts/3446F1_1_0.ttf') format('truetype');}
    

    Is there something special that I need to add to the Weaver Xtreme Plus Font Control section in order to make this work?  I just used this in box #2:

    <link href="webfonts/style.css?family=Goldenbook" type=“text/css” rel=”stylesheet”>

    and added the font-family code to box #3.  What am I missing?

     

    Thanks.

     

    #51382

    Weaver
    Keymaster

    I don’t think the url of “webfonts/style.css” is correct. That would mean there had to be a directory called webfonts added to the root of your WP site, but even if it was there, it would not work for all pages.

    The correct address would have to be some fixed location on your site if you are self-hosting the font files like url(//mysite.com/wp-content/uploads/webfonts/whatever…)

    The /wp-content/uploads directory is the proper place to put self-hosted fonts as that location is preserved over wp, theme, and plugin updates.

    If that doesn’t work, we’d need a link to your site to provide more help.

    #51392

    netgreen
    Participant

    I created the webfonts directory under /wp-content/uploads/fonts, so I assumed that it would start from there to find the webfonts directory. I’ll try specifying the full path to that directory in the .CSS file instead.

    #51393

    netgreen
    Participant

    I tried specifying the full path to the webfonts directory in the style.css file and still no joy.  (Actually, the .CSS file is named gb-style.css and is located in that same directory as the font files: /wp-content/uploads/fonts/webfonts/).

    The website is using a temporary URL until I can get this and a couple of other issues fixed: http://9aa.c05.myftpupload.com/

    Thanks!

    #51394

    scrambler
    Moderator

    I still see the file referenced with a relative url

    <link href=”webfonts/gb-style.css?family=Goldenbook”” type=“text/css” rel=”stylesheet”>
    <link href=”webfonts/gb-style.css?family=Goldenbook-Bold” type=“text/css” rel=”stylesheet”>
    <link href=”webfonts/gb-style.css?family=Goldenbook-Light” type=“text/css” rel=”stylesheet”>

    If you did change it to the full URL, may be try to clear your caches

    But you have a Quotes problem.

    There is a double double quote error in the first link (in yellow), and many of the double quotes are messed up asymmetrical ones (in blue)

    You must have cut and pasted from and editor that messes with the quotes.

    Retype all the double quotes properly

    #51399

    netgreen
    Participant

    That was it!  My source text apparently had “curly quotes” instead of straight quotes in it.  I deleted the font in the Weaver Xtreme Plus configuration and then used the following code to add it back in the Custom Fonts boxes 2 & 3:

    <link href='/wp-content/uploads/fonts/webfonts/gb-style.css' rel='stylesheet' type='text/css'>
    
    font-family: Goldenbook

    And now it’s working!

    Thanks!

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.