Home Forums Weaver Xtreme Theme Trying to fix “Warning! Your WP host server has only 32M of PHP Memory.”

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #68031
    MrWheeler
    Participant

    Greetings.

    I use the Customizer from time to time (excellent piece of work, as is the whole theme), but currently I’m afraid to try, and a little afraid to try other things that might be affected by the “32M” server limit reported for PHP. My site is stpeterregina.ca. I would be grateful if you would help me know what to do to fix this problem.

    I tried to find the cause of this low number, using my CPanel file manager/editor. Following instructions at https://guide.weavertheme.com/settings-wont-save-from-customizer, I also contacted my server’s tech support, who thereupon changed my PHP memory settings, but the error message “Your WP host server has only 32M of PHP Memory” persists in Weaver Xteme Admin – Help.

    It seems that the tech support person who tried to help me doesn’t know either. Curiously, the WordPress site health info report contains, “WP_MEMORY_LIMIT: 40M” and “WP_MAX_MEMORY_LIMIT: 512M.” I can’t find the cause of the “40M” limit either. (Is that related to the “32M” number reported by Weaver Xtreme’s report?) I will copy and paste below from some of my configuration files, then from “Weaver System Info,” and lastly from the WP site health info report. Thank you very, very much in advance.

    php.ini:

    allow_url_fopen = Off
    display_errors = Off
    enable_dl = Off
    file_uploads = On
    max_execution_time = 3000
    max_input_time = 3000
    max_input_vars = 3000
    memory_limit = 512M
    post_max_size = 1024M
    session.gc_maxlifetime = 1440
    session.save_path = “/var/cpanel/php/sessions/ea-php74”
    upload_max_filesize = 1024M
    zlib.output_compression = Off

     

    From .htaccess:

    php_flag display_errors Off
    php_value max_execution_time 3000
    php_value max_input_time 3000
    php_value max_input_vars 3000
    php_value memory_limit 512M
    php_value post_max_size 1024M
    php_value session.gc_maxlifetime 1440
    php_value session.save_path “/var/cpanel/php/sessions/ea-php74”
    php_value upload_max_filesize 1024M
    php_flag zlib.output_compression Off

     

    From user.ini:

    [PHP]
    display_errors = Off
    max_execution_time = 3000
    max_input_time = 3000
    max_input_vars = 3000
    memory_limit = 512M
    post_max_size = 1024M
    session.gc_maxlifetime = 1440
    session.save_path = “/var/cpanel/php/sessions/ea-php74”
    upload_max_filesize = 1024M
    zlib.output_compression = Off

     

    From wpconfig.php:

    Nothing related to PHP memory. I probably shouldn’t copy and paste what is there because of AUTH_KEY security considerations.

     

    ### Weaver System Info ###

    — WordPress Configuration —

    Site URL: https://stpeterregina.ca
    Home URL: https://stpeterregina.ca
    Multisite: No
    Version: 5.7.1
    Language: en_US
    WP_DEBUG: Disabled
    WP Memory Limit: 40M
    Permalink: /%year%/%monthnum%/%day%/%postname%/
    Show On Front: page
    Page On Front: Home (ID# 70)
    Page For Posts: (ID# 0)
    Current Theme: Weaver Xtreme (4.4.7)
    Post Types: post, page, attachment, revision, nav_menu_item, custom_css, customize_changeset, oembed_cache, user_request, wp_block, elementor_library

    — Weaver Xtreme Configuration —

    Weaver Xtreme Version: 4.4.7
    Theme Support Version: 4.4.5
    Xtreme Plus Version: 4.0

    — Server Configuration —

    Operating System: Linux
    PHP Version: 7.4.15
    MySQL Version: 5.5.5
    jQuery Version: 3.5.1
    Server Software: Apache

    — PHP Configuration —

    Local Memory Limit: 512M
    Server Memory Limit: 32M
    Post Max Size: 1024M
    Upload Max Filesize: 1024M
    Time Limit: 3000
    Max Input Vars: 3000
    Display Errors: N/A

    — WordPress Active Plugins —

    Elementor: 3.1.4
    Weaver Xtreme Plus: 4.0
    Weaver Xtreme Theme Support: 4.4.5
    WP Revisions Control: 1.3
    Yoast SEO: 16.1.1
    Zeno Font Resizer: 1.7.7

    — WordPress Inactive Plugins —

    Duplicator: 1.4.0

    ### End System Info ###

     

    
    ### wp-core ###
    
    version: 5.7.1
    site_language: en_US
    user_language: en_US
    timezone: -06:00
    permalink: /%year%/%monthnum%/%day%/%postname%/
    https_status: true
    multisite: false
    user_registration: 0
    blog_public: 1
    default_comment_status: open
    environment_type: production
    user_count: 1
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /home/stpeterr/public_html
    wordpress_size: 600.20 MB (629360067 bytes)
    uploads_path: /home/stpeterr/public_html/wp-content/uploads
    uploads_size: 16.40 MB (17194368 bytes)
    themes_path: /home/stpeterr/public_html/wp-content/themes
    themes_size: 9.65 MB (10120140 bytes)
    plugins_path: /home/stpeterr/public_html/wp-content/plugins
    plugins_size: 40.72 MB (42694499 bytes)
    database_size: 188.88 MB (198057472 bytes)
    total_size: 855.85 MB (897426546 bytes)
    
    ### wp-active-theme ###
    
    name: Weaver Xtreme (weaver-xtreme)
    version: 4.4.7
    author: Bruce Wampler
    author_website: //weavertheme.com/about
    parent_theme: none
    theme_features: core-block-patterns, automatic-feed-links, title-tag, post-thumbnails, customize-selective-refresh-widgets, html5, responsive-embeds, post-formats, wp-block-styles, align-wide, editor-styles, editor-style, custom-logo, custom-header, custom-background, menus, infinite-scroll, widgets
    theme_path: /home/stpeterr/public_html/wp-content/themes/weaver-xtreme
    auto_update: Disabled
    
    ### wp-themes-inactive (2) ###
    
    Twenty Twenty: version: 1.7, author: the WordPress team, Auto-updates disabled
    Twenty Twenty-One: version: 1.2, author: the WordPress team, Auto-updates disabled
    
    ### wp-plugins-active (6) ###
    
    Elementor: version: 3.1.4, author: Elementor.com, Auto-updates disabled
    Weaver Xtreme Plus: version: 4.0, author: Bruce Wampler, Auto-updates disabled
    Weaver Xtreme Theme Support: version: 4.4.5, author: wpweaver, Auto-updates disabled
    WP Revisions Control: version: 1.3, author: Erick Hitter, Auto-updates disabled
    Yoast SEO: version: 16.1.1, author: Team Yoast, Auto-updates disabled
    Zeno Font Resizer: version: 1.7.7, author: Marcel Pol, Auto-updates disabled
    
    ### wp-plugins-inactive (1) ###
    
    Duplicator: version: 1.4.0, author: Snap Creek, Auto-updates disabled
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_GD
    imagick_module_version: Not available
    imagemagick_version: Not available
    file_uploads: File uploads is turned off
    post_max_size: 1024M
    upload_max_filesize: 1024M
    max_effective_size: 1 GB
    max_file_uploads: 20
    gd_version: bundled (2.1.0 compatible)
    ghostscript_version: 9.25
    
    ### wp-server ###
    
    server_architecture: Linux 4.18.0-147.8.1.el7h.lve.1.x86_64 x86_64
    httpd_software: Apache
    php_version: 7.4.15 64bit
    php_sapi: cgi-fcgi
    max_input_variables: 3000
    time_limit: 3000
    memory_limit: 512M
    max_input_time: 3000
    upload_max_filesize: 1024M
    php_post_max_size: 1024M
    curl_version: 7.74.0 OpenSSL/1.1.1j
    suhosin: false
    imagick_availability: false
    pretty_permalinks: true
    htaccess_extra_rules: true
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 10.3.28-MariaDB-cll-lve
    client_version: mysqlnd 7.4.15
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /home/stpeterr/public_html/wp-content
    WP_PLUGIN_DIR: /home/stpeterr/public_html/wp-content/plugins
    WP_MEMORY_LIMIT: 40M
    WP_MAX_MEMORY_LIMIT: 512M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_LOCAL_DEV: undefined
    DB_CHARSET: utf8mb4
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    
    
    #68034
    scrambler
    Moderator

    Only your Host provider can raise that number, you need to reach out to them

    #68035
    Weaver
    Keymaster

    If you need more technical info, the 32MB limit displayed by the Weaver Xtreme report is obtaimed with the following PHP statement:

    $memlim = get_cfg_var( ‘memory_limit’ );

    That ‘memory_limit’ is imposed on how your host has PHP set up at its global level. All those other values may be from values that are set for your own account, but are superseded by the host server ‘memory_limit’ value.

    #68037
    MrWheeler
    Participant

    Great to know. Thank you very much again! I will pass these things on to support, hoping they can bring it up to at least 128M.

    Have a great weekend!

    #68046
    Private Reply
    MrWheeler
    Participant
    This reply has been marked as private.
    #68048
    Weaver
    Keymaster

    I’m not sure why their values (from a tool called phpinfo) shows 512M but the call Weaver makes shows only 32.

    BUT – if you open the Advanced Options -> Admin Options from the legacy interface, there is an option

    Ignore Customizer PHP Minimum Memory

    that you can check to elminnate the message. I would use the legacy interface to cave your settings to a file (on your computer ro in the WP database) dand then try using the customizer. I don’t know if it is able toc check if there are saaving errors or not – that is why the warning message is shown because the customizer interface really has control over that.

    But if it seems to work, then it is likely all is okay.

    #68049
    MrWheeler
    Participant

    Right on. I have saved my settings on the server using Plus and on my computer. Every time I use your theme or learn more about it, I love it.

Viewing 7 posts - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.