Home Forums Weaver Xtreme Theme The Gutenberg Cover Block became broken with 5.5.0 and 5.5.1 with Weaver Xtreme

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #65275
    elrond532000
    Participant

    The Gutenberg Cover Block became broken with 5.5.0 and 5.5.1 with Weaver Xtreme.  It worked fine on earlier releases.  The Covers don’t appear centrally on the page, they are being pushed to the right. This appears to be the case for full, wide and central covers.  This causes a problem on mobile devices as the screen width is wider than the viewport, and of course, it looks wrong.

    It seems to be a 16px padding in the .wp-block-cover class which is making the cover block to exceed its correct size and pushes the cover outside its bounds.

    I tested this on the WordPress 2020 theme, and have no issues.

    The following plugins are active.

    Network Plugin Auditor Network Active

    Optimize Database after Deleting Revisions Network Active

    Weaver Xtreme Plus 3.1.1

    Weaver Xtreme Theme Support 4.0.5

    Wordfence Security

    WordPress MU Domain Mapping

    A sample website with Weaver Xtreme is here

    Sample Page

    #65285
    Weaver
    Keymaster

    That padding is in fact coming from WordPress itself. I created a test page, and can see the padding is breaking the centering fo any text over the image. My test cover image didn’t itself have anything to indicate the padding was an issue, but the overlay text certainly did not center properly. And your symmetric demo clearly show it.

    So adding a Custom CSS rule to your Weave Xtreme settings:

    .wp-block-cover,
    .wp-block-cover-image {
    padding: 0;
    }

    will correct the problem. This rule comes from the WP block style.css file from the /wp-includes/css/dist/block-library/style.css.

    That rule seems to be new in WP 5.5 (it is NOT in 5.4). I think it is a WP bug. You might try reporting this to WP directly, or ask on their forum. Doesn’t make sense why that would be added now.

    #65292
    Weaver
    Keymaster

    Follow up: I think I will add that rule to Weaver Xtreme since it clearly breaks things. Then we won’t have to rely on WP to fix it.

    But that won’t happen until Weaver Xtreme 4.4. I don’t have a specific time frame for release of that, but it is under development.

    #65301
    elrond532000
    Participant

    Yes, placing padding 0 fixed it for me while I was testing.

    The other comment I have to make though is, it does appear to work on the 2020 WordPress theme.  Yes, it does have the padding, but the display appears to line up correctly.

     

    See http://test1.habarigani.co.uk/

     

     

    #65302
    scrambler
    Moderator

    This is because when using align full and align wide, the layout is done with the theme CSS and that Full width CSS requires a zero padding to work properly.

    To compare things better, we would need to see the same layout choice for both Xtreme and the WP theme

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.