Home Forums Weaver Xtreme Theme Suddenly the mobile menu shows as “undefined” instead of the hamburger icon

Topic Resolution: Resolved
  • This topic has 27 replies, 4 voices, and was last updated 1 month ago by LMur.
Viewing 16 posts - 1 through 16 (of 28 total)
  • Author
    Posts
  • #68977
    LMur
    Participant

    Hi, folks,

    This past week my website suddenly started showing the word “undefined” in place of the hamburger icon that used to be there when I switched to my mobile device (either my iPad or my iPhone).  And at the same time, I found that my menu switches to “undefined” whenever my laptop or desktop browser window is narrowed down to a smaller width on the screen.

    The Guide gives 5 pieces of information around this, and after careful reading and testing, nothing seems to be in there about this.

    Could someone here help me get my hamburger icon back in place?

    Many thanks!

    Leah M (LMur)

    #68978
    scrambler
    Moderator

    Please provide a link to your site.

    In the mean time try temporarily deactivating ALL non weaver plugin, to see if one is interfering

    #68987
    LMur
    Participant

    The link to my site is https://bytesmart.ca.

    I have deactivated all links on my site that are not from Weaver Xtreme, and this did not change anything.

    Leah M.

     

     

     

    #68989
    scrambler
    Moderator

    You menu works, but someone entered “undefined” in the Hamburger menu label option.

    Remove that text in Customizing ▸ Layout > Menus > Layout for all menus > Mobile menu Hamburger label box

     

    #68991
    LMur
    Participant

    I have now done that but nothing has changed.

     

     

    #68992
    LMur
    Participant

    I have also done that in the Weaver Xtreme Admin portal.

     

    #68993
    Weaver
    Keymaster

    Try entering MENU in that field to see it if changes to MENU instead of undefined. I have no idea how the string ‘undefined’ can be displayed unless perhaps there is an unknown or not defined symbol code entered.

    #68994
    scrambler
    Moderator

    Make 100% sure it is empty even of invisible character (yes that happens…)

    On a PC you would click on the box, then click CTRL + A to select all, and delete then save options

    If really empty, then I am at a lost of why the hamburger icon would be replaced by the word “undefined”, may be @weaver will have an idea…

    #68996
    LMur
    Participant

    I have done that several times now, with no change.

     

    #68997
    LMur
    Participant

    I have done this several times without any change.   I have also put other things in there, and it seems like nothing that is put into that field has any effect whatsoever.

    #68998
    scrambler
    Moderator

    If entering a text in the box does not change anything, then something is definitely up.

    And you confirm you tested deactivating ALL non weaver plugins at one.

    Also, please paste here the content of the system Info box in the theme help page

    #68999
    scrambler
    Moderator

    Just to make sure we are not running into a cache issue when you try to enter a text in the hamburger label box, can you do another obvious change at the same time like a background color, and make sure that this other change does show up

    #69000
    scrambler
    Moderator

    OK, You site says you are using XTreme version 1.2.4 !!!!

    This is way obsolete, we are now at 4.4.7

    Please update the theme, as well as the Theme support plugin (v 4.4.5) as well as Plus if you have it

    You also need to update WordPress, you are on 4.2.2 instead of 5.7.2 !!

    Update all the plugins too of course….

    And give us the system info so we can check your PHP version…

    #69001
    LMur
    Participant

    Hi,

    Ok, I am confused:  I have applied every theme update ever since I got the theme and the notificatons of updates required have been coming through to my dashboard.

    Why is it so far out of date when it has been telling me all the way along that the updates have been successful?

     

    #69002
    scrambler
    Moderator

    Something happened that must have blocked update notification, may be because you failed updating WordPress too long, no idea why.

    Try reinstalling over it, or save and download a copy of your settings, then switch to a different theme, then delete XTreme and reinstall and reactivate from WordPress.org.

    Remember to update WordPress as well as all of your plugins, and paste the content of the system info box so we can review and see if you are also behind in PHP version.

    This is what I have

    ### Weaver System Info ###

    — WordPress Configuration —

    Version: 5.7.2

    — Weaver Xtreme Configuration —

    Weaver Xtreme Version: 4.4.7
    Theme Support Version: 4.4.5
    Xtreme Plus Version: 4.0

    — Server Configuration —

    Operating System: Linux
    PHP Version: 7.4.20
    MySQL Version: 5.7.23
    jQuery Version: 3.5.1

     

    #69003
    LMur
    Participant

    Sorry, I’m not buying that:  this is a copy paste of what my dashboard says about my Weaver Xtreme installation:
    <h2 class=”theme-name”>Weaver XtremeVersion: 4.4.7</h2>

    By Bruce Wampler

    <button class=”toggle-auto-update button-link” type=”button” data-slug=”weaver-xtreme” data-wp-action=”enable”>Enable auto-updates</button>

    Weaver Xtreme – One Theme to Design Them All. Weaver Xtreme is the orginal Options-Based WordPress theme, and it is fully Gutenberg ready. Instead of spending hours finding the right theme, with Weaver Xtreme you can create the site. . .

     

    Where did you get the idea that my installation was that far behind?

     

    Leah M.

     

Viewing 16 posts - 1 through 16 (of 28 total)
  • You must be logged in to reply to this topic.