Home Forums Weaver Xtreme Theme Sub menus dont look like the help pages

This topic contains 35 replies, has 2 voices, and was last updated by  weavering 1 week, 3 days ago.

Viewing 16 posts - 17 through 32 (of 36 total)
  • Author
    Posts
  • #56923

    weavering
    Participant

    Let me have a think about that Scrambler

    Is there a way to get all the sub menus (not just the left one) to always start at the left rather than directly below the menu item

    @media (min-width:768px)
    {.menu-primary .wvrx-menu {padding-bottom:70px;}
    .menu-primary .wvrx-menu ul li
    {display:inline-block;
    width: auto;
    height: 35px;
    }
    }

    I’m also having trouble trying to get the post slider (using a category) working on the page!

    #56926

    scrambler
    Moderator

    You can align the sub menu all the way to the left (or anywhere), but you need one rule for each, as their position is relative to their parent.
    The rules below will do the second and third one

    .is-desktop .wvrx-menu #menu-item-1762 ul {left:-300px;}

    .is-desktop .wvrx-menu #menu-item-1762 ul {left:-600px;}

    “I’m also having trouble trying to get the post slider (using a category) working on the page!“

    You need to be more specific here

    #57129

    weavering
    Participant

    I ran through the tutorial

    https://weavertheme.com/plugins/plugin-tutorials/tutorial-create-posts-slideshow/

    using ‘category’ ‘news’ so it would use laready defined posts in the news category

    but it doesnt say what to do at the end to make the slider visible

    I tried adding this short code to the front page

    [show_slider name=create-slideshow]

    But still nothing

    ok i found info on how to make it display at the end of

    https://weavertheme.com/plugins/plugin-tutorials/tutorial-create-image-slideshow/

    the short code is slightly different but works

    [show_slider name=”create-slideshow”]

    #57133

    scrambler
    Moderator

    You can insert any created/saved slideshow in a page content editor by simply clicking the Add show slider button above the editor.

    This will add the slider shortcode of the slider you select in the drop down list with the proper syntax

    #57134

    weavering
    Participant

    thanks Scrambler

    yes I saw those tabs in the image slideshow tutorial but for some reason they didnt appear in the editor

    It may be that I’m confused by gutenburg !

    The  left sidebar top widget news header – do you know why the text colour is different to the other widget headers?

    The widths of the content including sidebars, info bar, menu, and header vary too

     

    #57137

    scrambler
    Moderator

    The  left sidebar top widget news header is different because it is a link

    You can style it with the rule below added to the theme global custom CSS rule box

    #rss-2 h3 a {color:white;}

    The widths of the content including sidebars, info bar, menu, and header vary too

    If you mean they are not the same, this is because of the settings you used.

    In Main options > Full Width > One step layout, you selected “Full width Extend BG to full width.

    This restrict the width of the areas content to your 1100px white extending their background.

    But then you have a larger header image

    Then you have set your menu to have its content extended to full width (stretched) in Main options > Full Width.

    And finally you used Main options > Menus > Info bar > align area > Align Wide that give you yet another width for the info bar.

    You need to explain what layout you are after, and you may want to start by setting  Main options > Full Width > One step layout to “Traditional” so you can control the width of each area with the options below that manually.

    Below is an article that explains the various full width settings

    https://guide.weavertheme.com/full-width-design/

    The important point, is for any given area, not to use both the settings in Main options > Full width and the wide or full width settings found in each area > Align Area drop down list, as they will conflict with each other.

     

     

    #57147

    weavering
    Participant

    re:

    Then you have set your menu to have its content extended to full width (stretched) in Main options > Full Width.

    This option was unticked, but the menu appeared as full width

    I ticked it. Nothing changed

    I unticked it and it changed to normal width

    Magic Scrambler! Theyre all the same width

     

     

    #57150

    scrambler
    Moderator

    You should add some left and right padding to your widget, it does not look good with the content right to the edge

    #57151

    weavering
    Participant

    Let me check that later Scrambler
    By the way I made the content 1170 wide same as the image for now.
    Or so I thought.

    Everything isnt the same width when I expand the browser width
    The menu is the same width as the content, while the image is the same width as the info bar

     

     

    #57153

    scrambler
    Moderator

    They look all the same to me, you probably have a cache issue. Clear them all.

    I think I know why you removed your widget padding, it was because you could not get their title BG to be full width.

    To do that and have padding, add the rules below in the theme Global Custom CSS Rule box

    .widget {padding-left:2%;padding-right:2%;}

    .widget-title {margin-left:-2%;width:104%;}

    That will create padding and expand the title BG to stay the full width of the widget.

    If you change the padding value, change the margin and width accordingly

    #57156

    weavering
    Participant

    Thanks

    How do I send you an image?

    #57157

    scrambler
    Moderator

    If you mean post here, you have to host the image somewhere online, and insert the URL here

    #57158

    scrambler
    Moderator

    I see your problem now, and it is because you have selected alignwide in the header image align area drop down list (select center), as well as in the Info bar align area drop down list (select left)

    #57159

    weavering
    Participant

    It took a while to find it
    Images>header media (layout)>align header image >center
    fixed the header image width

    spacing widths alignment >info bar >align info bar area > center
    fixed the info bar width

    PS Found
    spacing widths alignment content >width> add side margins     check box to give widgets separation from content

    #57198

    weavering
    Participant

    One more about the post slider Scrambler  🙂
    I was hoping to have the slider make the image from each post fit the slide with the excerpt underneath. The images are being reduced to about half the slide size.
    I also need to go through each post and make the first image ‘featured’ as some are not yet….

     

    #57199

    scrambler
    Moderator

    Setting for the Featured image size are in Main Options > Post Specifics > Featured Image.

    Make sure the appropriate one is set to full size

Viewing 16 posts - 17 through 32 (of 36 total)

You must be logged in to reply to this topic.