Home Forums Weaver Xtreme Theme Stopping the Font Inflation that is occuring on IOS Desktop Browsers

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
  • #17595

    I have developed a nice website using the Weaver Xtreme and it looks great on my Windows 8 Firefox browser. However, when I view it on my MAC Firefox and Safari browsers the menu font and header fonts (h1, h2, h3) are inflated, throwing off the menu alignment (causing it to wrap). I have added -webkit-text-size-adjust: 100%; (and the corresponding -ms, -moz versions) and it still inflates the size. I am using percentages on the font size with the base at 16px. How can the two sets of browsers be sooo different? Is there a way to stop the inflation that I haven’t figured out yet?

    I know all the forums across Google say there is no inflation on desktop browsers but that is not true based on my experience. The website is https://www.mountainhomedetailing.com … view it in a Windows browser then an Apple desktop browser and you can see the difference is significant. Is there something in the Weaver CSS that may be blocking the webkit-text-size-adjust?


     I’m not seeing any significant difference between any Windows browsers and any Mac Browsers. I didn’t look at iOS browsers (not the same as Mac browsers).

    I only get menu wrapping when the desktop browser window is narrow, which is expected and has no solution.

    There does seem to be a slight difference in the wrapping of the body text – slightly larger on Windows.


    Well … I figured out by setting my own font size for the menu items at 20px then the menu looked great on all browsers. I was trying to use a custom size of 1.45 em, which looked great on Windows Firefox but was larger on Apple browsers.


    Hmmm … I am noticing some body wrapping differences as well but they are ‘larger’ on my Mac than on my Windows. I am wondering if my Window browsers are giving me a false reading. It looks good enough for now, though. Thank you for checking for me!


    You may have specific settings in you browser causing the difference.

    You can adjust the menu items spacing to delay the moment it goes on two lines.

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.