Home Forums Weaver Xtreme Theme Split: Visual Tab in Xtreme (WPBakery issues)

Topic Resolution: Resolved
Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #73414
    KatieB
    Participant

    I’m having the same problem, but it doesn’t look like this thread ended with a solution. (direct email?)

    The only way to get the visual tab to work in the classic editor is to disable the Weaver Xtreme theme and switch to one of the default themes.

    #73415
    Weaver
    Keymaster

    As far as we know, the Classic Editor plugin works perfectly with Weaver Xtreme.

    When you open the Dashboard -> Pages (or Posts) list, after installing the Classic Editor plugin, you should see a tag to the right of each title showing if the page is Block or Classic. You are also give a choice to open that page in either editor. When editing the page, there also will be an option to switch editors.

    There is another possibility. Weaver Xtreme supports specific Per Page and Per Posts optoins, one of which is “Weaver Xtreme Options for this Page -> Misc Options -> Disable Visual Editor for this page.”. If that is checked, the visual editor tab is disabled. The point of this option it to allow custom HTML in a page to be easily edited and not escaped out on a visual page.

    #73417
    scrambler
    Moderator

    I have no problem accessing the visual and text tab using the classic editor plugin on Xtreme.

    If you do, the issue may lay elsewhere.

    Make sure all the page editing page options are checked in the screen options at the top.

    Try deactivating All non weaver plugin to see if that fixes the problem, and if so reactivate one by one

     

    #73420
    KatieB
    Participant

    Thank you so much for responding to this. I’ve been having a terrible time. I’ve been using Weaver for 10 years. I usually use it with the SiteOrigin Page Builder but this client wanted Elementor, which I absolutely loathe… We agreed to use WPBakery Builder. It was working perfectly for the first three months, and then all of a sudden, the text block editor stopped allowing me to edit in the visual tab. I have Classic editor installed, but it doesn’t show up as an option in the page list like you mentioned. See screenshot below.

    Page Edit Options

    Here is another screenshot of what it looks like when I try to edit the text block editor.
    (Note: this screenshot also shows the other suggestion you made regarding the unchecked option under Misc Options in Weaver Extreme Options. You can see “disable visual editor” is not checked.)

    Weaver Misc Options

    Lastly, I tried deactivating all of the other plugins, but nothing allows me to see the visual tab except when I deactivate Weaver Theme and switch to a default theme like Twenty-Twenty-One. See this screenshot of what it looks like when the text block does work.

    (I contacted WPBakery and they told me to contact you guys because they think it’s a theme compatibility issue.)

    Weaver Theme Disabled and Text Block Works

    #73421
    Private Reply
    KatieB
    Participant
    This reply has been marked as private.
    #73422
    User
    Moderator

    @KatieB

    I think the solution was to make sure the “Disable the visual editor” box was not selected:

    In WP Admin > All Users > Users

    Select user > Edit

    Personal Options > Visual Editor > □ Disable the visual editor when writing

    Regards!

     

     

    #73423
    KatieB
    Participant

    Thank you again for responding. I have tried that. Please see screenshot.

    User Settings

    #73424
    Weaver
    Keymaster

    Hi,

    I went to your demo page, and have concluded it is all due to WPBakery. It seems to interact badly with both  the other activated page builders, and the Classic Editor plugin.

    I found a WPBakery setting that had disabled the Gutenberg editor. After unchecking, the Visual tab will show up again, but does nothing. The Text view still works. This makes some sense to me as all the page builders and the Classic Editor need to intercept the “standard” WP editing path, and it would be easy to step on another plugin’s logic depending on the order these interceptions happen.

    So I think you will have to take this problem up with WPBakery as I don’t see anything that could be caused by the theme.

    #73434
    KatieB
    Participant

    Yeah…. now that I think about it, the issue did start when I added the SiteOrigin Widgets. (WPBakery doesn’t really offer much in terms of widgets.)
    Thanks anyway for your help.

Viewing 9 posts - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.