Home Forums Weaver Xtreme Theme Split: big issue with 4.4.0.1

Viewing 16 posts - 1 through 16 (of 19 total)
  • Author
    Posts
  • #65815
    beethoven
    Participant

    I don’t understand waht is happening with my last message which seems to have desappeared.  So again my asking for help :

    On the site fncta-midipy.fr I want to replace the recent-posts widget with a text widget with a show posts shortcode that looks identically
    The recent posts widget is on top of the sidebar on the homepage and I put the show posts widget on the botttom of the sidebar, so you can see both. The content is the same but fonts are different and the read more is different. How can I make them the  same (the show posts widget the same as the recent posts widget) ?

    #65817
    scrambler
    Moderator

    Sometimes the Forum blocks post with a link, and @weaver is having a hard time fixing the issue.

    The read more message can be changed in the SHow Post filter options, see the continue reading option box

    For the Styling here are the rules that will change what you need. they will go in the Theme Global Custom CSS Rule box

    .atw-show-posts-schema .post-title {font-variant:small-caps;font-size:100%;}
    .atw-show-posts-schema .post-area {color:brown;}

    If the filter gets a different name, you will need to change the first rule selector to reflect the nem name

    #65821
    beethoven
    Participant

    Merci beaucoup @scrambler for the two rules (the exact color is #5E0A0A) My last problem is with the read more message. Even if I change it in Show posts options, there is a lot of space before and after, if you compare with the recent posts widget.
    If you take the first port Stage Le Monologue, the read more in the recent text widget is … at the end of the excerpt without linebreak.
    With the show posts widget there are  tree points (without link) a line break, the read more
    The solution could perhaps be to have no read more at all but I don’t know how to do that ? Perhaps there is also too much space between the posts ?

    #65822
    scrambler
    Moderator

    Two solutions
    hide the more message link with the rule below, but the only link to the post will be the title
    .atw-show-posts-schema .more-link {display:none;}

    Or put three dots in the read more message box, then Hide the dots from the excerpts and format with the rules below.
    That will give you three dots with a link

    .atw-show-posts-schema .excerpt-dots {display:none;}
    .atw-show-posts-schema a.more-link {tex-align:left;display:inline;}

    #65837
    beethoven
    Participant

    Thank you very much @scrambler, the second solution is the nearest to the original and I tried it. It works but not entirely. Two things :

    If you compare the posts in the widget, the three dots are sometimes ok and sometimes not at the end of the text and with a blank space between the text and the dots ?

    How can I reduce the blank space under each post

     

    #65840
    scrambler
    Moderator

    This is caused by some excerpts being shorter than the word cutoff and some being above.

    When the excerpt is shorter that the word count, the paragraph is closed at the end of the excerpt, causing the paragraph margin to create a gap. When it is longer, the paragraph contains both the excerpts and the more message creating no gap.

    The rule below should fix the issue

    .atw-show-posts-schema .entry-summary p {margin-bottom:0;display:inline;}

    #65859
    beethoven
    Participant

    My last message has disappeared ! It said :

    Formidable, trop fort ! It works fine. I added a line-height: normal; to your css and now the show posts widget looks the same as the recent posts widget, with just a detail :

    In the recent posts widget, there is a fine line under each excerpt. In the show posts widget, the line appears only under two excerpts : “Europe connection” and “Projet Théâtre jeunes pour l’année 2020-2021” (both approximately in the middle of the widget).

    Can you help with that ?

    #65863
    scrambler
    Moderator

    The line above and below the post “Projet theatre jeunes…” in the show post shortcode comes from the sticky posts styling.

    Undo the sticky property for that post and it will go away.

    If you want a line at the bottom of each posts and only in the showpost, then modify the previous rule I gave

    .atw-show-posts-schema .post-area {color:#5E0A0A;line-height:normal;}

    and make it

    .atw-show-posts-schema .post-area {color:#5E0A0A;line-height:normal;border-bottom: 1px solid black;}

    If you still want to keep the post as sticky, but want to eliminate the sticky styling in the show post, then use the rule below

    .atw-show-posts-schema .sticky {border:none !important;padding:0 !important;}

     

    #65882
    beethoven
    Participant

    Thank you again.

    I undid the sticky property and added your firt rule, changing black with #CCC which is the color in the recent posts widgetdd

    I added also : .atw-show-posts-schema .post-area {margin-bottom:0.3em;} (it was 1em) to reduce the space between the posts (and I’m proud to have found it out by myself )

    Now a very last question : In the recent posts widget, there is a little space between the text and the bottom line (4 or 5 px I think). I tried different things to have the same in the show posts widget but it did not work. How can I do that ?

    #65883
    scrambler
    Moderator

    If you mean you want space under the last line, add bottom padding to the last rule

    .atw-show-posts-schema .post-area {margin-bottom:0.3em;padding-bottom:5px;}

    #65889
    beethoven
    Participant

    I added the rule and it works fine . Thank you very much. The recent posts widget is forgotten. You remember, this widget was causing trouble with xtreme 4.4.0.1 so I had to reverted to 4.4.3.9 . So, I upgraded another time to 4.4.0.1 and now I have this :

    <b>Notice</b>: Constant WP_POST_REVISIONS already defined in <b>/datas/vol1/w4a130541/var/www/fncta-midipy.fr/wp-config.php</b> on line <b>11</b>

    What now ?

     

    #65890
    scrambler
    Moderator

    No idea, may be @weaver will know more.

    Did you delete the recent post plugin completely?

    #65892
    beethoven
    Participant

    Yes I did. Tomorrow morning I’ll try deactivating all plugins and reactivate them one by one

    #65893
    Weaver
    Keymaster

    There is no instance of WP_POST_REVISIONS in any Weaver Xtreme code – any version.

    There is no such version of Weaver as 4.4.3.9, so I’m assuming you mean 4.5.9? But at any rate, I simply cannot understand why there would be any difference between the two versions of the theme, and finding that definition in the wp-config.php file.

    Normally, wp-config.php is never updates when you upgrade/update WordPress itself as it has all the critical definitions to make WP work – like the databas connection. So I don’t know which plugin might have added it, or which plugin might have tried to create is own defintion. But is is not Weaver.

    One solution would be to use your cPanel file editor and delete the instance from wp-config.php. That will almost certainly remove the error message. But it is really beyond my ability to try to figure out what plugin is causing the message. I’m just certain that it is not Weaver Xtreme or Xtreme Plus.

    Purpose of WP_POST_REVISIONS is to set how many edited revisions of pages/posts to keep in the database. So it is also possible that you added the definition yourself at somepoint. It is actually a normal way to set that value. The error message means that some other code (probably a plugin) is trying to redefine the value itself. But due to how definitions of constants like that work in PHP, you can’t try to define a value more than once. No code should ever do that if the value is already defined in wp-config.php, and to do so is a programming error.

    #65895
    beethoven
    Participant

    I ment 4.3.9 of course.

    the message is WP_POST_REVISIONS already defined in <b>/datas/vol1/w4a130541/var/www/fncta-midipy.fr/wp-config.php</b> on line <b>112</b>

    If I I delete the line 112 in wp-config.php, no more message

    If I deactivate all plugins but the weaver plugins, the message is still there

    If I deactive the weaver plugins too, the message is still there

    If I change the theme to twenty  twenty or twenty nineteen the message disappears

    If I revert back to xtreme 4.3.9 everything is OK

    So there must be an issue with 4.4.0.1

    The problem is not only the message. The admin of the site doesn’t work

    Actually, the line 112 from wp-config.php is deleted. But if you want I can put it back and give you an admin access

    I hope you can help

    #65896
    beethoven
    Participant

    One more thing : I use the spiffy calendar plugin and it doesn’t work correctly anymore (with or without the line 112). I wrote them too

    I hope this issue will be corrected soon. When not, I’ll have to revert to 4.3.9.  to make the site working and that cannot be a real solution

     

Viewing 16 posts - 1 through 16 (of 19 total)
  • You must be logged in to reply to this topic.