Home Forums Weaver Xtreme Theme Spacing in Gutenberg

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #65262
    MaryAhern
    Participant

    I’ve just started working on a test page in gutenberg and having difficulty figuring out how to tighten up the spacing. I set the columns to 3 across & the images were far too small so I reduced it to 2 columns. The images are bigger but still too much space.

    Is the column spacing controlled by the weaver theme since I can’t seem to get it looking tightly no matter how much I play around with the actual image settings.

    The vertical spacing is too much as well.

    Any advice on this please?!

    Thanks, …mary

    Here’s the page link: https://maryahernartist.com/test/

    #65263
    scrambler
    Moderator

    Blocks have their own styling, exposed or not with block settings.
    That said, the theme does apply some default styling.

    For example, the theme adds margins with the rules below
    #content [class^=wp-block-] {margin-top:1.2em;margin-bottom:1.5em;}
    figure {margin:1em 40px;}

    You can add these rules in the theme Global Custom CSS Rule box with smaller or zero values to override the default ones and reduce the spacing.

    #65266
    Weaver
    Keymaster

    This seems to me that perhaps we need to study some of the spacing styling used by various blocks, and perhaps provide some block specific spacing options. Most of the color and typography options already will apply to blocks, but I think the spacing rules are often overridden by the .wp-block-whatever rules. Hopefully, this might be a useful addition to Weaver Xtreme 5 next year.

    #65268
    MaryAhern
    Participant

    So is this something that I can add someplace to adjust the spacing?

    “For example, the theme adds margins with the rules below
    #content [class^=wp-block-] {margin-top:1.2em;margin-bottom:1.5em;}
    figure {margin:1em 40px;}”

    Where is the theme Global Custom CSS Rule box? And do I cut and paste this portion of code into it and play around with the em settings?

     

    #65271
    scrambler
    Moderator

    Either in Appearance > Xtreme Admin > Main options > Fonts & Custom > Custom CSS Rule box

    or

    Customizing ▸ Custom CSS > Global Custom CSS

    Paste the rules and change the values to your own (like zero)

    make sure you don’t paste any weird character like quotes and such as any syntax errors will likely break the CSS.

    If it does not work, post back while leaving the rules in

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.