Home Forums Weaver Show Posts & Show Sliders Space above atw show posts in sidebar

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #18179
    Maureen
    Participant

    On this site: http://www.cscmpchicago.org/10-15-15-northstar-aerospace-plant-tour-and-presentation/   I am using atw show posts short code for the Upcoming Events posts.  I cannot remove the extra spacing above the post. Seems to consist of a paragraph associated with ate-show-posts. Not spacing issues with single post page.

    Using Weaver Extreme  with Extreme Plus,and WP 4.3
    Thanks!

    #24220
    scrambler
    Moderator
    You appear to have an empty top meta info line.
    To eliminate it completely, check the option in the Filter setting to “hide Top Post Meta Ino”
    #24221
    Maureen
    Participant

    Thanks Scrambler.  The option box is already checked.  It shows up in the short code parameters : 

    [show_posts post_type=post category_name=upcoming-events excerpt_length=30 order=ASC posts_per_page=-1 show=excerpt hide_bottom_info=true hide_title=true hide_top_info=true]

    I also hid it under Main Opts/Post Specifics/Hide to post info. No change. I also tried changing the space after Title under Content and Post Specifics tab, but nothing changed.

    #24222
    scrambler
    Moderator
    Well you must have done something, because the top meta info line is now gone and the space too. If you still see the big space, clear your cache.
    The only small space left is the default margin on h3 Northstar Aerospace Plant Tour and Presentation
    h3{font-size:1.500em;margin-bottom:.417em;margin-top:.833em}
    Nor sure if you are creating the h3 in your content or if it is auto formatting.
    Let me know if you need to reduce the top margin of that h3
    #24223
    Maureen
    Participant

    I cleared the cache in both Safari and Foxfire and the space continues to appear in the side. Can you tell me what browser you are using that shows the space in the sidebar tightened up?

    I also changed the text I formatted from h3 to h2 with no change, and tried another show post filter and had the same spacing issues. I checked my CSS+ boxes to see if I added something there, and the Advanced Head Section in case some CSS carried over after I converted from Weaver Pro II to Weaver Extreme.

    I un-hid the the title in the show post filter to try to get a better feeling for what it is I need to change. 
    There continues to be a large space above and below the show post.
    #24224
    scrambler
    Moderator
    I was not looking at the sidebar…
    The space in the recent post in the sidebar between the title and content comes from some empty paragraph tags between the title and the content, as well as the top of the content.
    I am not sure how these are getting in.
    First thing to do is check the content of your post content and excerpt if using manual excerpts. Switch to text mode and remove all extra line returns.
    Eventually check Allow Raw HTML and scripts to prevent WP from doing autoformatting
    #24225
    Maureen
    Participant

    I checked the post content in the text tab and there are no paragraph or extra returns. Enabled Allow Raw HTML and all looks good there.

    Tried with/without Featured Img. Deleted the filter and re-did it. Still the same: large spacing issue in the sidebar.
    #24226
    scrambler
    Moderator
    I am not sure what is going on then.
    First thing to do is deactivate ALL plugins (except Show post, Xtreme Theme support and plus) and see if that fixes it. If it does, reactivate one by one to find the culprit.
    Next would be to create a test page and place the same show post shortcode in it to see if it behaves differently there.
    #24227
    Maureen
    Participant

    I figured it out!  

    I created a test page as you suggested, placed the short code in a new widget area, saved and checked out the page — NO EXTRA SPACING!

    I compared the test page widget against the published page widget. On the published page I had checked the “Automatically Add Paragraphs” on the bottom of the widget. I unchecked it and all is good.  

    Such a simple thing. Oh well, no pain  —  no gain.  :”>

    P.S. Thanks for hanging in there with me, Scramblerl.
    #24228
    scrambler
    Moderator

    AHAHH !!! 🙂

Viewing 10 posts - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.