Home Forums Weaver Xtreme Theme Social Icon Replacement not Replacing

Topic Resolution: Answered
Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #70274
    Answered
    GR8FL
    Participant

    I have followed instructions here: https://guide.weavertheme.com/social-icon-replacement-or-addition/ and reviewed two other sites that already have my own set of icons replacing the icon, and yet the images don’t change. I even used the URL for a published icon from another site, and it is still showing the stock icon for cart and codepen. 🙁

    Clearly, I am missing something obvious.

    This is a test site, so I will publish the URL in the next post that is hidden.

    Thank you.

     

    #70275
    Private Reply
    GR8FL
    Participant
    This reply has been marked as private.
    #70276
    scrambler
    Moderator

    Can you be specific about what rule(s) you used and where you placed them?

    #70277
    GR8FL
    Participant

    In CSS:

    .genericon-cart::before {
    content:””;
    display:block;
    width:32px;
    height:32px;
    background:url(https://test-imc.littledropup.com/wp-content/uploads/Subscribe-32-BW.png) center no-repeat;
    background-size:contain;
    }

    In Weaver Plus Social Buttons: Set the URL and Social Site Description under Cart.

    In Weaver Admin > Main Options > Menus > Menu Bar Right HTML : [social font_size=32 color=#000000]

    It brings up the cart icon. The link URL and the link description is what I put in. The icon is the cart, not the one I uploaded.

     

    #70278
    Best Answer
    scrambler
    Moderator

    This reply has been accepted as the best answer.

    Your CSS file is broken, you opened a comment at the beginning (/*) but did not close it properly, as you used the same opening (/*) insteadof a close (*/), so all the CSS rules are treated as comment

    /*.is-desktop #wrapper {margin-top:120px;}
    #inject_fixedtop .content-2-col {overflow:visible;}
    .is-mobile #inject_fixedtop {display:none;}

    .content-2-col {padding:0;}
    .is-menu-desktop .menu-alignright {padding-right:0;}

    #inject_fixedtop :nth-of-type(1).content-2-col {width:50%;}
    #inject_fixedtop :nth-of-type(2).content-2-col {width:50%;}/*

    Change the blue /* by */ and it will work

    #70279
    GR8FL
    Participant

    That stuff is so old… have no idea if I am even using it. I removed the entire section you highlighted, and it works fine.

    I have old eyes and didn’t see that.

    Thank you.

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.