Home Forums Weaver Show Posts & Show Sliders Slider Size Percentage Width Setting stopped being obeyed

Topic Resolution: Resolved

This topic contains 12 replies, has 3 voices, and was last updated by  Weaver 4 months ago.

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #61252

    RayHand
    Participant

    I’m using WordPress 5.2.2–en_GB with Theme Weaver Xtreme Version 4.3.1.5 Options: Version 38 (Subtheme: Plain White-V-38 – maybe no longer supported) and plugins Weaver Show Sliders Version 1.4.10 and Weaver Show Posts Version 1.3.16 (details below). My Sliders are all slideshows of Media Library images, and one of the Slider options (Slider Width Percentage) is now ignored. I WAS doing some non-Slider Customising and, because it worked OK before but doesn’t now, I admit that I MUST have accidentally changed something I didn’t mean to. Whatever Slider option width is set however, the slide show now displays to the full width of the container (in my case a regular web or post page). The slideshow on the home page is set to have a width of 25% (and floating right) and the one on this venue hire page is set to be 80% (centred) – but both fill the full container width.

    I’ve meticulously compared every Weaver Xtreme Theme Customising value with those on another web site I maintain which also uses the same Theme (but Options Version: 3 Subtheme: Antique Ivory-V-3 – also maybe no longer supported) and the same Plugins. The only differences I can find are in Typography and some minor tweaks to Sidebar/Widget Areas Spacing Widths and Alignments. On the working web site, percentage widths are honoured correctly. The really bizarre thing is that on the problem site, one slideshow – the one on this weddings page displays at the correct (75%) setting – although the surrounding faint border line does go to the edges (which it didn’t beforehand). N.B. You’ll see many other 100% slideshows on the site, but most are intended to be that wide.

    Please could you suggest where I might have gone wrong? I could send you screen shots of the “venue hire” (80% width) Slider Settings if they would help.

    Many thanks – Ray

    System and Configuration Info for the problem site:

    ### Weaver System Info ###

    — WordPress Configuration —

    Site URL: https://friendsofabingdon.org.uk/wp2016
    Home URL: https://friendsofabingdon.org.uk
    Multisite: No
    Version: 5.2.2
    Language: en_GB
    WP_DEBUG: Disabled
    WP Memory Limit: 40M
    Permalink: /%postname%/
    Show On Front: page
    Page On Front: Welcome (ID# 6)
    Page For Posts: (ID# 0)
    Current Theme: Weaver Xtreme (4.3.1.5)
    Post Types: post, page, attachment, revision, nav_menu_item, custom_css, customize_changeset, oembed_cache, user_request, wp_block, ai1ec_event, wpcf7_contact_form, cookielawinfo, atw_slider_post

    — Weaver Xtreme Configuration —

    Weaver Xtreme Version: 4.3.1.5
    Theme Support Version: 4.0.3

    — Server Configuration —

    Operating System: Linux
    PHP Version: 5.6.40
    MySQL Version: 5.5.62
    jQuery Version: 1.12.4-wp
    Server Software: Apache

    — PHP Configuration —

    Local Memory Limit: 128M
    Server Memory Limit: 128M
    Post Max Size: 8M
    Upload Max Filesize: 16M
    Time Limit: 14400
    Max Input Vars: 1000
    Display Errors: N/A

    — WordPress Active Plugins —

    All-in-One Event Calendar by Time.ly: 2.5.41
    All In One SEO Pack: 3.2.1
    Broken Link Checker: 1.11.8
    Contact Form 7: 5.1.3
    Contact Form 7 Honeypot: 1.14
    Custom Recent Posts Widget: 2.1.1
    File Away: 3.9.9.0.1
    GDPR Cookie Consent: 1.7.8
    Optimize Database after Deleting Revisions: 4.8.1
    Page Links To: 3.1.2
    UpdraftPlus – Backup/Restore: 1.16.16
    Weaver Show Posts: 1.3.16
    Weaver Show Sliders: 1.4.10
    Weaver Xtreme Theme Support: 4.0.5
    WP Edit: 4.0.4
    WP Lightbox 2: 3.0.6.2
    WP Like button: 1.5.0

    — WordPress Inactive Plugins —

    Google XML Sitemaps: 4.1.0

    #61254

    scrambler
    Moderator

    I think that is indeed a bug as I can reproduce it. If I specify a slider with less than 100%, it always shows at 100%.

    The one you think work does not, it is also set to 100% but I think images are smaller

    @weaver will have to have a look.

    #61258

    Weaver
    Keymaster

    I am unable to reproduce this problem – my sliders are generated with the specified width, and display correctly.

    I did notice that the output html of your site does not include the inline <style> block the show slider plugin normally generates for each slider. That is where the width is specified. I don’t know why it might be gone.

    I don’t see any plugins that might be causing this.

    I might be able to help if you saved your slider and filter settings for these slide shows. Zip the two files (.slider and .filter) into a single .zip file, and email theme to [email protected], and I’ll see if I see anything wrong.

     

    #61267

    RayHand
    Participant

    Weaver (Keymaster): Thanks for your quick reply. I’ve replied to your email and sent you the zip file you requested. I hope it helps, and I look forward to your findings.

    #61270

    RayHand
    Participant

    Bruce Wampler: In reply to your email…

    In what follows, I’m using <> brackets instead of square ones because square ones don’t render as desired on these pages.

    If I understand your <gallery> question correctly, I think the answer is Yes. To make things clear, I create my slideshows using a sequence I copied from your documentation some time ago. It is now in my “idiot’s guide” as follows (this is an actual example that I’m trying as I type these notes in):

    Create the Slider Post as follows:

    • Upload slide show images to Media Library
    • Create new Weaver Slider Post with name e.g. XXX (but don’t click Publish and don’t close editor window)
    • Click Add Media > (select Media Library tab) > Create Gallery > (select desired images)
    • Click Create a New Gallery > Insert Gallery
    • Back on the New Weaver Slider Post page click Publish

    Define a Slider to display the Slider Post as follows:

    • Select Weaver Posts and Slider Options – and select the Sliders tab
    • Enter name XXX (same as for the Post) and click Create new Slider
    • Under Required Options I normally use: Slider Type = Fader, Slider Paging = No Paging, Slider Content = Show Slider as images, Slider Filter = Default with Quick Options Slider Post Slug = xxx (from drop-down list)
    • Other options are: no prev/next nav buttons, Background Border = #000000 at 1px, Slider width = 50% centred
    • Standard (preset) settings of Image size from Media Library = full, Visual Effects = Swing – both are left as they are.
    • Click Save Slider Options

    I then insert the shortcode, in this case <show_slider name=xxx> into a page – update the page, then display it and… it displays full width.

    If you want more info, please ask. Good luck.

    #61271

    Weaver
    Keymaster

    I will check on my system what happens when using a gallery in a Slider Custom Post type.

    #61273

    RayHand
    Participant

    I’ve found the original Weaver page that I use to create a slideshow involving the use of <gallery ids=”n1,n2,n3,…”> and using the default filter in combination with the “Quick Option” option, as described in by previous message. It is:

    https://weavertheme.com/plugins/plugin-tutorials/tutorial-create-image-slideshow/

    #61278

    Weaver
    Keymaster

    I can’t figure out anything to do that can re-create your scenario.

    I would try to recreate your frontpage and carousel Slider definition from scratch. Then use a slider post with a gallery specified as the target in the short code on the page that is supposed to show the slide show….

    #61279

    scrambler
    Moderator

    And I though I had reproduced it, but I was wrong, it works for me too

    #61280

    RayHand
    Participant

    Many thanks for your efforts so far, but I’m sorry – this time I don’t understand what you want me to try. At the moment, my Home page slideshow shortcode is <show_slider name=frontpage> where frontpage is the slug for a slider post that is <gallery ids=”50,49,48,47,46,45,51″>

    Does your posting on August 7, 2019 at 21:17 UTC refer to something you’re going to try or something I should try? If the latter then…

    Can I assume you mean I should user “New Weaver Slide Post” to create a slider post from scratch – thereby producing something like my <gallery ids=”50,49,48,47,46,45,51″> above? Can I also assume I should then use “Weaver Posts & Slider Options” to create a slider with various options (inc % width) thereby producing a shortcode something like my <show_slider name=frontpage> above?

    If you want me do the latter with Slider options: 50% width; Slider Filter = Default Filter; and Quick Options Slider Post Slug = Slider Post Slug; then that’s what I did in my posting of August 6, 2019 at 20:46 UTC. That gave the same full-sized slideshow.

    If you want me to do something different, please outline the steps you want me to follow – and sorry for sounding a bit stupid.

    #61283

    Weaver
    Keymaster

    That’s all – just reproduce the Slider settings on a new slider definition. Try the same slider post with the gallery shortcode.

    If that fails, then try a new slider post and the same gallery shortcode.

    If that fails, the last resort would be to create an admin account for weaver using [email protected], and I can try to look directly. I will be unavailable until early next week, however.

    Fortunately, your sliders don’t really look bad the way they display now – a full content width doesn’t look out of place or anything, so I don’t think it is urgent (important, not urgent) to figure this one out.

    #61308

    RayHand
    Participant

    Sorry for delay – been busy all weekend until now, and you won’t believe what I’m about to say. I opened my WordPress site to try out your suggestions, and there were four plugins which needed updating – All In One SEO Pack, All-in-One Event Calendar by Time.ly, Contact Form 7, and WP Like button. The first three were active, the fourth not, but I updated all four anyway. Just out of curiosity, I then clicked “Visit Site” and – see for yourself – everything is working as originally intended and as originally designed.

    I honestly honestly hadn’t touched a thing since my last posting – apart, that is. from these plugin updates. I don’t understand how any of them could have compromised the Weaver plugins, but I’m pleased it’s working again. My training should have taught me to de-activate everything except the area I was investigating then, if slides worked OK, to re-activate things one at a time to find if anything external WAS causing the problem.

    Anyway, I got on the phone to a colleague who uses the All-in-One Event Calendar by Time.ly plugin on one of her websites, and she told me she’s had trouble with it (of a different but equally unfathomable kind) and had changed to a different plugin. I know it’s not proof enough to return a guilty verdict, but it taught me a lesson I really should have remembered.

    So let me apologise for the time you’ve spent on this non-Weaver issue. If you don’t want any further info, please close this ticket – or let me know, and I will close it.

    Once again, many thanks – Ray

    #61309

    Weaver
    Keymaster

    Normally, we try to remind users to deactivate other plugins when we get puzzling results.

    I really don’t understand what any of the plugins you have listed could be doing that might be stripping <style> tags from your code.

    Actually, now that I think about it, I think I can explain the problem – and it was likely a bug in a plugin.

    Sometimes plugins like Show Sliders (and even themes) need to add <style> statements inline with the generated HTML. The standard [gallery] is another good example of a feature that generates <style> output.

    So another think plugins do is add their own information. An event calendar might do that. They often do that by filtering the code output by the theme right before it is actually generated using various programming tricks. But WordPress wants the really final output code to be “sanitized” to remove possible hacks to the generated output. And the core WordPress provides special filter code that removes such possible hacks. The standard filters WILL remove <style> blocks. So some plugin must have tried to sanitize the output HTML, and thus stripped the required <style>. So the updates must have fixed this broken behavior, and the <style> blocks came back.

    But, we should have suggested disabling plugins earlier in this discussion.

Viewing 13 posts - 1 through 13 (of 13 total)

You must be logged in to reply to this topic.