Home Forums Weaver Xtreme Theme Site title in primary menu bar

Topic Resolution: Answered
Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #66153
    Answered
    Caetlyn
    Participant

    I’m a little perplexed about something. I’ve just added my site title to my primary menu bar and I have the menu bar background colour set at opacity of 50%. ¬†Everything seems to work okay except for the fact that the background colour for the site title which is still at 100% opacity.

    I noticed that it says to style the site title, I need to use the Header Title font family, bold, and italic setting. Yet, when I go to the Site Title/Tagline under the Header tab, I’ve already set the background colour to transparent.

    What am I doing wrong?

    #66154
    scrambler
    Moderator

    Please provide a link to your site…

    #66155
    Caetlyn
    Participant

    The link is as follows:

    Home

    #66157
    Best Answer
    scrambler
    Moderator

    This reply has been accepted as the best answer.

    Well, it took me a while to figure out what was going on.

    The problem is that when setting the background with the theme option, that color is applied to the menu bar and the site title, which caused the opacity to double down.

    The rule is

    .menu-primary .wvrx-menu-container,.menu-primary .site-title-on-menu,.menu-primary .site-title-on-menu a {background-color: rgba(0,0,0,0.6);}

    I think weaver did not plan for an rgba color, if so he should probably have used

    .menu-primary .wvrx-menu-container {background-color: rgba(0,0,0,0.6);}
    .menu-primary .site-title-on-menu,.menu-primary .site-title-on-menu a {background-color: transparent;}

    Now the solution for you is to add the rule below to the theme Global Custom CSS rule box to remove the color from the site title and container

    .menu-primary .site-title-on-menu,.menu-primary .site-title-on-menu a {background-color: transparent;}

    If it does not work, try adding !important

    .menu-primary .site-title-on-menu,.menu-primary .site-title-on-menu a {background-color: transparent !important;}

    or post back with the rule in place

     

    #66158
    Caetlyn
    Participant

    That worked perfectly. Thank you!

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.