Home Forums Weaver Xtreme Theme showhide shortcode not showing correct show/hide text

Topic Resolution: Resolved
Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #68895
    dillon
    Participant

    I’m using the showhide shortcode here: https://www.innerresourcing.co.uk/about/

    (Scroll down to the section headed “How I got to here”)

    I’ve specified the show text as ‘reveal’ and the hide text as ‘hide’ but as you’ll see, when you first load the page it continues to show the little plus icon, when you show the text it changes to the correct “hide” but when you do hide it again, instead of the word ‘reveal’ it displays the url of the plus icon.

    If I remove the show/hide text modifiers and just have the little +/- icons, it doesn’t do this.

    I had no end of trouble getting it to work at all, it was just inserting the + and – icons but not hiding the text. It is now at least hiding the text, but it doesn’t look great with the url showing….

    Please help!

     

    #68897
    scrambler
    Moderator

    Please give us the details of the shortcode you used so we can check your syntax

    It should look something like

    [showhide start='hide' show='Reveal' hide='Hide'] content [/showhide]

    #68899
    dillon
    Participant

     

    Here’s what it looks like:

    [showhide show='reveal' hide='hide']

    Content to be hidden

    [/showhide]

    #68901
    scrambler
    Moderator

    Are you 100% sure, because if I paste your shortcode on a test page, it works just fine.

    You may have some invisible formatting character that are corrupting the shortcode.

    Copy paste your shortcode from your last post just before the existing one and see that it works.

    If it does, then move your content in the working shortcode and delete the other one.

    #68926
    dillon
    Participant

    Thanks @scrambler. I realised I could use the “edit block as html” option to see what else was there and it’s got several  “code” tags appearing in it randomly 🙂

    So clearly that’s not right! When I delete all those extraneous tags, it works fine.

    Thanks for your help.

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.