Home Forums Weaver Show Posts & Show Sliders [Show Posts] on sidebar: excerpt showing on front page, but not on blog pages

This topic contains 6 replies, has 3 voices, and was last updated by  Weaver 5 months ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #59551

    Balrog
    Participant

    On the right sidebar of https://www.vofoundation.org/blog/, under Recent Posts, I’m using [show posts] with an excerpt, and it’s displaying fine. If you click into any blog post, when on the blog page, the excerpts under Recent Posts no longer show.

    I’m using the Weaver Xtreme theme for the site – the home page is a “Page with posts,” set to show excerpts.

    #59552

    scrambler
    Moderator

    @weaver will have to look into this

    #59553

    Weaver
    Keymaster

    I must not understand your issue.

    If I open your home page, I see the excerpted posts in the main area (left), and the recent posts in the right.

    If I open a post, either from the main content block, or from the right column, it opens the full post on the single page view, and the recent posts are still displayed in the right column.

    #59555

    scrambler
    Moderator

    @weaver,

    Open his page

    In the sidebar, the recent post show with excerpts.

    Click on the title of a post in the sidebar.

    The new page shows the single post in the content area

    BUT the recent posts in the sidebar no longer have an excerpt showing, just title and meta info lines

    #59559

    Balrog
    Participant

    I’m using [Show Posts] in a Custom HTML widget to display Recent Posts. On the front page (a page with posts, showing excerpts) the Recent Post excerpts in the widget display fine. If you click into a blog post, the Recent Posts sidebar widget now shows everything except the excerpt.

    #59562

    Weaver
    Keymaster

    I just didn’t 100% understand the issue. I can (not) see the missing excerpt. I won’t be able to check this out for a few days as I’m on the road without access to my dev machine.

    #59565

    Weaver
    Keymaster

    Did you try to use the Show Posts widget instead of the Custom HTML widget?

    I cannot duplicate this issue on my test site.

    But, just to be sure I really understand your issue.

    From what I understand, the issue is with viewing the excerpts on the Recent Posts [show_posts] in the right sidebar from the Single Page view of any post.

    You open a post originally displayed on any page on the site to the single page view, and the sidebar doesn’t show the excerpts. The original source of the post to open in the single page view is irrelevant as far as I can tell. It is only when displayed on the single page view that the recent posts displayed in the sidebar fail to show the excerpts.

    Are you using a Show Posts filter to create the shortcode? Could you post the exact format of the shortcode you use? e.g.

    Shortcode using parameters: [show_posts posts_per_page=5 show=excerpt]

    That might help diagnose the issue.

    Also, the output from the Appearance : Weaver Xtreme Admin : Theme Help : Your System and Configuration Info could help.

    You can post that info in a Private reply if you are concerned about revealing any info.

     

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.