Home Forums Weaver Show Posts & Show Sliders Show Posts Filter

This topic contains 3 replies, has 2 voices, and was last updated by  scrambler 2 weeks, 2 days ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #62054

    Xtivity
    Participant

    I have three categories of posts: Camps, Services, News.

    In the primary sidebar, I inserted a widget “weaver showpost”. If I use filter as “Camps” or “Services”, I am getting the filter ok. But if I select “News”, I am getting “all” the posts, instead of only the “News” posts. Why is this particular category not filtering…

    by the way – If I create a “page with posts” and put a short code “[show_posts category_name=”News”], it works fine.

    Strange…The widget does not seem to filter. And only happening with one category of posts….What could be the problem..

    Thanks for your time..

     

     

    #62056

    scrambler
    Moderator

    if news is selected from a dropdown list it is strange indeed.

    I would start by renaming your news category to test (no capital) and see if that fixes it.
    If it does rename to news and if it works rename to News.

    #62058

    Xtivity
    Participant

    After several hours, I figured what the problem is…

    1. Add a new Post. Add a new category to the post: News. Save
    2. Go to “Weaver Posts and Slider Option” –> click on Filter tab –> in the first box –Current filter –> add a new filter “News”. Save
    3. In the same page go to –> to Categories. Select “News” from dropdown. And in the corresponding field type “category_name=News” . Save
    4. Then finally go to the Widget and in the dropdown –>, Select a post, –> select “News”. Save

    This solves my problem. However I am not sure if I have ever done the extra steps 2 and 3…

    #62060

    scrambler
    Moderator

    You should not have to type anything, just selecting the category and hitting save should do.

    May be you forgot to hit the save button last time you created the filter.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.