Home Forums Weaver Xtreme Theme Show post with flex or equal height

Topic Resolution: Resolved
Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #70946

    I wonder if it would it somehow be possible to get show-posts to somehow populate into the Flex Columns Widget, rather than displaying posts in standard columns, or would that be barking up the wrong tree?  My problem with show-posts in columns is that the result appears in unequal heights.  I would like to obtain a result similar to Amnesty International’s page:


    I have trouble “taming” those pages with rows of posts in columns (example:  https://mindfulness-israel.org/about/) and getting headings to stay above the boxes.


    There is indeed no way to have Sho post flow in the flex columns.

    The way your reference site is doing it is simply by setting a minimum height for each post that is longer that the longest post.

    To do that on your page, add the CSS rule below to the theme Global Custom CSS rule box (adjust the height value to what you need)

    .home .post-area {min-height:400px;}

    It will help your maintenance of the site if you try to have fixed excerpt length and image size.

    For the post title, Check all the options that are available for the position of the featured image in Customize (in WHERE mode) > Post Specifics > Featured Image > Featured Image Excerpt posts > Position of the Featured image.

    To get the post title above the featured image just use “with Content Top”



    That’s a simple and elegant solution.  Thanks.  I should have thought of it.

    Regarding the headings, it was not the post title that bothers me, but the heading I use to precede each of the show-posts sections.  I have tried to use the obvious <break clear=”all”> but that doesn’t always work for some reason: if the row isn’t fully populated, sometimes the heading scoots down parallel to the posts.  I will next try to use the new block editor for the home page.  That might do it where I fail with the classic editor.


    It’s ok.  In the block editor I used a “spacer”  and that seems to fix it.

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.