Home Forums Weaver Xtreme Theme Search Page all jacked up!

Topic Resolution: Resolved

This topic contains 16 replies, has 3 voices, and was last updated by  scrambler 3 weeks, 3 days ago.

Viewing 16 posts - 1 through 16 (of 17 total)
  • Author
    Posts
  • #60555

    Patti
    Participant

    I have searched The Guide & this forum & I am not finding the answers that will make my search page work. My website’s at https://historyswomen.com. In the upper left sidebar, you’ll see a search box. If you type in “Mary Bowser” (the name of a woman that deserves to be known for her place in history) you’ll see what I mean when I wrote my subject line. It hasn’t always been like this. It used to work just fine! I have also never changed any of the code in the editor for this site. But I haven’t a clue how to fix it & I sure hope someone can help me with it. Thanks in advance, Patti

    #60556

    scrambler
    Moderator

    When I type that it finds a link called Mary Bowser that goes to its page.

    Unless you are using a specific search plugin, the search is done by WordPress, so I am not sure what the issue is, but it has nothing to do with the theme.

    #60557

    Patti
    Participant

    Dang! I had hoped it was something that ya’ll could help me with. I’m not using any type of “search plugin”, so I guess I need to figure out how to create a search page with WordPress.

    #60558

    Weaver
    Keymaster

    Actually, your Search Results page (which is a separate page) is totally broken. I you try to look at the search results page’s html source code, you get very strange results.

    I don’t know why as the rest of your site pages seem to work.

    You don’t seem to have a child theme.

    Did you try any editing of the search.php code in the theme/weaver-xtreme directory?

    Have you installed some kind of enhanced seach plugin?

    #60559

    Weaver
    Keymaster

    Follow up.

    I tried some other searchs. So it does seem you do have some kind of search plugin installed tha shows a drop down scrolling list of things to search for.

    That has to be the problem. You will need to contact that plugin’s authors for support.

    #61132

    Patti
    Participant

    I already told you, in the first comment I sent you that I have never changed the code for the search page (or any page) directly in the Weaver Xtreme editor. I have deactivated the plugin that you spoke of but that didn’t make any difference with the search page results! They’re still jacked up!

    The issue is that there are some of the women who are listed in more than one category. So when you do a search for one or more of them, all of their names should show up & they’re not showing up. Including a brief summary of their article.

    No, I don’t have a child theme set up, because I haven’t needed one. I’ve been using the WeaverX “Fonts & Customs” to change any code that I’ve needed to change.

    But I know you’re going to tell me it’s a WordPress issue so I’ll go figure out how to create a search page with them.

    #61133

    Weaver
    Keymaster

    When I looked at your page before and used the search box at the top of the left sidebar, it behaved as if it was being controlled by a plugin. When I typed in a name, it would open a results box below the actual search box. There was a bit of a delay, but it did show results when I typed in one of the names I found on a page or post (I don’t really remember exactly how I determined a valid name to enter, but it worked). It actually seemed to be a nice little search result with added information.

    So, what that means to me is that the search results being displayed were totally controlled by that plugin. The normal search box was overridden by that plugin.

    And the only other way to add a search box to a sidebar is to use the Search widget. While the theme adds styling to the search box, it has absolutely nothing else to do with how the Search works. Normally, it will result in a new page being displayed with the results of the search.

    So, in fact, the whatever search results you get are totally independent of the theme. That’s just how it works.

    #61158

    Patti
    Participant

    The sidebar search widget is what I’m using & have been all along. However, can you explain why the only thing that shows up on my search page is the header? There aren’t any sidebars, no menu below the header & no copyright at the bottom of the page. Where did they go? How do I get them back?

    #61159

    scrambler
    Moderator

    When I do a search, the search page has the header and the menu below it.

    if you dot, then something may be up on your system. Clear your caches and check other browsers / computers.

    Sidebar for the search page is a configurable option in Main options > Sidebar & Layout > Sidebar Layout > Search result, what do you have in there?

    Now you are indeed missing the footer so something is going on there. The last element in your page is an Image with the ID wpstats and some pinterest URL.

    Try deactivating ALL non weaver plugin and see if that makes a difference. If so, reactivate one by one to find the culprit.

    #61164

    Weaver
    Keymaster

    Just to be clear – are you using a plugin to add a search function with more features to your sidebar?

    But what is happening is that there is a bug in the search code. I’m pretty sure it is not coming from the theme.

    But I have a suggestion that might help.

    To help debug why the Search Results page is crashing, from your hosting control panel, open the wp-config.php file and find the setting

    define('WP_DEBUG', false);

    and change it to

    define('WP_DEBUG', true);

    That should cause an error message to be displayed when the Search Results crashes. That should idenitify where the issue really is.

    Unfortunately, I will not be available to follow up on this until next Tuesday. But I suspect that you will see the name of your search plugin show up in the error results.

    #61173

    Patti
    Participant

    I don’t have that search plugin anymore. I deleted it on July 25th. However, I did as you suggested with the wp-config.php file and it resulted it two lines of errors at the very top of my entire website. I changed the text back from “true” to “false” before I took a screenshot of it so I could show it to you. I did that because you said you’d be gone until next Tuesday. Not sure where to go and/or what to do about this search page mess but I guess I’ll try to find some answers via the WordPress community.

    #61174

    Weaver
    Keymaster

    You should be able to simply copy/paste the error messages and post them here.

    #61176

    scrambler
    Moderator

    So can you give us the errors?

    Also, have you actually tried to deactivate ALL non weaver plugins?

     

    #61218

    Patti
    Participant

    It’s not worth giving you the errors, because once I started deactivating the plugins, I found the one that was the culprit. It was called “Sociable.” So now my search page works again.

    One last question, though. I don’t know where to change the font size, that shows up in the ribbon, on my search page. If you look on this page: https://historyswomen.com/1st-women/aspasia/, you’ll see the font that I want to use on my search page. I’ve looked through the WeaverX settings and am not finding a way to change that font size. Any help would be appreciated!

    #61220

    scrambler
    Moderator

    If you mean the pick ribbon below “Search Result For” you target the text with the rule below

    .archive-info {font-size:100%;}

     

    #61224

    Patti
    Participant

    Yes, that’s the font that I mean. Your code didn’t change anything. However, when I changed it to 75% it worked out perfectly! Thanks for all of your help! My search page now looks like it’s supposed to!

Viewing 16 posts - 1 through 16 (of 17 total)

You must be logged in to reply to this topic.