Home Forums Weaver Xtreme Theme search missing in header

This topic contains 10 replies, has 3 voices, and was last updated by  scrambler 3 months, 2 weeks ago.

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #53303

    dosolutions
    Participant

    Perhaps it is the subtheme, but I cannot get the search option to show up in the header. Yes I checked that “Hide search on header is set to Do Not Hide.

     

    Any ideas?

    #53304

    scrambler
    Moderator

    Please provide a link to your site

    #53314

    dosolutions
    Participant
    #53317

    Weaver
    Keymaster

    I believe the search bar is hidden behind the menu – you must have added rules to move it (either the menu or the search).

    You also added some custom rules for the search – apparently trying to fix the problem. None of theme are doing anything because you would need to add “#header ” in front so the theme’s #header based rules don’t override yours.

    One is really wrong (dispay:yes is not a valid value), but probably not needed.

    If this isn’t enough, I imagine @scrambler can dig in more.

    
    
    #53318

    scrambler
    Moderator

    You created your header using the header widget area, you have no header image, so your header is empty and therefore there is no space for the header search to show up.

    If there is a reason for using the header widget area instead of a regular header image for your banner, then you should add a search shortcode to the heard widget area.

    We could use some custom CSS to force the header search to artificially show up, but I think the above would make more sense

    If using the search shortcode in the header widget area, you can use the following to style it like the default header search

    https://guide.weavertheme.com/search-bar-advanced-customizations/

     

    #53323

    dosolutions
    Participant

    So… when I add a header image it looks like crap, because it is stretched out full width. I do not want the image to look like crap.

    Have a look if you need to see what I mean. Yes, the search icon is back.

    But I would like search to show up without a header image, just the widget image I have. I like it sliding in… like it does now.

    I will try adding a search short code, if I only know what it was…?

    -Daniel

    #53326

    scrambler
    Moderator

    There is an option so the header image does not get stretched…

    It is in Main options >  Header > Header Image > “use Actual Image size” option

    That will keep the header image whatever size it has, and allow the header search to show up

     

    #53339

    dosolutions
    Participant

    If I had the plus version I would do that.

    #53340

    dosolutions
    Participant

    Can you tell me the search short code please.

    #53362

    Weaver
    Keymaster

    If you have the Weaver Xtreme Theme Extras plugin installed AND Weaver Xtreme Plus, you can find the instructions on the Dashboard : Appearance : Weaver Xtreme Admin : Add-ons tab.

    #53363

    scrambler
    Moderator

    Add the Rule below in Main options > Fonts & Custom > Custom CSS Rule box, it will prevent the header image from scaling up

    #branding #header-image img {width:auto;}

    Sorry the search shortcode is also a plus option…

Viewing 11 posts - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.