Home Forums Weaver Xtreme Theme Search blog posts

Viewing 16 posts - 1 through 16 (of 32 total)
  • Author
    Posts
  • #65417
    lostinspace
    Participant

    Using Weaver Xtreme for my website and have posted articles that I’d like to be searchable (by tags and/or titles).  At this point all one sees are the titles and featured image.  Can you help someone who is somewhat mystified by where to begin?  Many thanks in advance.

    #65418
    scrambler
    Moderator

    I am not sure I follow.

    Are you saying your posts only show the title and featured image and not its content or excerpt?

    If so, this is an option you set. Where it is depends what method you used to create your blog page.

    If you created you blog page using a page based on the “page with posts” template. there is an option in the page editing to display post as excerpts or full or title and featured image..

    If you not what you meant, please elaborate and provide a link to the page illustrating the issue.

    #65419
    lostinspace
    Participant

    Thanks so much for your quick response.  Here’s the page for my “articles of interest”:  https://www.hvpi.net/category/articles-of-interest/

    I’ve disabled comments.  The page is a kind of reference library (of sorts). I need some way for folks to search for the articles they want to view based on tags or some other kind of listing.  I see how to add tags, but I don’t know how to enable a listing of the tags or the articles.  My WP skills are very limited.

    #65420
    scrambler
    Moderator

    If you want on page interactive filtering, then you will need a plugin for that.

    You can have a look at one called Search & Filter

    Below is an article that shows how to use it

    https://www.wpbeginner.com/plugins/how-to-let-users-filter-posts-and-pages-in-wordpress/

     

    #65421
    lostinspace
    Participant

    The plugin is great (thanks to you Scrambler!), but I need to redo the poor way that I set up my posts.  I mistakenly had set the link on my homepage as a category rather than a “page with posts”.  When I try to set up a  “page with posts” the preview shows my default page structure all messed up.  My left sidebar moves to the right and causes the page to look ridiculous.  I assume that I’m going about this process all wrong.  I’d be happy to pay someone to straighten it out for me so that I have a landing page for blog posts rather than landing on a category page.

    #65422
    scrambler
    Moderator

    Yo create a page with post do the following

    • Create a new page
    • Select the template “page with posts” and publish so you can see the options.
    • Set all your display options using the Xtreme Options for this page tabs.
      There you have general layout option like sidebars and visibility of key pieces.
      You also have how to display post, which one, layout, content….
    • Next Make sure you are not using the WordPress default blog page by going to the dashboard > Setting > Reading
    • Make sure home page is set to display as “a Static page”
    • Make sure nothing is selected in the Post page drop down list, showing “select”

    After all that if there are things that are not quite like you want and you are not sure how to change them, post back with a link to the post page

    #65432
    lostinspace
    Participant

    Beautiful.  Now I have some work to do organizing.  Not sure if I’ll use the Search & Filter plugin.  My only issue at this point is that the posts (and the plugin if I use it) wind up a bit further down the page than I’d like. Thhere’s a gap between my top nav buttons and the first posts or search bar.   Is there a setting somewhere for that?

    #65433
    scrambler
    Moderator

    Please provide a link to the page so we can be sure of the solution

    #65436
    lostinspace
    Participant
    #65437
    scrambler
    Moderator

    First you have an empty infobar that takes space.
    Hide it in Main Options > Menu > Info bar > Hide area

    But mostly, you seem top have added a 180px top padding to the content area via some custom CSS (below)
    #content {
    padding-top: 180px !important;
    background-color: #e5e5e6;
    min-height: 880px;
    margin-top: -50px !important;
    position: relative;
    }

    So you need to reduce the 180px value to something more appropriate.

    I am not sure where this custom CSS is coming from.
    You can check the Theme Global Custom CSS Rule box and check if you see it there

    #65439
    lostinspace
    Participant

    Sorry, but I don’t know where to find these:  “Main Options > Menu > Info bar > Hide area”  NOR  “Theme Global Custom CSS Rule box.

    #65440
    scrambler
    Moderator

    On your site dashboard > Appearance > Xtreme Admin > Main Options > Menu > Info bar > Hide area

    and

    site dashboard > Appearance > Xtreme Admin > Main Options > Fonts and Custom > Custom CSS Rule box.

    It looks like you have quite a bit of custom CSS on your site, if you did not create that, who did?

    Are you using a plugin for content creation?

    #65442
    lostinspace
    Participant

    The look of the site was originally set up by an individual in India for a fee.  This was several years ago.

     

    Hiding the info bar doesn’t seem to change anything.  When I went to “Fonts and Custom > Custom CSS Rule box”  I found the following:

    /* —- Custom CSS for the Go Basic Subtheme. These rules make the Continue Reading and next/prev links buttons. —- */
    .more-msg {background:#606060; border-radius: 8px; border:1px solid green;padding:2px 5px;margin-left:1%;}
    a.more-link {color:white;margin-top:4px;font-size:85%;white-space:nowrap;}
    a.more-link:hover {color:#ddd;text-decoration:none;}
    /* — end of Go Basic Custom CSS — */

    #65443
    scrambler
    Moderator

    Look in
    Dashboard > Customizing ▸ Custom CSS > Additional CSS – WP Settings

    If not there, I think they have added a CSS style sheet somewhere, but I am not quite sure where it is


    @weaver
    , on the site https://www.hvpi.net/articles-of-interest/
    It looks like someone added a CSS stylesheet
    <link rel=’stylesheet’ id=’wp-add-custom-css-css’ href=’https://www.hvpi.net?display_custom_css=css&ver=5.4.2&#8242; type=’text/css’ media=’all’ />

    Can you tell if it is generated by a plugin, or if it was manually added to the site and if so where (the ? in the link confuses me)?


    @lostinspace
    , until Weaver can tell us more, you can add the rule below to Dashboard > Customizing ▸ Custom CSS > Global Custom CSS. That should override the existing rule

    #wrapper #content {margin-top:30px !important; padding-top:0 !important;}

    But you need to go through all the pages of the site, to check if that space works globally

    #65445
    lostinspace
    Participant

    I found it in Add Custom CSS>Main CSS>CSS Rules.

    There’s a lot there…and I have no experience with CSS, only HTML.

    #65447
    scrambler
    Moderator

    Look for the rule below

    #content {
    padding-top: 180px !important;
    background-color: #e5e5e6;
    min-height: 880px;
    margin-top: -50px !important;
    position: relative;
    }

    then change the padding-top to zero and the margin top to 30px or any value that works for you.

    After you change it it should look like

    #content {
    padding-top: 0px !important;
    background-color: #e5e5e6;
    min-height: 880px;
    margin-top: 30px !important;
    position: relative;
    }

    Then go through all the pages of the site, to check if that space works globally

Viewing 16 posts - 1 through 16 (of 32 total)
  • You must be logged in to reply to this topic.