Home Forums Weaver II Theme Weaver II Pro Save menu not working

This topic contains 7 replies, has 4 voices, and was last updated by  Maureen 1 month ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #53652

    pbedouk
    Participant

    Hi

    I’ve done something which has broken the ‘Save Menu’ button on the appearance>menus page.

    After clicking it goes to a ‘Sorry, no such page’ page. The old menu remains unchanged (thankfully!) so the site continues to work, but I can’t change anything at the moment without the save menu option!

    website is veronalions.ca

    weaver pro version 2.2.3

    wp version 4.9.4

    How can I fix this?

     

    Thanks

     

    #53654

    scrambler
    Moderator

    This is 100% WordPress, no not sure what happened.

    Regular things to try.

    Deactivate ALL non weaver plugins and see if that makes a difference

    Redo the last WordPress update from the dashboard > Update in case Some WordPress file became corrupted

    #53655

    pbedouk
    Participant

    Thanks … reinstalling and disabling plugins didn’t work.

    I’ll rebuild the menu and try again.

    Thanks for your response!

    #53922

    pbedouk
    Participant

    Hi again,

    I’ve tried disabling plugins, reinstalling wordpress and rebuilding the menu and variety of other shots in the dark. I contacted the wordpress support forum and the response from there is that it’s a theme issue.

    more details on the particulars. After backing up, I activated the 2015 theme and succeeded to modify the navigation menu in preview mode. I went back to the weaver theme and could not modify the menu (when ‘save’-ing it says page not found).  then I tried that in the 2015 theme and could not add any menu items there either. Not sure what to do next. Any help would be greatly appreciated!

    #53925

    Weaver
    Keymaster

    Try re-installing WordPress from the Dashboard -> Updates menu. There may be something corrupted in your installation.

    If you are getting the same results with 2015, then the issue is certainly not theme related, but more likely either a plugin or a host configuration issue.

    If it is a plugin, you should try to disable ALL of the plugins, and see if you can then edit the menu. Then re-enable the plugins one by one until it breaks again.

    With all plugins disabled, a fresh install of WordPress, and using a Twenty-something theme, there should be no issue with editing your menu definitions.

    #53926

    pbedouk
    Participant

    Thanks again.

    Here is what I did and the results:

    1. Deactivated all plugins
    2. re-installed WordPress 4.9.4 from dashboard > updates > re-install now … successful
    3. using weaver theme: create a custom menu item (#,test), click ‘add to menu’, click ‘Save Menu” … page not found
    4. switch to 2015 theme: create a custom menu item (#,test), click ‘add to menu’, click ‘Save Menu” … page not found
    5. using weaver theme or 2015 theme: from the appearance > menu > manage with live preview created same custom menu item, published and added successfully! the test item is in the navigation menu as it should be.

    Bizarre.

    You mention a host issue? can you point me in some direction there? It all used to work flawlessly.

    Since I get the exact same results with weaver and 2015, that would suggest it is a wordpress issue?

    #53930

    Weaver
    Keymaster

    Having both themes get the same page not found result means it is not a theme issue. Having the plugins deactivated means it is not a plugin issue.

    I’ve never heard of this issue before. I don’t know what the issue might be. Given it is not anything widely reportd for WP, and having installed an updated WP, it sort of implies some issue with your host.

    The only things I cant think of is either an old version of PHP or some other “safety” issue added by your host.

    Sorry, can’t be much more helpful than that.

    #53972

    Maureen
    Participant

    I just looked at   http://veronalions.ca/#,test      and I can see the page and it looks exactly like your home page.

    Your test page —   #,test  —– seems to be the problem.  Look for a duplicate  page in your list of pages.

    Or go to the text tab and copy and past the html onto a new page and name TEST  without comma or hash tag.

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.