Home Forums Weaver Xtreme Theme Removing primary widget from Woocommerce category pages

Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
    Posts
  • #74698
    Caetlyn
    Participant

    How does one remove the primary widget from these pages? No matter what I do, the primary widget remains. If I change the archive layout to No Sidebars, the widget ends up at the bottom of the post. Here’s an example:

    https://www.craftylion.com/product-category/sound-effects/

    #74699
    scrambler
    Moderator

    This is the primary widget area indeed and these are archive pages.

    Have you deactivated the sidebar for archive pages in the global sidebar and layout settings?

    #74700
    Caetlyn
    Participant

    All the archive pages are set to no sidebars content only.

    #74701
    scrambler
    Moderator

    where did you set that exactly?

    #74702
    Caetlyn
    Participant

    In the sidebar layout.

    #74703
    scrambler
    Moderator

    More precisely:

    Appearance > Xtreme Admin > Main Options > SIdebar & Layout > Sid3ebar Layout >

    • Archive like-default
    • Date  / Category / Tags / Author Archive
    • All of them?

    Customizing ▸ Sidebars & Widgets > Sidebar & Widget Area Layout

    • Archive like-default
    • Date  / Category / Tags / Author Archive
    • All of them?

    Have you checked options in Both locations

    Have you try selecting “No sidebar content only” in ALL of the options and see if the issue disappear?


    @weaver
    , in the Archive page she links to above, the primary widget area appears on the page at the bottom. is there any other option that could make that appear on an archive page?

     

     

    #74704
    Weaver
    Keymaster

    I don’t think Woocommerce has a part in this, but I just tested the settings.

    The setting needed to have no sidebars on Archive-like pages is:

    Customizer Where -> Sidebars & Widgets -> Sidebar & Widget Area Layout -> Archive-like Default -> No sidebars, content only

    Xtreme Plus has other options for different kind of Archive pages.

    #74705
    Caetlyn
    Participant

    All the archive sidebars (date/category/tags/author) have been set to no sidebars but just content only. The sidebar does disappear but for some reason it has moved to the bottom of the page. I did try the css code

    .woocommerce-shop #primary-widget-area {display:none;}

    But nothing happened …

    #74706
    Weaver
    Keymaster

    I’ve looked at the html output of that page.

    I don’t know why/when the primary widget area would get generated after the container <div> right before the <footer> area.

    BUT, the page does seem to be interacting with Woocommerce as indicated by some of the output. So it would be helpful to know exactly how the https://www.craftylion.com/product-category/sound-effects/   URL is being generated. Is Woocommerce doing that?

    The /product-category/ sounds like it is coming from Woo, so there might be some glitch between Woo and Weaver when generating that kind of product-category page.

    #74707
    Weaver
    Keymaster

    Also check the setting for Category Archives. I don’t see any way to make it show right before the footer, but that is the only other category and widget area that could have interaction.

    #74708
    User
    Moderator

    @Caetlyn

    You have disabled the right-button operations on the mouse on your sample page.

    Is it possible that you can those settings off for your page for 24 hours?

    Regards!

    #74709
    scrambler
    Moderator

    @user the way to go around that is open the browser, hit F12 to open the browser developer tool, then paste the site URL.

    The site will now be open with the developer tools also opened

     

    #74710
    User
    Moderator

    @scrambler

    Thanks!

    I kept getting a ‘frozen’ page, tho the F12 data worked.

     

    #74711
    User
    Moderator

    @Caetlyn

    I have a suspicion from the above informed comments that there may be a plugin conflict which is causing the issue.

    Please kindly install and try the “Health Check & Troubleshooting” WP plugin to see if anything is interfering with Weaver and Woo .   It should only take a couple of minutes to get confirmation, one way or the other

    Regards.

    #74714
    Caetlyn
    Participant

    The page in question is being generated by Woocommerce as it’s a product category page. I had to disable the right-click function to prevent media theft on my site as much of the media there is copyright protected.

    I’m also using Site Origin’s custom Woocommerce template layout widget which may be the cause of the issue.

    After some thought, I’ve decided not to proceed with Woocommerce as I can’t guarantee the proper working of my site without the plugins I already have installed. Thanks anyway!

Viewing 15 posts - 1 through 15 (of 15 total)
  • You must be logged in to reply to this topic.