Home Forums Weaver Xtreme Theme Reduce Space between menu bar and first line

Topic Resolution: Answered

This topic contains 9 replies, has 2 voices, and was last updated by  GR8FL 4 months ago.

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #59103
    Answered

    GR8FL
    Participant

    How can I reduce the amount of space between the menu bar and the text on the home page? I’m hiding the info bar.

    For that matter, how can I reduce the amount of space between the info bar and the other pages? Especially on mobile, there’s too much blank space.

    See this site.

    Note: I did go back to this post: https://forum.weavertheme.com/forums/topic/reduce-space-between-info-bar-and-first-line/ but neither solution offered helped.

    #59109
    Best Answer

    scrambler
    Moderator

    This reply has been accepted as the best answer.

    First, there is a custom CSS rule (below) adding 20px, remove that

    .home #content {padding-top:20px;}

    next you can reduce the space between Title and content in Main option > Content area > Space between title and content box (put zero in it)

    Last your title is an h2 that carries a 0.66em top margin.  If you have done that with HTML, you can add a style attribute with a zero margin, or you can add the rule below to remove the top margin on all h2

    .home .entry-content h2 {margin-top:0;}

    For the other pages, the only space is the page-title top margin that you can remove with

    .page-title {margin-top:0;}

    #59118

    GR8FL
    Participant

    Thank you.

    #59711

    GR8FL
    Participant

    I’m revisiting this because I think I have it and then I don’t.

    I want the <h2>My Inserted Title</h2> to appear at the same place as the default page title does. It comes much lower.

    When I’ve inserted .home .entry-content h2 {margin-top:0;} nothing changes.

    Take a look at http://demo.littledropup.com/sample-page/ which is not hiding post title and compare to http://demo.littledropup.com/test/ which is using <h2>. If I didn’t have the info bar, it would look acceptable.

    This rule also jams the home page title right under menu bar (no info bar here).

    I also tried combinations of using
    h2 {margin-top:.1em;}
    .page-title {margin-top:0;}

    #59713

    scrambler
    Moderator

    The standard page title (using h1) does not have any top margin.

    So just add a margin-top:0 to your h2

    <h2 class="font-inherit" style="margin-top: 0px;">Sample Test Page</h2>

     

    #59714

    GR8FL
    Participant

    Is there any way to reduce the space further? On my phone it looks too much white space. Same with the title on home page.

    #59715

    scrambler
    Moderator

    There is another 4px top padding on the Content area you can remove with the theme options

    And a 5px bottom [adding on the InfoBar you could remove with

    #Infobar {padding-bottom:0;}

     

     

    #59721

    GR8FL
    Participant

    Even taking out the info bar shows too much space. Is it possible to at least line up the start of the <h2> line with the title of the first widget in the side-bar?

    Home Page – <h2 class=”font-inherit”>The Medicare Specialist</h2> lines up with Widget-1 Title

    Why can’t the other pages?

    And when I hide info bar on all devices – then the sidebar widget is way too high.

    #59723

    scrambler
    Moderator

    For the space I was only looking at the desktop and there was none.
    If it was on other devices then I can have another look.

    If you remove the info bar, you must also remove the custom CSS rule you added to shift the sidebar up…

    .is-desktop #primary-widget-area {margin-top:-10px;}

    If you want the 24H help line to line up with the title, keep the rule and change the value to a positive one that fits

    But I get the feeling I am not seeing what you are seeing so make sure you clear your caches…

    #59738

    GR8FL
    Participant

    I think it’s resolved (with your kind help).

    Thank you.

Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.